Motherboard Forums


Reply
Thread Tools Display Modes

Catalyst 9.5 for Windows 2000 ?

 
 
testeur
Guest
Posts: n/a
 
      05-31-2009, 05:05 PM
Hello,
Is it possible to modify 9.5 XP drivers for installation under Windows2000.
My system is multiboot Windows2000 / XP SP3 and I just installed an HD4770 video only supported by
9.5 drivers, but unfortunately there no version for W2K.
Basic VGA drivers under W2K only offer 640*480*16 resolution ! not usable at all.
I try to change entries WINXP to WIN2K in INF file, but no succes.
Any help welcome.
Thanks

Olivier


 
Reply With Quote
 
 
 
 
testeur
Guest
Posts: n/a
 
      06-01-2009, 11:00 AM
In fact, it was that I already done (mods in INI files, not INF) but when I start driver install I
get an error message saying that there is no Video card supported by this driver version.
I check in registry and the card has the same identifier under XP and W2K :

Under W2K :
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\P CI\VEN_1002&DEV_94B3&SUBSYS_03101043&REV_00\4&d8b1 42a&0&0010]
"DeviceDesc"="Contrôleur vidéo (compatible VGA)"
"LocationInformation"="Bus PCI 1, périphérique 0, fonction 0"
"Capabilities"=dword:00000000
"UINumber"=dword:00000001

Under WXP :
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\P CI\VEN_1002&DEV_94B3&SUBSYS_03101043&REV_00]
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\P CI\VEN_1002&DEV_94B3&SUBSYS_03101043&REV_00\4&d8b1 42a&0&0010]
"DeviceDesc"="ASUS EAH4770 series"
"LocationInformation"="Bus PCI 1, périphérique 0, fonction 0"
"Capabilities"=dword:00000000
"UINumber"=dword:00000001

I do not understand why the driver install does not reconizes this card under W2K

Is there any thing to do more ?

Olivier


 
Reply With Quote
 
 
 
 
DrTeeth
Guest
Posts: n/a
 
      06-01-2009, 08:27 PM
On Mon, 1 Jun 2009 13:00:20 +0200, just as I was about to take a herb,
"testeur" <olivier;(E-Mail Removed)> disturbed my reverie and
wrote:

>I do not understand why the driver install does not reconizes this card under W2K


This site, http://www.laptopvideo2go.com/ uses modified INF files to
install nVidia drivers for cards/chipsets that they were not designed
for. If a card is not recognised, it sounds like the info is missing
from the INF file.

Hope this helps and points you in the right direction.
--

Cheers,

DrT

** Stress - the condition brought about by having to
** resist the temptation to beat the living daylights
** out of someone who richly deserves it.
 
Reply With Quote
 
testeur
Guest
Posts: n/a
 
      06-02-2009, 03:34 PM
To go ahead, I have copied all registery entries related to ATI card from XP to W2K; (services,
control, class)
This way the card is reconized and driver is installed.
But there is an incompatibility from this new driver and W2K kernel
The new driver call "IoGetLowerDeviceObject" in NTOSKRNL that does not exist in W2K version.
So I get a blue screen when the driver is loaded.
I also try to copy VGA.SYS driver from XP to W2K, but I get the same kind of incompatibity problem
with VIDEOPRT.SYS.

Now, I will scan ATI download files to get the latest driver supporting W2K, and try to add HD4770
entry in INF file to see if that works.
What I need is only to set résolution to 1024*780*32, no need for hardware accélération.
I you have another idea, you are welcome.

Olivier


 
Reply With Quote
 
DrTeeth
Guest
Posts: n/a
 
      06-02-2009, 07:20 PM
On Mon, 1 Jun 2009 23:01:59 -0400, just as I was about to take a herb,
"First of One" <root@127.0.0.1> disturbed my reverie and wrote:

>And yes, the HD4770 is already in the INF file:
>"ATI Radeon HD 4770" = ati2mtag_R7X, PCI\VEN_1002&DEV_94B3&SUBSYS_29001682
>"ATI Radeon HD 4770 " = ati2mtag_R7X, PCI\VEN_1002&DEV_94B3


Did you type or copy this? I ask as there is a space in the second
line after the 4770 and before the ".

Thanks for your info.
--

Cheers,

DrT

** Stress - the condition brought about by having to
** resist the temptation to beat the living daylights
** out of someone who richly deserves it.
 
Reply With Quote
 
testeur
Guest
Posts: n/a
 
      06-02-2009, 08:23 PM
No so easy ;
Your proposal cannot work, because if you keep ati2mtag_R7X as entry, you have to provide all
sections related to this entry.
I just try to use the latest ATI W2K supported driver, that is Catalyst 6.2, by adding the HD 4770
line, and replacing ati2mtag_R7X by ati2mtag_R580 , the most recent card supported by this driver
version.
Install go fine, card is detected and driver installed, but after reboot driver cannot start with
code 10. Stuck with VGA 640*480*16.

I read in AMD/ATI web site that they have change driver interfaces since version 9.4 to take account
of new technology for latest GPU as HD 4700 and 4800 series.
So, It is clear for me that there is no way to retrofit any driver to work with HD4770 under W2K.

Remark : "ATI Radeon HD 4770 " is just an external display name of the card, trailing blank is not
meaningful.

I always wait for someone with a solution to run basic VGA driver at 1024*728*32 resolution under
W2K.

Thanks

Olivier


 
Reply With Quote
 
DrTeeth
Guest
Posts: n/a
 
      06-03-2009, 09:05 PM
On Tue, 2 Jun 2009 22:21:18 -0400, just as I was about to take a herb,
"First of One" <root@127.0.0.1> disturbed my reverie and wrote:

>Remember, it takes 42 muscles to frown, and only 4 to pull the trigger...


LOL
--

Cheers,

DrT

** Stress - the condition brought about by having to
** resist the temptation to beat the living daylights
** out of someone who richly deserves it.
 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Catalyst 9.6 vs. Catalyst 9.7 DRS ATI 3 08-02-2009 04:15 AM
VisionTek Retail Box Radeon HD 4870 PCI Express - VisionTek Catalyst - Or- ATI's Catalyst RoadRunner@Not_Here.com ATI 2 03-21-2009 08:57 PM
Question Re:Catalyst Drivers and Catalyst Control Center LouisG ATI 4 01-23-2005 09:20 PM
Catalyst 4.11 and Catalyst Control Center Bill Davis Jr ATI 16 11-21-2004 04:24 PM
To get my Xp 2000 to a true 2000 mhz i have to have a FSB of 160 ? We Live For The One We Die For The One Asus 2 07-29-2003 12:44 AM


All times are GMT. The time now is 01:30 AM.


Welcome!
Welcome to Motherboard Point
 

Advertisment