Motherboard Forums


Reply
Thread Tools Display Modes

continuous beep after power surge tyan

 
 
jakobmetzger@gmail.com
Guest
Posts: n/a
 
      05-19-2011, 12:28 AM
I am getting a continuous beep after a power surge on a Thunder K8SD
Pro (S2882-D) . Everything works fine and I have noticed no actual
changes within the system like ram/cpu issues while running. Is there
a way to disable this or reset it somehow?

http://www.tyan.com/product_board_detail.aspx?pid=127
 
Reply With Quote
 
 
 
 
Paul
Guest
Posts: n/a
 
      05-19-2011, 05:40 AM
(E-Mail Removed) wrote:
> I am getting a continuous beep after a power surge on a Thunder K8SD
> Pro (S2882-D) . Everything works fine and I have noticed no actual
> changes within the system like ram/cpu issues while running. Is there
> a way to disable this or reset it somehow?
>
> http://www.tyan.com/product_board_detail.aspx?pid=127


By looking at the manual, I notice the Front Panel Connector (J6)
has two options for audio notification devices.

Connecting a speaker between pins 12 and 18, creates a tone
in the speaker. That implies the SuperI/O or similar,
provides a tone signal suitable for driving, say, s 32 ohm
load. Normally, the SuperI/O provides a logic level signal,
and an external switching transistor switches power from the
+5V rail on and off, to make a tone in a magnetic speaker.
The transistor functions as an amplifier, providing enough
drive for a 32 ohm speaker.

Connecting a piezoelectric buzzer between pins 16 and 18 is
an alternative. I take it, that the buzzer generates the
tone, based on receiving DC power, switched on between pins 16 and
18. So rather than the motherboard generating a tone, the buzzer
does that on its own. In that case, the driving transistor stays
ON or OFF, to achieve tone or no-tone condition.

Now, let's say your enclosure provides a piezoelectric buzzer,
and it is always on. It's a relatively simple fault, for the
power to that buzzer to be jammed in the ON position. There might
be a damaged interface transistor.

If you were to disconnect the buzzer, and use a small speaker instead,
and connect the speaker across 12 and 18, that might still be functional.
(It would be using a different transistor, which might not be damaged.)
If that speaker drive transistor were to be damaged, it either stays
ON or OFF, and no tone is there to continuously annoy you. In the ON
position, the cone would poke out a bit, and OFF, it would be relaxed.
But it would stay fixed in one position or the other, if it isn't
being actively modulated.

If the fault is inside the SuperI/O, and a register bit to enable
the generation of a tone is set, then using SPKR pins might still
result in a tone, but that is a more unlikely fault. If the SuperI/O
was to be damaged, why stop at one bit. Easier for it to just
blow up completely, if a surge was applied across the device. So
I don't buy that as a fault. I feel it's more likely to be
one of the external transistors which got damaged.

One thing about piezoelectric devices, is they "work in both directions".
On the one hand, applying electricity, makes sound. And on the other
hand, compressing or deflecting the piezo material generates electricity.
In the case of a hand-held barbecue starter, for a propane barbecue,
a piezoelectric material in there, generates thousands of volts, and
strikes an actual spark when mechanically excited. In the case of the
inverter in the back of an LCD monitor, some of those use piezo material,
and up to 4000 volts can be created by that material leading to the
cracking of the piezo (if it's over excited). To do damage to your
motherboard "buzzer" pins, all that has to happen is a "back potential"
to come back from that device. It could also be, that whatever surge
you had, somehow induced current into, or followed along the wire pair
leading to the device. (Like a fault raising the potential on Safety
Ground, which is the same potential as the chassis of the computer.)

In any case, you have two I/O options. My interpretation is, you're using
a piezo buzzer right now (rather than a piezo or magnetic speaker), and
changing speaker types may be enough to give you peace and quiet. Take
note of the PANEL pins you're currently using, and switch to a different
kind of speaker and put it across the alternative pair of pins.

The fact you have two options, is quite a feature. None of my motherboards
have that (ability to drive two kinds of beeper).

Paul
 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TH7-II Raid continuous beep Sigfrid the Brave Abit 1 01-22-2004 02:09 PM
A7V133-VM + PCI video = BEEP BEEP BEEP BEEP? Lost Asus 2 11-13-2003 05:33 AM
BE7 - beep , beep beep zero Abit 9 10-07-2003 04:36 PM
Re: Abit KT7A won't boot, continuous beep, ps/2 keyboard not work GlassVial Abit 3 08-22-2003 05:32 PM
Re: Abit KT7A won't boot, continuous beep, ps/2 keyboard not work Homie Abit 0 08-21-2003 08:56 AM


All times are GMT. The time now is 11:19 PM.


Welcome!
Welcome to Motherboard Point
 

Advertisment