Motherboard Forums


Reply
Thread Tools Display Modes

Drivers for ATI Radeon 7500 card ?

 
 
Richard Cox
Guest
Posts: n/a
 
      11-10-2003, 03:18 PM
Hello there,

Yesterday I tried to install the latest ATI drivers on my cousin's ATI
Radeon card- which is the 7500 series.

I went to ATI's site, did the usual thing,

find drives, clicked XP for the OS, then the Radeon family,
then took the latest and ONLY drivers they have listed there.

There is no info about what actual cards the drivers support.

I'm puzzled. After downloading these drivers and installing them,
- upon reboot the computer screen was completely screwed up - the
video was unreadable, and the screen was scrolling like an old TV
screen.

I rebooted into safe mode, and uninstalled the drivers.

Any clue to what I did wrong ?

Before installing these drivers, I downloaded the latest MMC ( version
8.7 I think it was) - I chose the latest one, - installed that, then
installed the Remote software for remote control, - version 2.1

it told me the Remote 21. software could not run because video card
drivers were outdated, so it was at this point that i downloaded the
latest video drivers - ran those, and the problem arose that i
describe above.

Any help is much appreciated.

Richard.
 
Reply With Quote
 
 
 
 
Lateef
Guest
Posts: n/a
 
      11-14-2003, 12:31 PM
On Mon, 10 Nov 2003 10:18:13 -0500, Richard Cox <(E-Mail Removed)>
wrote:

>Hello there,
>
>Yesterday I tried to install the latest ATI drivers on my cousin's ATI
>Radeon card- which is the 7500 series.
>
>I went to ATI's site, did the usual thing,
>
>find drives, clicked XP for the OS, then the Radeon family,
>then took the latest and ONLY drivers they have listed there.
>
>There is no info about what actual cards the drivers support.
>
>I'm puzzled. After downloading these drivers and installing them,
>- upon reboot the computer screen was completely screwed up - the
>video was unreadable, and the screen was scrolling like an old TV
>screen.
>
>I rebooted into safe mode, and uninstalled the drivers.
>
>Any clue to what I did wrong ?
>
>Before installing these drivers, I downloaded the latest MMC ( version
>8.7 I think it was) - I chose the latest one, - installed that, then
>installed the Remote software for remote control, - version 2.1
>
>it told me the Remote 21. software could not run because video card
>drivers were outdated, so it was at this point that i downloaded the
>latest video drivers - ran those, and the problem arose that i
>describe above.
>
>Any help is much appreciated.
>
>Richard.



It sounds like a refresh rate problem with your monitor....
from your description of symptoms.

fixable from display settings dialogue from safe mode though maybe
tricky.
try adapter default.
 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI AiW Radeon 32MB vs. ATI AiW 7500 64MB New Question ATI 2 04-22-2004 07:43 PM
Any known issues with the ATI AIW 7500 Radeon and nVidia chipset drivers? heymikey ATI 1 12-14-2003 07:30 AM
Any known issues with nVidia chipset drivers and ATI All-In-Wonder 7500 Radeon cards? heymikey Asus 0 12-14-2003 03:34 AM
ATI Radeon AIW 7500 drivers??? Bitsbucket ATI 4 11-22-2003 10:33 PM
Drivers for ATI Radeon 7500 card ? Richard Cox ATI 4 11-10-2003 11:59 PM


All times are GMT. The time now is 09:18 AM.


Welcome!
Welcome to Motherboard Point
 

Advertisment