Motherboard Forums


Reply
Thread Tools Display Modes

A nasty display problem on a Thinkpad T20

 
 
Nick E
Guest
Posts: n/a
 
      07-01-2004, 06:31 PM
Since a picture is worth 1000 words, please find below my 3000 word
essay on "A nasty display problem on a Thinkpad T20". I'd appreciate
any input on what the faulty component can be:

1. Inverter card
2. System board
3. LCD display
4. Other

Notice that the leftmost 2 cm of the screen is fine (the fuzziness is
just high compression of the JPG image). Using an external display
works perfectly. So, what do you think is wrong?

I ask because I need to know what to replace. I'll try a DIY job on
this one because IBM won't fix it for me. Sure, my warranty has
expired, but I had the exact same problem "fixed" under warranty less
than a year ago. I don't know what they did to solve it then, but it
worked when I got it back. IBM apparently only has a 3 month guarantee
on repairs.

http://www.entek.chalmers.se/~niclas/DSC01758b.JPG
http://www.entek.chalmers.se/~niclas/DSC01759b.JPG
http://www.entek.chalmers.se/~niclas/DSC01764b.JPG
 
Reply With Quote
 
 
 
 
Quaoar
Guest
Posts: n/a
 
      07-02-2004, 05:08 AM
Nick E wrote:
> Since a picture is worth 1000 words, please find below my 3000 word
> essay on "A nasty display problem on a Thinkpad T20". I'd appreciate
> any input on what the faulty component can be:
>
> 1. Inverter card
> 2. System board
> 3. LCD display
> 4. Other
>
> Notice that the leftmost 2 cm of the screen is fine (the fuzziness is
> just high compression of the JPG image). Using an external display
> works perfectly. So, what do you think is wrong?
>
> I ask because I need to know what to replace. I'll try a DIY job on
> this one because IBM won't fix it for me. Sure, my warranty has
> expired, but I had the exact same problem "fixed" under warranty less
> than a year ago. I don't know what they did to solve it then, but it
> worked when I got it back. IBM apparently only has a 3 month guarantee
> on repairs.
>
> http://www.entek.chalmers.se/~niclas/DSC01758b.JPG
> http://www.entek.chalmers.se/~niclas/DSC01759b.JPG
> http://www.entek.chalmers.se/~niclas/DSC01764b.JPG


4. Other... You are going to have to open the unit anyway, so once you
get in there, first check the connector to the LCD on the mainboard.
You could get lucky and it's loose. If it were the mainboard/video
chipset, the external monitor would not work, unless it is in the analog
signal processing for the LCD, then it's eBay for a board.

Q


 
Reply With Quote
 
 
 
 
G Tom
Guest
Posts: n/a
 
      07-02-2004, 01:24 PM
Ooh! ooh! I had this EXACT same problem on an a20m about a year ago! I
didn't know what was exactly wrong either, but I took a guess and
replaced the LCD panel. Now it works fine! It was about $150. I'm a
big fan of the field service manuals IBM publishes on their website.
That's how I replaced mine.

Good luck!


(E-Mail Removed) (Nick E) wrote in message news:<(E-Mail Removed) om>...
> Since a picture is worth 1000 words, please find below my 3000 word
> essay on "A nasty display problem on a Thinkpad T20". I'd appreciate
> any input on what the faulty component can be:
>
> 1. Inverter card
> 2. System board
> 3. LCD display
> 4. Other
>
> Notice that the leftmost 2 cm of the screen is fine (the fuzziness is
> just high compression of the JPG image). Using an external display
> works perfectly. So, what do you think is wrong?
>
> I ask because I need to know what to replace. I'll try a DIY job on
> this one because IBM won't fix it for me. Sure, my warranty has
> expired, but I had the exact same problem "fixed" under warranty less
> than a year ago. I don't know what they did to solve it then, but it
> worked when I got it back. IBM apparently only has a 3 month guarantee
> on repairs.
>
> http://www.entek.chalmers.se/~niclas/DSC01758b.JPG
> http://www.entek.chalmers.se/~niclas/DSC01759b.JPG
> http://www.entek.chalmers.se/~niclas/DSC01764b.JPG

 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cooo, nasty! MasterBlaster PC Hardware 1 07-10-2004 10:49 AM
nasty problem with geforce2 mx 100/200 Dwe Nvidia 6 05-21-2004 09:59 AM
Nasty framerate on Compaq Armada 100s K. Petropoulos Laptops 1 02-04-2004 12:07 AM
Recovering from a nasty MBR corruption ByteMan Laptops 1 12-31-2003 05:47 PM
Nasty File Remover Chris Murfitt Nvidia 1 11-07-2003 06:22 PM


All times are GMT. The time now is 03:14 AM.


Welcome!
Welcome to Motherboard Point
 

Advertisment