Motherboard Forums


Reply
Thread Tools Display Modes

Problems with X850 and possible best AGP cards

 
 
Phat_Jethro aka Jethro[AGHL]
Guest
Posts: n/a
 
      04-03-2009, 03:57 PM
After a recent LAN party my son's PC has been running like a dog. The
current ATI X850 PE only puts out about 9 fps in TF2. It was running
fine before so not sure what happened.
One "funny" issue is that even after I reinstall it after full driver
cleanup, the "ATI Radeon" tab doesn't show up in the Advanced tab under
Display properties. (When you do a right-click Properties, Settings Tab,
Advanced button)
It's like the video card is not really installed. I show in the hardware
list but just generally runs like crap in games now.

Since his system is an older AMD 939 4200+ on a A8V board which still
has AGP port, I was also wondering what the latest AGP card available
is. From what I can Google I think it's a X1650 Pro? Or maybe even an
HD3650 or HD3850?

J

--
Jethro[AGHL] aka Phat_Jethro
Reply Email: jethro86 (at) gmail (dot) com
 
Reply With Quote
 
 
 
 
Benjamin Gawert
Guest
Posts: n/a
 
      04-05-2009, 03:14 PM
* Phat_Jethro aka Jethro[AGHL]:
> Since his system is an older AMD 939 4200+ on a A8V board which still
> has AGP port, I was also wondering what the latest AGP card available
> is. From what I can Google I think it's a X1650 Pro? Or maybe even an
> HD3650 or HD3850?


HD3850. However, you should be aware that AGP support has a very low
priority for ATI/AMD which means that the AGP versions usually cause
much more troubles than the PCIe versions. I would think twice about
investing any money in such an old AGP system.

Benjamin
 
Reply With Quote
 
 
 
 
Phat_Jethro aka Jethro[AGHL]
Guest
Posts: n/a
 
      04-06-2009, 03:40 PM
First of One wrote:
> "Phat_Jethro aka Jethro[AGHL]" <(E-Mail Removed)> wrote in message
> news:gr5bhd$ee8$(E-Mail Removed)...
>> After a recent LAN party my son's PC has been running like a dog. The
>> current ATI X850 PE only puts out about 9 fps in TF2. It was running fine
>> before so not sure what happened.

>
> Did you disable any ATI startup programs or services previously, like
> ATISmart? If so, re-enable them, for they are somehow tied to basic 3D
> acceleration. You are using XP?


Using XP. Actually it is a fresh install as we also had HDD issues and
started from scratch.

> There should be a SmartGART tab in the control panel. Make sure AGP is
> enabled there.


In the display properties? There is no extra tabs in the Display
properties. When I did a test install of a Nvidia 6600GT it should up in
the display properties.

>
>> One "funny" issue is that even after I reinstall it after full driver
>> cleanup, the "ATI Radeon" tab doesn't show up in the Advanced tab under
>> Display properties. (When you do a right-click Properties, Settings Tab,
>> Advanced button) It's like the video card is not really installed. I show
>> in the hardware list but just generally runs like crap in games now.

>
> Could be any number of reasons...
> - Power cable dislodged from card in transit

removed reinstalled card
> - Disabled startup programs or services

such as?? just did fresh windows install

> - Incorrect BIOS AGP setting

hmmm.. I had upgraded BIOS to last version 0229... did I miss something
I wonder now? Any specific settings?

> - Incorrect driver
> - Virus/worm/trojan

clean windows install

> What drivers are you using?


I think the non-CCC I used was 8.2

>
>> Since his system is an older AMD 939 4200+ on a A8V board which still has
>> AGP port, I was also wondering what the latest AGP card available is. From
>> what I can Google I think it's a X1650 Pro? Or maybe even an HD3650 or
>> HD3850?

>
> HD3850. The Sapphire card Bill linked is pretty good.


Now not being an ATI fanboi, what is nVidia's best AGP (I think 7600
GS?)and how would that compare?


--
Jethro[AGHL] aka Phat_Jethro
Reply Email: jethro86 (at) gmail (dot) com
 
Reply With Quote
 
Tom
Guest
Posts: n/a
 
      04-08-2009, 10:23 PM

Benjamin Gawert <(E-Mail Removed)> wrote in
news:(E-Mail Removed) thusly:

> * Phat_Jethro aka Jethro[AGHL]:
>> Since his system is an older AMD 939 4200+ on a A8V board which still
>> has AGP port, I was also wondering what the latest AGP card available
>> is. From what I can Google I think it's a X1650 Pro? Or maybe even an
>> HD3650 or HD3850?

>
> HD3850. However, you should be aware that AGP support has a very low
> priority for ATI/AMD which means that the AGP versions usually cause
> much more troubles than the PCIe versions. I would think twice about
> investing any money in such an old AGP system.


Really? And, what are those troubles you speak of?

--

Tom

 
Reply With Quote
 
Phat_Jethro aka Jethro[AGHL]
Guest
Posts: n/a
 
      04-09-2009, 02:54 PM
First of One wrote:
> "Phat_Jethro aka Jethro[AGHL]" <(E-Mail Removed)> wrote in message
> news:grd7m5$uto$(E-Mail Removed)...
>> Using XP. Actually it is a fresh install as we also had HDD issues and
>> started from scratch.

>
> Since the board is an A8V, did you install the VIA AGP drivers? If not,
> download and install them:
> http://www.viaarena.com/Driver/VIA_H...nPro_V523A.zip You only need the
> AGP driver (aka miniport driver or GART driver).
>
>> In the display properties? There is no extra tabs in the Display
>> properties. When I did a test install of a Nvidia 6600GT it should up in
>> the display properties.
>>
>> I think the non-CCC I used was 8.2

>
> You installed the 8.2 standalone driver without CCC? Then there wouldn't be
> extra tabs in Display Properties, as ATI stopped bundling the old Control
> Panel with drivers long before 8.2.
>
>>> HD3850. The Sapphire card Bill linked is pretty good.

>> Now not being an ATI fanboi, what is nVidia's best AGP (I think 7600
>> GS?)and how would that compare?

>
> Best nVidia AGP card is the XFX 7950GT AGP. Driver support is flaky because
> only XFX makes them. It is on par with ATI X1900-series cards. The HD3850 is
> *two generations* newer with commensurate difference in performance.
>


Well I did another drivers update. Installed Cat9.2 with full CCC and
Dot Net v2. Finally got a proper tab in the Display Properties -
Advanced settings.
"Seemed" to work well afterwards. I played TF2 and seemed to be getting
40-60 fps. Thought it was all good.
My son went to another TF2 map with more open spaces and Pyros and he
says the performance dropped off and got all laggy. Going to check and
try to get some hard numbers from the net_graph as opposed to a "feeling".

Thanks for all your suggestions.

J
--
Jethro[AGHL] aka Phat_Jethro
Reply Email: jethro86 (at) gmail (dot) com
 
Reply With Quote
 
Phat_Jethro aka Jethro[AGHL]
Guest
Posts: n/a
 
      04-09-2009, 02:55 PM
First of One wrote:
> "Phat_Jethro aka Jethro[AGHL]" <(E-Mail Removed)> wrote in message
> news:grd7m5$uto$(E-Mail Removed)...
>> Using XP. Actually it is a fresh install as we also had HDD issues and
>> started from scratch.

>
> Since the board is an A8V, did you install the VIA AGP drivers? If not,
> download and install them:
> http://www.viaarena.com/Driver/VIA_H...nPro_V523A.zip You only need the
> AGP driver (aka miniport driver or GART driver).
>
>> In the display properties? There is no extra tabs in the Display
>> properties. When I did a test install of a Nvidia 6600GT it should up in
>> the display properties.
>>
>> I think the non-CCC I used was 8.2

>
> You installed the 8.2 standalone driver without CCC? Then there wouldn't be
> extra tabs in Display Properties, as ATI stopped bundling the old Control
> Panel with drivers long before 8.2.
>
>>> HD3850. The Sapphire card Bill linked is pretty good.

>> Now not being an ATI fanboi, what is nVidia's best AGP (I think 7600
>> GS?)and how would that compare?

>
> Best nVidia AGP card is the XFX 7950GT AGP. Driver support is flaky because
> only XFX makes them. It is on par with ATI X1900-series cards. The HD3850 is
> *two generations* newer with commensurate difference in performance.
>


Well I did another drivers update. Installed Cat9.2 with full CCC and
Dot Net v2. Finally got a proper tab in the Display Properties -
Advanced settings.
"Seemed" to work well afterwards. I played TF2 and seemed to be getting
40-60 fps. Thought it was all good.
My son went to another TF2 map with more open spaces and Pyros and he
says the performance dropped off and got all laggy. Going to check and
try to get some hard numbers from the net_graph as opposed to a "feeling".

Thanks for all your suggestions.

J
--
Jethro[AGHL] aka Phat_Jethro
Reply Email: jethro86 (at) gmail (dot) com
 
Reply With Quote
 
Benjamin Gawert
Guest
Posts: n/a
 
      04-10-2009, 05:05 PM
* Tom:
>> However, you should be aware that AGP support has a very low
>> priority for ATI/AMD which means that the AGP versions usually cause
>> much more troubles than the PCIe versions. I would think twice about
>> investing any money in such an old AGP system.

>
> Really? And, what are those troubles you speak of?


For example instability, very low performance and display errors.

Benjamin
 
Reply With Quote
 
Tom
Guest
Posts: n/a
 
      04-10-2009, 10:44 PM

Benjamin Gawert <(E-Mail Removed)> wrote in
news:(E-Mail Removed) thusly:

>>> However, you should be aware that AGP support has a very low
>>> priority for ATI/AMD which means that the AGP versions usually cause
>>> much more troubles than the PCIe versions. I would think twice about
>>> investing any money in such an old AGP system.

>>
>> Really? And, what are those troubles you speak of?

>
> For example instability, very low performance and display errors.


I can certainly understand that there is an AGP bottleneck, but I've
seen no signs of instability or display errors with my Sapphire HD3850
and a Asus P4C800-E Deluxe Motherboard. These "troubles" must depend on
some other factor. Thanks for the info.

--

Tom

 
Reply With Quote
 
Benjamin Gawert
Guest
Posts: n/a
 
      04-11-2009, 03:21 PM
* Tom:

>>> Really? And, what are those troubles you speak of?

>> For example instability, very low performance and display errors.

>
> I can certainly understand that there is an AGP bottleneck,


There is no "AGP bottleneck" which causes the problems.

> but I've
> seen no signs of instability or display errors with my Sapphire HD3850
> and a Asus P4C800-E Deluxe Motherboard. These "troubles" must depend on
> some other factor.


Yes, as I said before they depend on the drivers of which the AGP part
gets rarely updated at all. Simply because AMD doesn't give much on AGP
support any more. In lots of cases the only driver that works stable is
the one that comes with the card and which has been modified by the
board maker, and as soon as the user updates the driver with the generic
AMD Catalyst driver hell breaks loose.

That you don't have any problems is fine for you, however it doesn't
change the fact that the chance of experiencing problems is much higher
with the AGP versions of Radeon HD 2000/3000 series cards than with
their PCIe counterparts.

Benjamin
 
Reply With Quote
 
Tom
Guest
Posts: n/a
 
      04-15-2009, 09:05 PM

In news:(E-Mail Removed) you wrote:

>> I've seen no signs of instability or display errors with my Sapphire
>> HD3850 and a Asus P4C800-E Deluxe Motherboard. These "troubles" must
>> depend on some other factor.

>
> Yes, as I said before they depend on the drivers of which the AGP part
> gets rarely updated at all. Simply because AMD doesn't give much on
> AGP support any more. In lots of cases the only driver that works
> stable is the one that comes with the card and which has been modified
> by the board maker, and as soon as the user updates the driver with
> the generic AMD Catalyst driver hell breaks loose.


I can only offer what I personally have experienced. I did a lot of
reading of reviews before finally purchasing the AGP Sapphire HD3850.

One of the most apparent criticisms of all AGP HD3850 cards regardless
of manufacture was that the supplied drivers on CD were horrible. Nearly
all recommended bypassing the included CD for the ATI Catalyst drivers.

I didn't use the drivers on the CD and instead installed the Catalyst
9.1 drivers directly from ATI/AMD and it worked right out of the box
with my old Intel 875P chipset software that's dated March 25, 2004.

In the case of Sapphire, they don't modify their drivers. The driver
available at the Sapphire site is the same driver that is available at
the ATI/AMD site. That might be a reason to go with the AGP Sapphire
HD3850 over other manufactures.

> That you don't have any problems is fine for you, however it doesn't
> change the fact that the chance of experiencing problems is much
> higher with the AGP versions of Radeon HD 2000/3000 series cards than
> with their PCIe counterparts.


Well, the chance of experiencing problems is much higher if you have a
VIA motherboard.

I can't speak for all situations, but it seems to me that the likelihood
of having problems depends on more factors than only the driver.

--

Tom

 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is a 2x/4x AGP v.2.0 slot compatible with the AGP 4x/8x slot? In other words, are 2x/4x AGP compatioble with 4x/8x AGP Video Cards? NIV Consulting Tyan 1 06-06-2007 11:04 AM
Spiderman3 Not Supporting X850 Cards Kent_Diego ATI 6 05-10-2007 12:41 AM
Radeon X800 X850 AGP in barebones Paul Shuttle 1 01-20-2006 08:38 AM
Any stress test programs for ATI cards? (new x850 pro is crapping out is it the 350 power supply perhaps?) Ernie ATI 1 01-18-2006 09:54 PM
X850 Pro's being sold as X850 XT's? pigdos ATI 17 01-15-2006 11:57 PM


All times are GMT. The time now is 07:50 PM.


Welcome!
Welcome to Motherboard Point
 

Advertisment