1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

adding xvr-100 video card to Sun Blade 2000

Discussion in 'Sun Hardware' started by Solarys, Mar 3, 2009.

  1. Solarys

    Solarys Guest

    Help needed!! I just installed a xvr-100 video card in a Sun Blade
    2000. I can not get video from the dvi connection. I can get video
    from the hd-15 connection. I just purchased the system and it boots
    to a Solaris 10 install. Is that part of the problem? What am I
    doing wrong? Any/all suggestions are welcomed. Thanks in advance.


    Solarys
     
    Solarys, Mar 3, 2009
    #1
    1. Advertising

  2. Solarys schrieb:
    > Help needed!! I just installed a xvr-100 video card in a Sun Blade
    > 2000. I can not get video from the dvi connection. I can get video
    > from the hd-15 connection. I just purchased the system and it boots
    > to a Solaris 10 install. Is that part of the problem? What am I
    > doing wrong? Any/all suggestions are welcomed. Thanks in advance.
    >
    >
    > Solarys


    IIRC, the dvi connector is unsupported by OBP. So you'll need to get to
    the stage, when X gets started. But I don't know for sure, as I never
    tried it myself...

    - Thomas
     
    Thomas Maier-Komor, Mar 3, 2009
    #2
    1. Advertising

  3. Solarys

    Martin Paul Guest

    Solarys wrote:
    > Help needed!! I just installed a xvr-100 video card in a Sun Blade
    > 2000. I can not get video from the dvi connection. I can get video
    > from the hd-15 connection.


    As Thomas said, the DVI port cannot be used while the machine is in OBP
    and before the X-Server comes up.

    The X-Server uses the VGA port by default, too, so you must copy
    /usr/dt/config/Xservers to /etc/dt/config and add "-dev /dev/fbs/pfb0b"
    to the only non-comment line to make it use DVI instead.

    I used to have TFTs with both a VGA and a DVI port, and connected both
    the analog and the digital output to the monitor. Like that, you have
    output both during bootup and later in X.

    hth,

    mp.
    --
    SysAdmin | Institute of Scientific Computing, University of Vienna
    PCA | Analyze, download and install patches for Solaris
    | http://www.par.univie.ac.at/solaris/pca/
     
    Martin Paul, Mar 3, 2009
    #3
  4. Solarys

    Jeff Wieland Guest

    In article <49ad30e2$0$28520$> Martin Paul <> writes:
    >Solarys wrote:
    >> Help needed!! I just installed a xvr-100 video card in a Sun Blade
    >> 2000. I can not get video from the dvi connection. I can get video
    >> from the hd-15 connection.

    >
    >As Thomas said, the DVI port cannot be used while the machine is in OBP
    >and before the X-Server comes up.
    >
    >The X-Server uses the VGA port by default, too, so you must copy
    >/usr/dt/config/Xservers to /etc/dt/config and add "-dev /dev/fbs/pfb0b"
    >to the only non-comment line to make it use DVI instead.
    >
    >I used to have TFTs with both a VGA and a DVI port, and connected both
    >the analog and the digital output to the monitor. Like that, you have
    >output both during bootup and later in X.
    >
    >hth,
    >
    >mp.


    Or you can connect two monitors and use it in double-wide mode. You
    enable that with:

    # /usr/lib/fbconfig/SUNWpfb_config -doublewide enable

    I usually enable the "fake8" mode for the couple of apps that I still
    have around that need 8 bit pseudocolor (one really useless app is
    WABI, which will run under Solaris 10 :) ).

    # /usr/lib/fbconfig/SUNWpfb_config -fake8 enable
    --
    Jeff Wieland
     
    Jeff Wieland, Mar 4, 2009
    #4
  5. Solarys

    Solarys Guest

    On Mar 4, 9:27 am, Jeff Wieland <> wrote:
    > In article <49ad30e2$0$28520$> Martin Paul <> writes:
    > >Solarys wrote:
    > >> Help needed!!  I just installed a xvr-100 video card in a Sun Blade
    > >> 2000.  I can not get video from the dvi connection.  I can get video
    > >> from the hd-15 connection.

    >
    > >As Thomas said, the DVI port cannot be used while the machine is in OBP
    > >and before the X-Server comes up.

    >
    > >The X-Server uses the VGA port by default, too, so you must copy
    > >/usr/dt/config/Xservers to /etc/dt/config and add "-dev /dev/fbs/pfb0b"
    > >to the only non-comment line to make it use DVI instead.

    >
    > >I used to have TFTs with both a VGA and a DVI port, and connected both
    > >the analog and the digital output to the monitor. Like that, you have
    > >output both during bootup and later in X.

    >
    > >hth,

    >
    > >mp.

    >
    > Or you can connect two monitors and use it in double-wide mode.  You
    > enable that with:
    >
    > # /usr/lib/fbconfig/SUNWpfb_config -doublewide enable
    >
    > I usually enable the "fake8" mode for the couple of apps that I still
    > have around that need 8 bit pseudocolor (one really useless app is
    > WABI, which will run under Solaris 10 :) ).
    >
    > # /usr/lib/fbconfig/SUNWpfb_config -fake8 enable
    > --
    > Jeff Wieland- Hide quoted text -
    >
    > - Show quoted text -


    Thanks for ur responses. I will take ur suggestions.

    Solarys
     
    Solarys, Mar 5, 2009
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dhawal Tyagi

    XVR-100 and Blade 100

    Dhawal Tyagi, Nov 19, 2003, in forum: Sun Hardware
    Replies:
    5
    Views:
    370
    Dhawal Tyagi
    Dec 8, 2003
  2. Martin Paul

    xvr-100/xvr-600 console output

    Martin Paul, Sep 30, 2004, in forum: Sun Hardware
    Replies:
    1
    Views:
    387
  3. dougm

    Can I? Blade 1500, XVR-600 + XVR-100?

    dougm, Apr 27, 2005, in forum: Sun Hardware
    Replies:
    2
    Views:
    567
  4. Martin Bochnig
    Replies:
    12
    Views:
    911
    Tim Bradshaw
    May 31, 2005
  5. llothar
    Replies:
    5
    Views:
    249
Loading...

Share This Page