1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Configuring 4-port ethernet card on Ultra-1

Discussion in 'Sun Hardware' started by Henry van Cleef, Jul 23, 2004.

  1. I have a 4-port 501-2062 SQEC/S card that I plugged into an Ultra-1
    200E running Solaris 8 10/01 patched to Generic_117350-04. Did a
    reconfiguration reboot and did a manual ifconfig for qe0 with plumb
    up, and tried to ping the connection. The ping responds through the
    hme0 port, not the qe0 port. I checked cabling, etc.---if I
    disconnect the hme0 cable, things hang and there appears to be no
    activity on my hub lights on the qe0 cable, even reversing the cables
    at the Ultra.

    Checked to see if I have a driver loaded, and if I could see anything
    funny anywhere. What I get are:

    # ifconfig -a
    lo0: flags=1000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index
    1
    inet 127.0.0.1 netmask ff000000
    hme0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500
    index 2
    inet 192.168.1.1 netmask ffffff00 broadcast 192.168.1.255
    ether 8:0:20:a0:aa:24
    qe0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index
    3
    inet 192.168.1.9 netmask ffffff00 broadcast 192.168.1.255
    ether 8:0:20:a0:aa:24
    # modinfo |grep ether
    # modinfo |grep Ether
    71 102d6783 f18a 7 1 hme (10/100Mb Ethernet Driver v1.149)
    104 102abfe2 6512 104 1 qe (Quad-MACE Ethernet Driver v1.80)
    # netstat -nr

    Routing Table: IPv4
    Destination Gateway Flags Ref Use Interface
    -------------------- -------------------- ----- ----- ------ ---------
    192.168.1.0 192.168.1.1 U 1 190 hme0
    192.168.1.0 192.168.1.9 U 1 0 qe0
    224.0.0.0 192.168.1.1 U 1 0 hme0
    127.0.0.1 127.0.0.1 UH 2 28 lo0
    #

    What do I need to do to get this thing to talk out of the qu ports?

    Hank
     
    1. Advertising

  2. Dave Uhring

    Dave Uhring Guest

    On Thu, 22 Jul 2004 20:31:24 -0600, Henry van Cleef wrote:

    > hme0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500
    > index 2
    > inet 192.168.1.1 netmask ffffff00 broadcast 192.168.1.255
    > ether 8:0:20:a0:aa:24
    > qe0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index
    > 3
    > inet 192.168.1.9 netmask ffffff00 broadcast 192.168.1.255
    > ether 8:0:20:a0:aa:24


    You cannot have 2 ethernet interfaces on a subnet with the same ethernet
    address.
     
    1. Advertising

  3. K7MEM

    K7MEM Guest

    Henry van Cleef wrote:
    > I have a 4-port 501-2062 SQEC/S card that I plugged into an Ultra-1
    > 200E running Solaris 8 10/01 patched to Generic_117350-04. Did a
    > reconfiguration reboot and did a manual ifconfig for qe0 with plumb
    > up, and tried to ping the connection. The ping responds through the
    > hme0 port, not the qe0 port. I checked cabling, etc.---if I
    > disconnect the hme0 cable, things hang and there appears to be no
    > activity on my hub lights on the qe0 cable, even reversing the cables
    > at the Ultra.
    >
    > Checked to see if I have a driver loaded, and if I could see anything
    > funny anywhere. What I get are:
    >
    > # ifconfig -a
    > lo0: flags=1000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index
    > 1
    > inet 127.0.0.1 netmask ff000000
    > hme0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500
    > index 2
    > inet 192.168.1.1 netmask ffffff00 broadcast 192.168.1.255
    > ether 8:0:20:a0:aa:24
    > qe0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index
    > 3
    > inet 192.168.1.9 netmask ffffff00 broadcast 192.168.1.255
    > ether 8:0:20:a0:aa:24
    > # modinfo |grep ether
    > # modinfo |grep Ether
    > 71 102d6783 f18a 7 1 hme (10/100Mb Ethernet Driver v1.149)
    > 104 102abfe2 6512 104 1 qe (Quad-MACE Ethernet Driver v1.80)
    > # netstat -nr
    >
    > Routing Table: IPv4
    > Destination Gateway Flags Ref Use Interface
    > -------------------- -------------------- ----- ----- ------ ---------
    > 192.168.1.0 192.168.1.1 U 1 190 hme0
    > 192.168.1.0 192.168.1.9 U 1 0 qe0
    > 224.0.0.0 192.168.1.1 U 1 0 hme0
    > 127.0.0.1 127.0.0.1 UH 2 28 lo0
    > #
    >
    > What do I need to do to get this thing to talk out of the qu ports?
    >
    > Hank


    Dave pointed out that "you cannot have 2 ethernet interfaces on a subnet
    with the same ethernet address". That's not strictly true, but it's not
    very useful. As you have found out, output data will only go out over
    one ethernet but the system will be able to receive data on either.
    If the output ethernet goes down, the system will not switch over to
    the other one.

    Failover is possible, if that's what you are trying to do, but
    this isn't the way to do it. There was a very recient thread on
    this. It's called IP Multipathing and here are a link on it:

    http://www.eng.auburn.edu/~doug/howtos/multipathing.html

    As for getting the "ge" interface talking, you should have two file
    in "/etc" named "hostname.hme0" and "hostname.ge0". These should
    contain host names in them. I assume that they both contain the
    same name. Temporarily, change the name of "hostname.hme0" to
    "hostname.hme0.ori" and reboot. This will then bring up only "ge0"
    as your network interface.

    If you want to bring up the other interface, add a new entry to the
    host file and use a different name and a different subnet.

    > cat /etc/hosts

    127.0.0.1 localhost
    192.168.1.1 mainhost loghost
    192.168.10.1 sub_host

    > cat /etc/hostname.ge0

    mainhost

    > cat /etc/hostname.hme0

    sub_host

    With this setup, a reboot should bring up both interfaces with the
    "ge" ingerface being your main connection. I did a similar setup
    just this week with a "eri" and a "frcgei" ethernet interface. The
    "frcgei" interface didn't respond until they were defined as
    hosts on separate sub-nets.

    I'm sure that other will give further input on possible router
    issues and such.

    --
    Martin E. Meserve

    http://www.k7mem.150m.com
     
  4. Dave Uhring

    Dave Uhring Guest

    On Fri, 23 Jul 2004 06:54:13 -0700, K7MEM wrote:

    > Dave pointed out that "you cannot have 2 ethernet interfaces on a subnet
    > with the same ethernet address". That's not strictly true, but it's not
    > very useful.


    It is true on a switched network. And I left all the rest unsaid because
    I gave the OP a chance to figure out for himself how to resolve the
    problem.
     
  5. In article <>,
    Dave Uhring <> wrote:
    >On Fri, 23 Jul 2004 06:54:13 -0700, K7MEM wrote:
    >
    >> Dave pointed out that "you cannot have 2 ethernet interfaces on a subnet
    >> with the same ethernet address". That's not strictly true, but it's not
    >> very useful.

    >
    >It is true on a switched network. And I left all the rest unsaid because
    >I gave the OP a chance to figure out for himself how to resolve the
    >problem.
    >

    Thanks for your answer, Dave. Basically, I want to configure the
    multiport box as a router, but didn't have a third box up and running
    to look like a different subnet. And it turns out that taking an
    unused box off my stack of U1E's isn't plug'n play---shuffled too many
    hard disks around before making a 400 mile move, so I've got some
    reinstalls to do.

    Sun's docs seem clear that a box is a router if it's got two IP's
    configured and no /etc/notrouter file. If that's not the case, then I
    need more calibration.

    Hank
     
  6. Dave Uhring

    Dave Uhring Guest

    On Fri, 23 Jul 2004 22:12:29 -0600, Henry van Cleef wrote:

    > Thanks for your answer, Dave. Basically, I want to configure the
    > multiport box as a router, but didn't have a third box up and running
    > to look like a different subnet. And it turns out that taking an
    > unused box off my stack of U1E's isn't plug'n play---shuffled too many
    > hard disks around before making a 400 mile move, so I've got some
    > reinstalls to do.


    If you have a switched network and place two NICs on that network with the
    same ethernet address and different IP addresses you confuse the switch.

    You can change the ethernet addresses of your qe0 by using ifconfig ether
    or use setenv in OBP but I don't remember the exact parameter.

    > Sun's docs seem clear that a box is a router if it's got two IP's
    > configured and no /etc/notrouter file. If that's not the case, then I
    > need more calibration.


    Yes that is true, but you were trying to route to the same subnet.
    Configure qe0 to 192.168.0.9/24, connect it to the 192.168.0.0/24 network
    and you should not have the reported problems.
     
  7. Andrew Tyson

    Andrew Tyson Guest

    <snip>
    > You can change the ethernet addresses of your qe0 by using ifconfig ether
    > or use setenv in OBP but I don't remember the exact parameter.

    </snip>

    Either from Solaris;

    $ eeprom local-mac-address?=true

    or OBP;

    ok setenv local-mac-address? true

    AT
     
  8. In article <>,
    Dave Uhring <> wrote:
    >On Fri, 23 Jul 2004 22:12:29 -0600, Henry van Cleef wrote:
    >
    >If you have a switched network and place two NICs on that network with the
    >same ethernet address and different IP addresses you confuse the switch.
    >
    >You can change the ethernet addresses of your qe0 by using ifconfig ether
    >or use setenv in OBP but I don't remember the exact parameter.
    >

    Once again, thanks for flagging the fact that the qe's get configured
    with the box ethernet address. I can think of about eight ways to
    make that problem go away, but solving it is on the back burner, as I
    am routing through two different hubs.

    >> Sun's docs seem clear that a box is a router if it's got two IP's
    >> configured and no /etc/notrouter file. If that's not the case, then I
    >> need more calibration.

    >
    >Yes that is true, but you were trying to route to the same subnet.
    >Configure qe0 to 192.168.0.9/24, connect it to the 192.168.0.0/24 network
    >and you should not have the reported problems.
    >

    Understood. I've gotten the box with the SQEC card up and running as
    a router, and have tested it. As I mentioned, my objective was to get
    a router between a 100BaseT hub, and a 10BaseT hub, and now have this
    up and working.

    I have a hunch that putting in an /etc/ethers file may work with the
    startup scripts---if I can't find a "Sun way," I can always add a
    script to change the ethernet addresses with ifconfig.

    Hank
     
  9. Dave Uhring

    Dave Uhring Guest

    On Sun, 25 Jul 2004 11:27:04 -0600, Henry van Cleef wrote:

    > Understood. I've gotten the box with the SQEC card up and running as
    > a router, and have tested it. As I mentioned, my objective was to get
    > a router between a 100BaseT hub, and a 10BaseT hub, and now have this
    > up and working.


    Glad to hear it.

    > I have a hunch that putting in an /etc/ethers file may work with the
    > startup scripts---if I can't find a "Sun way," I can always add a
    > script to change the ethernet addresses with ifconfig.


    See the article posted by Andrew Tyson in this thread. He provided the
    needed parameters for modifying the OBP settings, which should solve the
    identical MACADDR problem.

    ethers(4) does not seem to deal with the problem of the same ethernet
    addresses on 2 or more ethernet interfaces. Best to modify the OBP
    local-mac-address? setting or as a second choice to use ifconfig qe0
    ether.
     
  10. Greg Andrews

    Greg Andrews Guest

    "Andrew Tyson" <asptysonATyahooD0TcomD0Tau> writes:
    ><snip>
    >> You can change the ethernet addresses of your qe0 by using ifconfig ether
    >> or use setenv in OBP but I don't remember the exact parameter.

    ></snip>
    >
    >Either from Solaris;
    >
    >$ eeprom local-mac-address?=true
    >


    It's wisest to prevent the question mark character
    from being interpreted as a shell globbing wildcard:

    $ eeprom local-mac-address\?=true
    or
    $ eeprom 'local-mac-address?=true'


    -Greg
    --
    Do NOT reply via e-mail.
    Reply in the newsgroup.
     
  11. In article <4103a3c6$0$22580$>,
    Andrew Tyson <asptysonATyahooD0TcomD0Tau> wrote:
    ><snip>
    >> You can change the ethernet addresses of your qe0 by using ifconfig ether
    >> or use setenv in OBP but I don't remember the exact parameter.

    ></snip>
    >
    >Either from Solaris;
    >
    >$ eeprom local-mac-address?=true
    >
    >or OBP;
    >
    >ok setenv local-mac-address? true
    >
    >AT
    >

    I did that, and am still getting the box mac addresses assigned to all
    the qe ports.

    Hank
     
  12. Henry van Cleef <> probably said:
    >I did that, and am still getting the box mac addresses assigned to all
    >the qe ports.


    Not all ethernet cards have local MACs to use, if the qe card is one
    of them then you'll have to assign it addresses manually.

    P.

    --
    pir
     
  13. (Henry van Cleef) wrote in message news:<>...
    > >ok setenv local-mac-address? true


    > I did that, and am still getting the box mac addresses assigned to all
    > the qe ports.


    That does give the ports their own MAC addresses, only allows them to
    have their own MAC addresses.
     
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. xyz
    Replies:
    4
    Views:
    367
    Darkfalz
    Jun 4, 2004
  2. Islam Ossama

    Help configuring XUP PPC for Ethernet

    Islam Ossama, Jun 17, 2007, in forum: Embedded
    Replies:
    0
    Views:
    268
    Islam Ossama
    Jun 17, 2007
  3. Patrick Powell
    Replies:
    0
    Views:
    155
    Patrick Powell
    Jul 28, 2005
  4. Paul
    Replies:
    2
    Views:
    1,055
  5. Bill
    Replies:
    0
    Views:
    846
Loading...

Share This Page