Deskpro Small Form Factor & USB Keyboard

Discussion in 'Compaq' started by Richard, Aug 30, 2004.

  1. Richard

    Richard Guest

    Hi,

    It spits out a 'keyboard error, press F1 to boot' if I boot without a
    keyboard plugged into the keyboard PS2 port.

    It doesn't seem to recognise the USB keyboard that is attached, so I plug a
    board back into the PS2 and press F1 and it boots up as normal.

    Is there a way to get it to recognise the USB keyboard at this level (ie:
    before windows had loaded) or a way to get it to ignore such an error.

    Thanks,

    Joe
     
    Richard, Aug 30, 2004
    #1
    1. Advertising

  2. Richard

    HH Guest

    No enabling USB option in F10 setup?
    HH

    "Richard" <> wrote in message
    news:ch094s$o2h$1$...
    > Hi,
    >
    > It spits out a 'keyboard error, press F1 to boot' if I boot without a
    > keyboard plugged into the keyboard PS2 port.
    >
    > It doesn't seem to recognise the USB keyboard that is attached, so I plug

    a
    > board back into the PS2 and press F1 and it boots up as normal.
    >
    > Is there a way to get it to recognise the USB keyboard at this level (ie:
    > before windows had loaded) or a way to get it to ignore such an error.
    >
    > Thanks,
    >
    > Joe
    >
    >
    >
    >
     
    HH, Aug 30, 2004
    #2
    1. Advertising

  3. "Richard" <> wrote in
    news:ch094s$o2h$1$:

    > Hi,
    >
    > It spits out a 'keyboard error, press F1 to boot' if I boot
    > without a keyboard plugged into the keyboard PS2 port.
    >
    > It doesn't seem to recognise the USB keyboard that is attached,
    > so I plug a board back into the PS2 and press F1 and it boots up
    > as normal.
    >
    > Is there a way to get it to recognise the USB keyboard at this
    > level (ie: before windows had loaded) or a way to get it to
    > ignore such an error.
    >

    Suggest you check your BIOS setup, looking for:
    - USB ports enable/disable
    - USB keyboard enable/disable
    - boot error ignore settings
     
    Frank le Spikkin, Aug 31, 2004
    #3
  4. Richard

    Richard Guest

    "Frank le Spikkin" <> wrote in message
    news:Xns95562F609678FlSxxx@130.133.1.4...
    > "Richard" <> wrote in
    > news:ch094s$o2h$1$:
    >
    > > Hi,
    > >
    > > It spits out a 'keyboard error, press F1 to boot' if I boot
    > > without a keyboard plugged into the keyboard PS2 port.
    > >
    > > It doesn't seem to recognise the USB keyboard that is attached,
    > > so I plug a board back into the PS2 and press F1 and it boots up
    > > as normal.
    > >
    > > Is there a way to get it to recognise the USB keyboard at this
    > > level (ie: before windows had loaded) or a way to get it to
    > > ignore such an error.
    > >

    > Suggest you check your BIOS setup, looking for:
    > - USB ports enable/disable
    > - USB keyboard enable/disable
    > - boot error ignore settings
    >
    >


    Thanks for the replies, Frank and HH.

    There is no obvious BIOS USB setting, in fact USB isn't even mentioned in
    any page.

    No boot error ignore either.

    Maybe it's cos it's an old archaic architecture or something, PIII 450.

    Unless....there's another name for USB, like it is listed as a serial port
    or soemthing, but that page has devices listed in Hexadecimal codes instead
    of saying what they are.

    Ho hum.

    If anyone has any more thoughts, I will be here to try em out!

    Richard
     
    Richard, Aug 31, 2004
    #4
  5. Richard

    Ben Myers Guest

    Older Pentium III class computers, even as old as 450MHz have decent (USB 1.1)
    support for USB keyboards built-in. Almost every motherboard I've touched from
    that era (I am currently working with HP small form factor VLi8 P3 boxes) has a
    BIOS setup option to enable/disable USB. It would be a big surprise if the
    DeskPro SFF lacked USB keyboard support entirely, but name brand manufacturers
    often do really stupid things in an effort to control costs.

    Can you get into the system BIOS setup, usually the F10 key on Compaq DeskPro
    boxes? If not, there is often a good explanation. Unlike many other name-brand
    and generic computers, many Compaq DeskPros need to have a diagnostic partition
    filled with software, and the BIOS setup is actually software run from the
    diagnostic partition. Stupid, stupid, stupid, but that's the way Compaq did it
    back then. This is no better than the IBM's follies with MIcroChannel in the
    late '80s, or the response of the rest of the industry (including Compaq) with
    the EISA setup follies.

    So if your system does not respond to F10 with setup menus, you need to download
    the diagnostic/setup software for your system, remove all partitions from the
    hard drive, then load up the diagnostic partition. Do the necessary setup, then
    load up the operating system.

    You might also clear the motherboard CMOS (a jumper or switch on the
    motherboard) to see if that improves the situation and/or allows you to get into
    the BIOS setup... Ben Myers

    On Tue, 31 Aug 2004 14:31:52 +0100, "Richard" <> wrote:

    >
    >"Frank le Spikkin" <> wrote in message
    >news:Xns95562F609678FlSxxx@130.133.1.4...
    >> "Richard" <> wrote in
    >> news:ch094s$o2h$1$:
    >>
    >> > Hi,
    >> >
    >> > It spits out a 'keyboard error, press F1 to boot' if I boot
    >> > without a keyboard plugged into the keyboard PS2 port.
    >> >
    >> > It doesn't seem to recognise the USB keyboard that is attached,
    >> > so I plug a board back into the PS2 and press F1 and it boots up
    >> > as normal.
    >> >
    >> > Is there a way to get it to recognise the USB keyboard at this
    >> > level (ie: before windows had loaded) or a way to get it to
    >> > ignore such an error.
    >> >

    >> Suggest you check your BIOS setup, looking for:
    >> - USB ports enable/disable
    >> - USB keyboard enable/disable
    >> - boot error ignore settings
    >>
    >>

    >
    >Thanks for the replies, Frank and HH.
    >
    >There is no obvious BIOS USB setting, in fact USB isn't even mentioned in
    >any page.
    >
    >No boot error ignore either.
    >
    >Maybe it's cos it's an old archaic architecture or something, PIII 450.
    >
    >Unless....there's another name for USB, like it is listed as a serial port
    >or soemthing, but that page has devices listed in Hexadecimal codes instead
    >of saying what they are.
    >
    >Ho hum.
    >
    >If anyone has any more thoughts, I will be here to try em out!
    >
    >Richard
    >
    >
     
    Ben Myers, Aug 31, 2004
    #5
  6. Richard

    Richard Guest

    <ben_myers_spam_me_not @ charter.net (Ben Myers)> wrote in message
    news:...
    > Older Pentium III class computers, even as old as 450MHz have decent (USB

    1.1)
    > support for USB keyboards built-in. Almost every motherboard I've touched

    from
    > that era (I am currently working with HP small form factor VLi8 P3 boxes)

    has a
    > BIOS setup option to enable/disable USB. It would be a big surprise if

    the
    > DeskPro SFF lacked USB keyboard support entirely, but name brand

    manufacturers
    > often do really stupid things in an effort to control costs.
    >
    > Can you get into the system BIOS setup, usually the F10 key on Compaq

    DeskPro
    > boxes? If not, there is often a good explanation. Unlike many other

    name-brand
    > and generic computers, many Compaq DeskPros need to have a diagnostic

    partition
    > filled with software, and the BIOS setup is actually software run from the
    > diagnostic partition. Stupid, stupid, stupid, but that's the way Compaq

    did it
    > back then. This is no better than the IBM's follies with MIcroChannel in

    the
    > late '80s, or the response of the rest of the industry (including Compaq)

    with
    > the EISA setup follies.
    >
    > So if your system does not respond to F10 with setup menus, you need to

    download
    > the diagnostic/setup software for your system, remove all partitions from

    the
    > hard drive, then load up the diagnostic partition. Do the necessary

    setup, then
    > load up the operating system.
    >
    > You might also clear the motherboard CMOS (a jumper or switch on the
    > motherboard) to see if that improves the situation and/or allows you to

    get into
    > the BIOS setup... Ben Myers
    >


    Thanks for that Ben, I can get into the BIOS with F10, and there is no
    mention of USB at all. I did remove the existing partition before
    reformatting and loading XP (runs a treat :)

    It would truly appear to not support a USB keyboard at the BIOS level.

    Weird, but then again a simpole workaround - I got a £5 keyboard and have it
    shoved down the back just to keep it happy on reboots!

    Thanks,

    Richard
     
    Richard, Sep 3, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jack
    Replies:
    8
    Views:
    369
  2. Jack
    Replies:
    8
    Views:
    385
  3. Jack
    Replies:
    8
    Views:
    387
  4. Jack
    Replies:
    8
    Views:
    325
  5. Bill
    Replies:
    4
    Views:
    1,870
Loading...

Share This Page