Getting an IP from Linksys router

Discussion in 'Apple' started by 2minutehate, Jul 28, 2004.

  1. 2minutehate

    2minutehate Guest

    I've got a Linksys BEFW11S4 router that works fine. What I would like to
    do, though, is to be able to assign my PowerBook a static local IP--
    something like 192.168.1.123. I get my real IP via DHCP. How would I go
    about doing this? I'm mainly looking to doing this to make connecting to
    IRC networks that require ident (or whatever it's called), which uses
    port 113-- which needs to be forwarded to the internal IP changing PB--,
    easier. (Meaning I won't have to look up my internal IP everytime I want
    to connect to IRC; it'll always be 192.168.1.123).
    2minutehate, Jul 28, 2004
    #1
    1. Advertising

  2. In article <>,
    2minutehate <> wrote:

    > I've got a Linksys BEFW11S4 router that works fine. What I would like to
    > do, though, is to be able to assign my PowerBook a static local IP--
    > something like 192.168.1.123. I get my real IP via DHCP. How would I go
    > about doing this? I'm mainly looking to doing this to make connecting to
    > IRC networks that require ident (or whatever it's called), which uses
    > port 113-- which needs to be forwarded to the internal IP changing PB--,
    > easier. (Meaning I won't have to look up my internal IP everytime I want
    > to connect to IRC; it'll always be 192.168.1.123).


    In the Network system preferences, change "Configure using DHCP" to
    "Configure Manually", and set the IP address that you want to use.

    --
    Barry Margolin,
    Arlington, MA
    *** PLEASE post questions in newsgroups, not directly to me ***
    Barry Margolin, Jul 28, 2004
    #2
    1. Advertising

  3. 2minutehate

    Mats Weber Guest

    In article <>,
    Barry Margolin <> wrote:

    >In the Network system preferences, change "Configure using DHCP" to
    >"Configure Manually", and set the IP address that you want to use.


    I think, but I am not sure, that it is better to use "DHCP with manual
    address" (or something to that effect) instead of fully manual
    configuration. Maybe someone who knows better can confirm ?
    Mats Weber, Jul 28, 2004
    #3
  4. 2minutehate

    2minutehate Guest

    In article <>,
    (Tacit) wrote:

    > >I've got a Linksys BEFW11S4 router that works fine. What I would like to
    > >do, though, is to be able to assign my PowerBook a static local IP--
    > >something like 192.168.1.123.

    >
    > Change the network prefpane setting (OS X) or TCP/IP control panel (OS 9) to
    > "manually" instead of "DHCP".
    >
    > In the IP address space, put "192.168.1.123".
    >
    > For the Subnet Mask, use "255.255.255.0".
    >
    > For the gateway address, use "192.168.1.1".
    >
    > That's it! You're done.


    Well, I implement those steps and then I get "server cannot be found"
    errors in Firefox (and Safari for that matter). I tried both vanilla
    "manually" and "DHCP with manual address." Airport's still at full
    strength, though. Does it have anything to do with me connecting
    wirelessly rather than just straight into the router via Cat5?
    2minutehate, Jul 28, 2004
    #4
  5. In article <>,
    2minutehate <> wrote:

    > In article <>,
    > (Tacit) wrote:
    >
    > > >I've got a Linksys BEFW11S4 router that works fine. What I would like to
    > > >do, though, is to be able to assign my PowerBook a static local IP--
    > > >something like 192.168.1.123.

    > >
    > > Change the network prefpane setting (OS X) or TCP/IP control panel (OS 9) to
    > > "manually" instead of "DHCP".
    > >
    > > In the IP address space, put "192.168.1.123".
    > >
    > > For the Subnet Mask, use "255.255.255.0".
    > >
    > > For the gateway address, use "192.168.1.1".
    > >
    > > That's it! You're done.

    >
    > Well, I implement those steps and then I get "server cannot be found"
    > errors in Firefox (and Safari for that matter). I tried both vanilla
    > "manually" and "DHCP with manual address." Airport's still at full
    > strength, though. Does it have anything to do with me connecting
    > wirelessly rather than just straight into the router via Cat5?


    You may also need to manually configure your DNS server address.

    --
    Barry Margolin,
    Arlington, MA
    *** PLEASE post questions in newsgroups, not directly to me ***
    Barry Margolin, Jul 29, 2004
    #5
  6. 2minutehate

    Bob Harris Guest

    In article <>,
    2minutehate <> wrote:

    > In article <>,
    > (Tacit) wrote:
    >
    > > >I've got a Linksys BEFW11S4 router that works fine. What I would like to
    > > >do, though, is to be able to assign my PowerBook a static local IP--
    > > >something like 192.168.1.123.

    > >
    > > Change the network prefpane setting (OS X) or TCP/IP control panel (OS 9) to
    > > "manually" instead of "DHCP".
    > >
    > > In the IP address space, put "192.168.1.123".
    > >
    > > For the Subnet Mask, use "255.255.255.0".
    > >
    > > For the gateway address, use "192.168.1.1".
    > >
    > > That's it! You're done.

    >
    > Well, I implement those steps and then I get "server cannot be found"
    > errors in Firefox (and Safari for that matter). I tried both vanilla
    > "manually" and "DHCP with manual address." Airport's still at full
    > strength, though. Does it have anything to do with me connecting
    > wirelessly rather than just straight into the router via Cat5?


    Most likely reasons is that the DNS did not get distributed to your Mac.
    In the network preferences on the Mac, specify the primary and secondary
    DNS address from your ISP.

    Bob Harris
    Bob Harris, Jul 29, 2004
    #6
  7. 2minutehate

    2minutehate Guest

    In article <>,
    Barry Margolin <> wrote:

    > In article <>,
    > 2minutehate <> wrote:
    >
    > > In article <>,
    > > (Tacit) wrote:
    > >
    > > > >I've got a Linksys BEFW11S4 router that works fine. What I would like to
    > > > >do, though, is to be able to assign my PowerBook a static local IP--
    > > > >something like 192.168.1.123.
    > > >
    > > > Change the network prefpane setting (OS X) or TCP/IP control panel (OS 9)
    > > > to
    > > > "manually" instead of "DHCP".
    > > >
    > > > In the IP address space, put "192.168.1.123".
    > > >
    > > > For the Subnet Mask, use "255.255.255.0".
    > > >
    > > > For the gateway address, use "192.168.1.1".
    > > >
    > > > That's it! You're done.

    > >
    > > Well, I implement those steps and then I get "server cannot be found"
    > > errors in Firefox (and Safari for that matter). I tried both vanilla
    > > "manually" and "DHCP with manual address." Airport's still at full
    > > strength, though. Does it have anything to do with me connecting
    > > wirelessly rather than just straight into the router via Cat5?

    >
    > You may also need to manually configure your DNS server address.


    /me Slaps forehead
    Yup, that did the trick. Thanks a bunch.
    2minutehate, Jul 29, 2004
    #7
  8. 2minutehate

    Acid Pooh Guest

    2minutehate <> wrote in message news:<>...
    > In article <>,
    > (Tacit) wrote:
    >
    > > >I've got a Linksys BEFW11S4 router that works fine. What I would like to
    > > >do, though, is to be able to assign my PowerBook a static local IP--
    > > >something like 192.168.1.123.

    > >
    > > Change the network prefpane setting (OS X) or TCP/IP control panel (OS 9) to
    > > "manually" instead of "DHCP".
    > >
    > > In the IP address space, put "192.168.1.123".
    > >
    > > For the Subnet Mask, use "255.255.255.0".
    > >
    > > For the gateway address, use "192.168.1.1".
    > >
    > > That's it! You're done.

    >
    > Well, I implement those steps and then I get "server cannot be found"
    > errors in Firefox (and Safari for that matter). I tried both vanilla
    > "manually" and "DHCP with manual address." Airport's still at full
    > strength, though. Does it have anything to do with me connecting
    > wirelessly rather than just straight into the router via Cat5?


    No.

    What I suggest is that you set your preferences back to DCHP and
    connect to http://192.168.0.0 or http://192.168.0.1. Most of these
    new routers have built-in web based configuration tools which you can
    use to set up all sorts of stuff, including DHCP. My (non-Linksys,
    unfortunately) router is set up to always assign the same IP to each
    computer on my network (it's based on MAC address, I believe)

    'cid 'ooh
    Acid Pooh, Jul 29, 2004
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mark K.

    BH6 - Linksys Router Issue

    Mark K., May 29, 2005, in forum: Abit
    Replies:
    2
    Views:
    363
    Conor
    May 29, 2005
  2. John
    Replies:
    2
    Views:
    278
    Andreas Koenig
    Aug 13, 2004
  3. Chris Lemon
    Replies:
    10
    Views:
    487
    Chris Lemon
    Oct 30, 2004
  4. Daniel Prince
    Replies:
    4
    Views:
    497
  5. Duffy Tweedy
    Replies:
    15
    Views:
    299
    Otto Pylot
    Nov 15, 2003
Loading...

Share This Page