1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

IDE interfacing with 8051 new problem (old one fixed)

Discussion in 'Hardware' started by bob, Apr 30, 2004.

  1. bob

    bob Guest

    So now I can seemingly read and write sectors on the hard drive and
    store the data in a 512 byte buffer in my ram, but whenever I read a
    sector, no matter what, I get the same data, an alternating pattern of
    FF and 7F for the whole sector. Any thoughts? I am using LBA
    (logical block addressing) which basically treats the whole drive as
    an amorphous array of sectors. However Im not sure that I know what
    im doing with the addressing scheme. This may be my problem. I just
    choose a low address like 00 00 00 01h as the sector to be accessed,
    but I dont know if there are constraints on which sectors I can
    actually access successfully except that if I try to access a sector
    with too high an address i.e 01 00 00 00h it gives me an error because
    the hard drive is not that big. Any help?
     
    bob, Apr 30, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. TEL
    Replies:
    0
    Views:
    678
  2. andrew queisser

    8051 memory interfacing questions

    andrew queisser, Feb 3, 2004, in forum: Embedded
    Replies:
    9
    Views:
    328
    Chris Hills
    Feb 4, 2004
  3. splendidm
    Replies:
    0
    Views:
    513
    splendidm
    Feb 23, 2006
  4. embedidea
    Replies:
    10
    Views:
    989
    embedidea
    Jul 10, 2006
  5. bob
    Replies:
    0
    Views:
    239
Loading...

Share This Page