K7vme system - no rebate yet, 2nd mo bo eats bios batteries.

Discussion in 'Soyo' started by john czarnuszewicz, Apr 20, 2005.

  1. SOYO was my favorite mo bo supplier in the old days.

    But now, its been 11 months since I bought the the SOYO 7VME barebones at
    Tiger Direct. I bought several other barebones at TIGER and other places. I
    build PCs for friends and relatives.

    I sent in the rebate forms. About 6 months ago I complained that the rebate
    had not shown up. Got a reply from SOYO that it was being processed. Nothing
    Yet. I think I would remember a $50 rebate.

    The original mo bo refused to boot, got a RMA and sent it back for a
    replacement. About $7 for shipping + $5 for SOYO handling.

    The replacement mo bo drains a fresh CMOS battery in about 3 weeks. I don't
    want to spend another $12 shipping and handling to get another defective mo
    bo.

    Now the SOYO case has an old MATSONIC mo bo that is running great. I know
    that this is not a power supply problem.

    Next month, I will go to the two LUGs ( Linux User Groups) I hang out in
    as well as the local PC USER (Windows) Group and update the gang on my SOYO
    (mis)adventures.

    Anyone else have this type of experience?
     
    john czarnuszewicz, Apr 20, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Vince
    Replies:
    32
    Views:
    1,637
    OldSailor
    Dec 27, 2005
  2. MJ
    Replies:
    0
    Views:
    256
  3. goldy
    Replies:
    1
    Views:
    355
    sam owens
    Jul 19, 2006
  4. Replies:
    0
    Views:
    835
  5. Mike K
    Replies:
    1
    Views:
    212
    matt neuburg
    Apr 21, 2004
Loading...

Share This Page