1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Linux drivers for Lenovo 3000 N100

Discussion in 'IBM Thinkpad' started by xp_newbie@yahoo.com, Jun 13, 2006.

  1. Guest

    I just finished installing Ubuntu 6.0.6 on my Lenovo 3000 N100 - in a
    dual boot configration.

    (actually it is multi-boot, since Ubuntu was able to discover the
    Restore & Recovery partition that became hidden to the F11 key after I
    did an XP clean install).

    It looks great - and very user friendly. It even detected the WiFi
    device on the laptop.

    However, sounds is still not working - and the screen resolution is
    fixed at 1024x768 (instead of the max 1280x800 available to Windows
    XP).

    Now... knowing IBM and its Linux strategy, it is hard for me to believe
    that they wouldn't release drivers for Linux.

    Yet, if you go to the Lenovo/IBM support web site, you will discover
    that ironically the only downloadable software for Linux is...
    "Software Installer for Windows 98/SE/Me/NT/2000/XP"

    See for yourself: http://tinyurl.com/lnm8n

    Anyone knows whether it is possible to utilize available Lenovo 3000
    N100 hardware in Linux?

    Any Lenovo plans to release drivers for this poor laptop? Or is it
    something that is only reserved for the higher end ThinkPads (albeit
    containing the same exact electronics)?

    Thanks,
    Alex
     
    , Jun 13, 2006
    #1
    1. Advertising

  2. GomJabbar Guest

    If I am not mistaken, the Lenovo 3000 N100 is strictly Lenovo's baby.
    It is not a ThinkPad. Lenovo was building computers in China before
    they bought IBM's PC division. As such, the non-ThinkPad laptops have
    no reason to conform to former IBM standards. It is the consumer line.
    And generally speaking, consumers don't run Linux. How many laptops
    in Best Buy, Circuit City, or WalMart do you see running Linux?
     
    GomJabbar, Jun 13, 2006
    #2
    1. Advertising

  3. wrote:
    > I just finished installing Ubuntu 6.0.6 on my Lenovo 3000 N100 - in a
    > dual boot configration.
    >
    > (actually it is multi-boot, since Ubuntu was able to discover the
    > Restore & Recovery partition that became hidden to the F11 key after I
    > did an XP clean install).
    >
    > It looks great - and very user friendly. It even detected the WiFi
    > device on the laptop.
    >
    > However, sounds is still not working - and the screen resolution is
    > fixed at 1024x768 (instead of the max 1280x800 available to Windows
    > XP).
    >


    Regarding the screen resolution:
    1. Open a terminal and run: sudo /sbin/telinit 3
    Note: This will close X windows
    2. Log in on console and as root (so use sudo) edit /etc/X11/xorg.conf
    Note: I prefer vim, but a lot of people like nano
    3. Change the line:
    Modes "1024x768"
    to
    Modes "1280x800" "1024x768"
    4. Save your changes and run: sudo /sbin/telinit 5

    X should launch with the new resolution, but if not, open
    gnome-control-center and see if the new resolution is listed under
    Screen Resolution.

    > Now... knowing IBM and its Linux strategy, it is hard for me to believe
    > that they wouldn't release drivers for Linux.
    >

    I'm guessing you're new to Linux; there's actually a reason you're not
    seeing Linux drivers. The vast majority of drivers (and almost
    certainly everything on your N100) are included in the kernel itself,
    and furthermore, it's generally considered bad form when companies only
    offer a closed binary driver. I'd be willing to bet there's a
    compatible sound driver already installed (there's even a chance the
    sound works and is muted, which isn't your fault it's a stupid default
    in ALSA).

    Post the results of: lsmod|grep snd

    You might also want to run the "Multimedia Systems Selector" in
    gnome-control-center
     
    Nicholas Andrade, Jun 13, 2006
    #3
  4. Guest

    GomJabbar wrote:
    > If I am not mistaken, the Lenovo 3000 N100 is strictly Lenovo's baby.
    > It is not a ThinkPad. Lenovo was building computers in China before
    > they bought IBM's PC division. As such, the non-ThinkPad laptops have
    > no reason to conform to former IBM standards. It is the consumer line.
    > And generally speaking, consumers don't run Linux. How many laptops
    > in Best Buy, Circuit City, or WalMart do you see running Linux?


    GomJabbar, have you read this article?

    http://hardware.slashdot.org/hardware/06/06/04/0415221.shtml

    Is it really true that Lenovo is going to dump ThinkPads too?

    Also, my Lenovo 3000 N100's electronics is basically the same the T60
    described here (except for the amount of memory, fingerprint reader the
    processor speed): http://www.sbellon.de/t60.html

    Can the same procedure work for my Lenovo?

    I will try that and report back here. :)

    Alex
     
    , Jun 14, 2006
    #4
  5. Guest

    Nicholas Andrade wrote:
    > Regarding the screen resolution:
    > 1. Open a terminal and run: sudo /sbin/telinit 3
    > Note: This will close X windows
    > 2. Log in on console and as root (so use sudo) edit /etc/X11/xorg.conf
    > Note: I prefer vim, but a lot of people like nano
    > 3. Change the line:
    > Modes "1024x768"
    > to
    > Modes "1280x800" "1024x768"
    > 4. Save your changes and run: sudo /sbin/telinit 5


    Unfortunately I have already found my etc/X11/xorg.conf with "1280x800"
    entries and no "1024x768" at all. It seems that Ubuntu properly
    detected my hardware, as can bee seen from the following excerpt:

    Section "Screen"
    Identifier "Default Screen"
    Device "Intel Corporation Mobile Integrated Graphics Controller"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    Depth 16
    Modes "1280x800"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x800"
    EndSubSection
    EndSection

    However, the monitor section shows:

    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    EndSection

    Could that be the problem?

    > X should launch with the new resolution, but if not, open
    > gnome-control-center and see if the new resolution is listed under
    > Screen Resolution.


    This is exactly what I used to view available resolutions. It lists
    only one: 1024x768

    > I'm guessing you're new to Linux; there's actually a reason you're not
    > seeing Linux drivers. The vast majority of drivers (and almost
    > certainly everything on your N100) are included in the kernel itself,
    > and furthermore, it's generally considered bad form when companies only
    > offer a closed binary driver. I'd be willing to bet there's a
    > compatible sound driver already installed (there's even a chance the
    > sound works and is muted, which isn't your fault it's a stupid default
    > in ALSA).
    >
    > Post the results of: lsmod|grep snd
    >


    Here they are:

    snd_hda_intel 18964 1
    snd_hda_codec 142640 1 snd_hda_intel
    snd_pcm_oss 53664 0
    snd_mixer_oss 18688 1 snd_pcm_oss
    snd_pcm 89864 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
    snd_timer 25220 1 snd_pcm
    snd 55268 8 snd_hda_intel, snd_hda_codec,
    snd_pcm_oss, snd_mixer_oss,
    snd_pcm, snd_timer
    soundcore 10208 1 snd
    snd_page_alloc 10632 2 snd_hda_intel,snd_pcm



    > You might also want to run the "Multimedia Systems Selector" in
    > gnome-control-center


    I run gnome-control-center but there is no "Multimedia Systems
    Selector" in there. Instead, there is an applette name "Sound". It
    lists "HDA Intel" as the default sound card, but no sound emits from
    the speaker. The amazing thing is that the Lenovo specific keys on the
    panel (not part of the keyboard) that are responsible for the volume
    and mute, display nice graphics when pressed. I am saying amazing,
    because for Windows XP that came preloaded with this laptop I had to
    install special OSD/hotkey driver to make these button work. Linux
    supported those out of the box. The big question now is - where is the
    sound?

    Thanks,
    Alex
     
    , Jun 14, 2006
    #5
  6. Guest

    wrote:
    > However, the monitor section shows:
    >
    > Section "Monitor"
    > Identifier "Generic Monitor"
    > Option "DPMS"
    > EndSection
    >
    > Could that be the problem?
    >


    Sure enough, I added thre more lines to that section to come up with
    the following:

    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 28-64
    VertRefresh 43-60
    Modeline "1280x800@60" 83.91 1280 1312 1624 1656 800 816
    824 841
    EndSection

    And now I can select any of 3 resolutions: 1024x768, 800x600, 640x480
    (instead of the single 1024x768).

    Not the 1280x800 resolution that I know my laptop's LCD is capable of,
    but at least I know that I am in the right direction. I will keep
    looking...

    Alex
     
    , Jun 14, 2006
    #6
  7. Guest

    wrote:
    > Sure enough, I added thre more lines to that section to come up with
    > the following:
    >
    > Section "Monitor"
    > Identifier "Generic Monitor"
    > Option "DPMS"
    > HorizSync 28-64
    > VertRefresh 43-60
    > Modeline "1280x800@60" 83.91 1280 1312 1624 1656 800 816
    > 824 841
    > EndSection
    >
    > And now I can select any of 3 resolutions: 1024x768, 800x600, 640x480
    > (instead of the single 1024x768).
    >
    > Not the 1280x800 resolution that I know my laptop's LCD is capable of,
    > but at least I know that I am in the right direction. I will keep
    > looking...
    >


    Well, it turned out that the xorg.conf file was not the right
    direction.

    Wanna know what the right direction is? :)

    Here it is - and specifically for the Lenovo 3000 N100 (just like mine)

    http://tinyurl.com/l5r93

    http://www.ubuntuforums.org/showthread.php?t=190237

    Man I am telling ya this Linux thing rocks. :)

    Alex
     
    , Jun 14, 2006
    #7
  8. Guest

    wrote:
    > Wanna know what the right direction is? :)
    >
    > Here it is - and specifically for the Lenovo 3000 N100 (just like mine)
    >
    > http://tinyurl.com/l5r93
    >
    > http://www.ubuntuforums.org/showthread.php?t=190237
    >


    And just so that this wonderful method is documented in more than one
    place on the Internet, here are the steps that I performed to gain the
    glorious 1200x800 resolution:

    Using "Start Menu", selected System | Administration | Synaptic Package
    Manager
    > Settings | Repositories [Add]
    > Community maintained (Universe) [Add]
    > Reload, download and Install the "915resolution" package.


    Then I started a terminal and in there typed:
    sudo 915resolution -l

    My Lenovo's 1200x800 @ 32 bit mode came out "5c".

    Then I edited that file:

    sudo gedit /etc/default/915resolution

    and replaced mode from "auto" to "5c" and filled XRESO=1280, YRESO=800.

    Saved the file, Ctrl+Alt+Backspace, X starts again - and bingo!
    1200x800 at its glory.

    Man I am telling ya Linux rocks! :)

    Alex
     
    , Jun 14, 2006
    #8
  9. Guest

    Angry American wrote:

    > Quality of components, thats the key, you do not have a thinkpad, not even
    > close.


    Who needs quality when running Virus XP SP2? ;-)

    And more seriously, I doubt that a laptop bought today will not be
    obsolete in a year or two, which means - it will need to be replaced.
    Why pay twice?

    I have a very well built, durable and reliable ThinkPad 600e. I can't
    really use it for any productive work. Not even web surfing (it's
    running Windows 2000 SP4).

    Regards,
    Alex
     
    , Jun 14, 2006
    #9
  10. wrote:

    >>
    >> Post the results of: lsmod|grep snd
    >>

    >
    > Here they are:
    >
    > snd_hda_intel 18964 1
    > snd_hda_codec 142640 1 snd_hda_intel
    > snd_pcm_oss 53664 0
    > snd_mixer_oss 18688 1 snd_pcm_oss
    > snd_pcm 89864 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
    > snd_timer 25220 1 snd_pcm
    > snd 55268 8 snd_hda_intel, snd_hda_codec,
    > snd_pcm_oss, snd_mixer_oss,
    > snd_pcm, snd_timer
    > soundcore 10208 1 snd
    > snd_page_alloc 10632 2 snd_hda_intel,snd_pcm
    >
    >

    Well it looks like you got your video card set, which is good, now as to
    sound. As I suspected, the module is detected and (assuming it's
    correct) I believe your sound is just muted. Instead of using the
    laptop's hardware keys, run the command: alsamixer. From there make
    sure both Master and PCM are not 0 and not muted (to select or
    in/deccrease an item use your arrow keys, to toggle mute press m, to
    save and exit press escape). Chances are the laptop's hardware keys
    simply control either the master volume or the PCM, not both. If you'd
    prefer a GUI for some reason, you can use kmix if KDE is installed or
    install aumix-gtk.

    One other thing you might want to do is add the following line to your
    kernel line in /boot/grub/menu.lst: vga=791. This will give you XGA
    resolution when you're on a real console (sorry, WXGA isn't supported
    there). To access a real (or virtual) console, press ctrl-alt-f[1-6] to
    return to X press ctrl-alt-f7. This is what's known as a kernel
    parameter so it won't take affect until the next reboot.

    One last thing, I should preface that although I do run one machine at
    work with Ubuntu, I don't know that distro (or Debian in general) that
    well. I am quite familiar with Red Hat (mostly Fedora) and Gentoo, but
    most of concepts carry over.
     
    Nicholas Andrade, Jun 14, 2006
    #10
  11. Guest

    Nicholas Andrade wrote:
    > Well it looks like you got your video card set, which is good, now as to
    > sound. As I suspected, the module is detected and (assuming it's
    > correct) I believe your sound is just muted. Instead of using the
    > laptop's hardware keys, run the command: alsamixer. From there make
    > sure both Master and PCM are not 0 and not muted (to select or
    > in/deccrease an item use your arrow keys, to toggle mute press m, to
    > save and exit press escape). Chances are the laptop's hardware keys
    > simply control either the master volume or the PCM, not both. If you'd
    > prefer a GUI for some reason, you can use kmix if KDE is installed or
    > install aumix-gtk.
    >


    Just did what you suggested:

    typed: alsamixer
    > received a cursors-like GUI with sliders as follows

    (card: HDA Intel, chip: AD1986A):
    Playback: Headphone, PCM, Front, Surround*, Center*,
    LFE*, Line*, CD, Mic*, IEC958**, PC Speaker*,
    Aux*, Mono*, Stereo Downmix**
    Capture: Line, CD, Mic, Phone, Aux, Mono, Capture***!, Mix

    * = Off, but sliders responding to up/down arrow keys,
    ** = Off, no full slider
    *** = The only "Capture" control that has slider

    I used the 'm' key to turn on all the channels that were off, but that
    didn't help. Any more ideas?

    In the meanwhile I will keep looking. I hope to find something specific
    to the Lenovo 3000 N100, just as I found the solution for the X screen
    resolution.

    Thanks for all the help and tips you have been providing!

    Alex
     
    , Jun 14, 2006
    #11
  12. Guest

    wrote:
    >
    > typed: alsamixer
    > > received a cursors-like GUI with sliders as follows

    > (card: HDA Intel, chip: AD1986A):
    > Playback: Headphone, PCM, Front, Surround*, Center*,
    > LFE*, Line*, CD, Mic*, IEC958**, PC Speaker*,
    > Aux*, Mono*, Stereo Downmix**
    > Capture: Line, CD, Mic, Phone, Aux, Mono, Capture***!, Mix
    >
    > * = Off, but sliders responding to up/down arrow keys,
    > ** = Off, no full slider
    > *** = The only "Capture" control that has slider
    >
    > I used the 'm' key to turn on all the channels that were off, but that
    > didn't help. Any more ideas?
    >
    > In the meanwhile I will keep looking. I hope to find something specific
    > to the Lenovo 3000 N100, just as I found the solution for the X screen
    > resolution.
    >
    > Thanks for all the help and tips you have been providing!
    >


    Once again the solution was found in the Ubuntu Forums:

    http://tinyurl.com/lh6mv

    http://www.ubuntuforums.org/showpost.php?p=1101974&postcount=10

    Here is what I did:
    > sudo gedit /etc/modprobe.d/options
    > Add the line:

    options snd-hda-intel model=laptop-eapd
    > Reboot.


    Sound works like a charm now. :)

    Wow! I didn't know Linux was so cool (and easy to install and
    configure, too).

    Thanks for everything,
    Alex
     
    , Jun 14, 2006
    #12
  13. Guest

    wrote:
    > wrote:
    > >
    > > typed: alsamixer
    > > > received a cursors-like GUI with sliders as follows

    > > (card: HDA Intel, chip: AD1986A):
    > > Playback: Headphone, PCM, Front, Surround*, Center*,
    > > LFE*, Line*, CD, Mic*, IEC958**, PC Speaker*,
    > > Aux*, Mono*, Stereo Downmix**
    > > Capture: Line, CD, Mic, Phone, Aux, Mono, Capture***!, Mix
    > >
    > > * = Off, but sliders responding to up/down arrow keys,
    > > ** = Off, no full slider
    > > *** = The only "Capture" control that has slider
    > >
    > > I used the 'm' key to turn on all the channels that were off, but that
    > > didn't help. Any more ideas?
    > >
    > > In the meanwhile I will keep looking. I hope to find something specific
    > > to the Lenovo 3000 N100, just as I found the solution for the X screen
    > > resolution.
    > >
    > > Thanks for all the help and tips you have been providing!
    > >

    >
    > Once again the solution was found in the Ubuntu Forums:
    >
    > http://tinyurl.com/lh6mv
    >
    > http://www.ubuntuforums.org/showpost.php?p=1101974&postcount=10
    >
    > Here is what I did:
    > > sudo gedit /etc/modprobe.d/options
    > > Add the line:

    > options snd-hda-intel model=laptop-eapd
    > > Reboot.

    >
    > Sound works like a charm now. :)
    >
    > Wow! I didn't know Linux was so cool (and easy to install and
    > configure, too).
    >
    > Thanks for everything,
    > Alex


    Oh and once last remark regarding the comment made at

    http://www.ubuntuforums.org/showpost.php?p=1101974&postcount=10

    The special sound keys on the Lenovo 3000 N100 (outside the keyboard
    section, at the same row as the power button, to its right) work great
    (and not as described in that solution post). However, it is true that
    when headphones are plugged in, the speakers are still on. Interesting,
    once upon a time the automatic speaker disconnect used to be done
    mechanically at the jack, now it seems that it utilizes some load sense
    that is translated to a bit somewhere. I am sure this can be easily
    fixed. At the moment this is no big deal.

    Alex
     
    , Jun 14, 2006
    #13
  14. wrote:
    > wrote:
    >
    >> wrote:
    >>
    >>>typed: alsamixer
    >>> > received a cursors-like GUI with sliders as follows
    >>> (card: HDA Intel, chip: AD1986A):
    >>> Playback: Headphone, PCM, Front, Surround*, Center*,
    >>> LFE*, Line*, CD, Mic*, IEC958**, PC Speaker*,
    >>> Aux*, Mono*, Stereo Downmix**
    >>> Capture: Line, CD, Mic, Phone, Aux, Mono, Capture***!, Mix
    >>>
    >>>* = Off, but sliders responding to up/down arrow keys,
    >>>** = Off, no full slider
    >>>*** = The only "Capture" control that has slider
    >>>
    >>>I used the 'm' key to turn on all the channels that were off, but that
    >>>didn't help. Any more ideas?
    >>>
    >>>In the meanwhile I will keep looking. I hope to find something specific
    >>>to the Lenovo 3000 N100, just as I found the solution for the X screen
    >>>resolution.
    >>>
    >>>Thanks for all the help and tips you have been providing!
    >>>

    >>
    >>Once again the solution was found in the Ubuntu Forums:
    >>
    >>http://tinyurl.com/lh6mv
    >>
    >>http://www.ubuntuforums.org/showpost.php?p=1101974&postcount=10
    >>
    >>Here is what I did:
    >> > sudo gedit /etc/modprobe.d/options
    >> > Add the line:

    >> options snd-hda-intel model=laptop-eapd
    >> > Reboot.

    >>
    >>Sound works like a charm now. :)
    >>
    >>Wow! I didn't know Linux was so cool (and easy to install and
    >>configure, too).
    >>
    >>Thanks for everything,
    >>Alex

    >
    >
    > Oh and once last remark regarding the comment made at
    >
    > http://www.ubuntuforums.org/showpost.php?p=1101974&postcount=10
    >
    > The special sound keys on the Lenovo 3000 N100 (outside the keyboard
    > section, at the same row as the power button, to its right) work great
    > (and not as described in that solution post). However, it is true that
    > when headphones are plugged in, the speakers are still on. Interesting,
    > once upon a time the automatic speaker disconnect used to be done
    > mechanically at the jack, now it seems that it utilizes some load sense
    > that is translated to a bit somewhere. I am sure this can be easily
    > fixed. At the moment this is no big deal.
    >
    > Alex
    >

    I'm sure it's some ALSA option as the plugging in headphones turns off
    my speakers in both Fedora & Gentoo on my laptop.
     
    Nicholas Andrade, Jun 14, 2006
    #14
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. AAA
    Replies:
    1
    Views:
    458
    Richard Johnson
    Oct 8, 2006
  2. Jef Driesen
    Replies:
    1
    Views:
    532
    Phil Sherman
    Jan 19, 2007
  3. googler
    Replies:
    1
    Views:
    502
  4. CK
    Replies:
    0
    Views:
    327
  5. Seth
    Replies:
    3
    Views:
    586
    GomJabbar
    Jul 4, 2006
Loading...

Share This Page