Netbook wouldn't charge, Acer kept screws

Discussion in 'Acer' started by Paul H, Jun 7, 2010.

  1. Paul H

    Paul H Guest

    My Acer netbook would not charge, even with the charger plugged in. I had
    it repaired under warranty. Now everything is good.

    Except: I took the hard disk out because they warn that they may (most
    likely will) erase the disk. I left the teeny tiny screws in the netbook.
    Big mistake! It came back without them. I put the hard disk back in and
    the netbook runs fine. However I cannot mount it properly because a couple
    of these screws are missing.

    I have checked everywhere - Fry's, the Geek Squad, every repair place I can
    think of. All the screws they have are too fat. My calls to Acer fall on
    deaf ears.

    Ideas, anyone? TIA, Paul
     
    1. Advertising

  2. Ed Maier

    Ed Maier Guest

    On 6/7/2010 5:55 PM, Paul H wrote:
    > My Acer netbook would not charge, even with the charger plugged in. I
    > had it repaired under warranty. Now everything is good.
    >
    > Except: I took the hard disk out because they warn that they may (most
    > likely will) erase the disk. I left the teeny tiny screws in the
    > netbook. Big mistake! It came back without them. I put the hard disk
    > back in and the netbook runs fine. However I cannot mount it properly
    > because a couple of these screws are missing.
    >
    > I have checked everywhere - Fry's, the Geek Squad, every repair place I
    > can think of. All the screws they have are too fat. My calls to Acer
    > fall on deaf ears.
    >
    > Ideas, anyone? TIA, Paul
    >


    Thanks, Paul. Did you need to get a return shipping authority and if so,
    how did you obtain it?

    Thanks,

    Ed
     
    1. Advertising

  3. Ed Maier

    Ed Maier Guest

    On 6/7/2010 8:28 PM, Ed Maier wrote:
    > On 6/7/2010 5:55 PM, Paul H wrote:
    >> My Acer netbook would not charge, even with the charger plugged in. I
    >> had it repaired under warranty. Now everything is good.
    >>
    >> Except: I took the hard disk out because they warn that they may (most
    >> likely will) erase the disk. I left the teeny tiny screws in the
    >> netbook. Big mistake! It came back without them. I put the hard disk
    >> back in and the netbook runs fine. However I cannot mount it properly
    >> because a couple of these screws are missing.
    >>
    >> I have checked everywhere - Fry's, the Geek Squad, every repair place I
    >> can think of. All the screws they have are too fat. My calls to Acer
    >> fall on deaf ears.
    >>
    >> Ideas, anyone? TIA, Paul
    >>

    >
    > Thanks, Paul. Did you need to get a return shipping authority and if so,
    > how did you obtain it?
    >
    > Thanks,
    >
    > Ed


    Went to their home page and then to support. Supplied the info and they
    verified ownership, but the warranty is expired. Didn't realize I had it
    that long.

    Plan B: Requested an iPad for Fathers Day. <grin>

    Ed
     
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. FireBrick

    bluetooth wouldn't work

    FireBrick, Nov 4, 2003, in forum: Asus
    Replies:
    1
    Views:
    278
  2. Mr Happy

    60 degree centigrade K6-2/500 kept running

    Mr Happy, Jul 7, 2003, in forum: PC Hardware
    Replies:
    0
    Views:
    520
    Mr Happy
    Jul 7, 2003
  3. Tony!

    any reason you wouldn't?

    Tony!, Feb 19, 2004, in forum: ATI
    Replies:
    5
    Views:
    293
  4. BillW50
    Replies:
    13
    Views:
    489
    BillW50
    Nov 22, 2008
  5. Ed Maier
    Replies:
    12
    Views:
    3,373
    pollard1988
    Jul 31, 2012
Loading...

Share This Page