1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Start menu slow to display. XP

Discussion in 'Laptops' started by John Doue, Jan 29, 2010.

  1. John Doue

    John Doue Guest

    Hi,

    I realize this is not exactly the right place to ask the question, but
    no one seems to have a clue on WindowsXP.general.

    On one of my machines (all have a nearly identical set-up), access to
    the Start Menu various items is often slow (several seconds), with hard
    disk activity (several seconds) before they display.

    Since I have 1.5 G of RAM, it is not an issue of lack of memory. What
    can I do to make XP keep in memory the Start Menu and display it
    instantly or almost, as on my other machines?

    Thanks for your pointers.

    --
    John Doue
     
    John Doue, Jan 29, 2010
    #1
    1. Advertising

  2. John Doue

    BillW50 Guest

    In news:hjukk5$dau$-september.org,
    John Doue typed on Fri, 29 Jan 2010 14:34:13 +0200:
    > Hi,
    >
    > I realize this is not exactly the right place to ask the question, but
    > no one seems to have a clue on WindowsXP.general.
    >
    > On one of my machines (all have a nearly identical set-up), access to
    > the Start Menu various items is often slow (several seconds), with
    > hard disk activity (several seconds) before they display.
    >
    > Since I have 1.5 G of RAM, it is not an issue of lack of memory. What
    > can I do to make XP keep in memory the Start Menu and display it
    > instantly or almost, as on my other machines?
    >
    > Thanks for your pointers.


    Hi John, did you ever check Task Manager and check the CPU use? And if
    it goes up, see which process is causing this?

    It could be an uninstalled program that left stuff in the registry too.
    And careful with registry cleaners. As they remove important stuff if
    you are not careful.

    --
    Bill
    Gateway M465e ('06 era) - Windows XP SP3
     
    BillW50, Jan 29, 2010
    #2
    1. Advertising

  3. John Doue

    John Doue Guest

    On 1/29/2010 6:05 PM, BillW50 wrote:
    > In news:hjukk5$dau$-september.org,
    > John Doue typed on Fri, 29 Jan 2010 14:34:13 +0200:
    >> Hi,
    >>
    >> I realize this is not exactly the right place to ask the question, but
    >> no one seems to have a clue on WindowsXP.general.
    >>
    >> On one of my machines (all have a nearly identical set-up), access to
    >> the Start Menu various items is often slow (several seconds), with
    >> hard disk activity (several seconds) before they display.
    >>
    >> Since I have 1.5 G of RAM, it is not an issue of lack of memory. What
    >> can I do to make XP keep in memory the Start Menu and display it
    >> instantly or almost, as on my other machines?
    >>
    >> Thanks for your pointers.

    >
    > Hi John, did you ever check Task Manager and check the CPU use? And if
    > it goes up, see which process is causing this?
    >
    > It could be an uninstalled program that left stuff in the registry too.
    > And careful with registry cleaners. As they remove important stuff if
    > you are not careful.
    >


    Bill,

    No, it is trying to access the Start Menu items which causes the HD
    "grinding". It is obviously reading information before it can display
    it. IMHO, that information should be cached and not require reading each
    time (or most often).

    --
    John Doue
     
    John Doue, Jan 29, 2010
    #3
  4. John Doue

    BillW50 Guest

    John Doue wrote on Fri, 29 Jan 2010 20:44:47 +0200:
    > On 1/29/2010 6:05 PM, BillW50 wrote:
    >> In news:hjukk5$dau$-september.org,
    >> John Doue typed on Fri, 29 Jan 2010 14:34:13 +0200:
    >>> Hi,
    >>>
    >>> I realize this is not exactly the right place to ask the question, but
    >>> no one seems to have a clue on WindowsXP.general.
    >>>
    >>> On one of my machines (all have a nearly identical set-up), access to
    >>> the Start Menu various items is often slow (several seconds), with
    >>> hard disk activity (several seconds) before they display.
    >>>
    >>> Since I have 1.5 G of RAM, it is not an issue of lack of memory. What
    >>> can I do to make XP keep in memory the Start Menu and display it
    >>> instantly or almost, as on my other machines?
    >>>
    >>> Thanks for your pointers.

    >>
    >> Hi John, did you ever check Task Manager and check the CPU use? And if
    >> it goes up, see which process is causing this?
    >>
    >> It could be an uninstalled program that left stuff in the registry too.
    >> And careful with registry cleaners. As they remove important stuff if
    >> you are not careful.
    >>

    >
    > Bill,
    >
    > No, it is trying to access the Start Menu items which causes the HD
    > "grinding". It is obviously reading information before it can display
    > it. IMHO, that information should be cached and not require reading each
    > time (or most often).


    Yeah I know. Some programs (although rare) hooks into the Start menu.
    And why I like to know if the CPU usage goes up when you click on the
    menu. And if it does, what process is causing it? That way we know where
    to start looking.

    --
    Bill
    Asus EEE PC 702G4 ~ 2GB RAM ~ 16GB-SDHC
    Ubuntu 9.10 Netbook Remix
     
    BillW50, Jan 29, 2010
    #4
  5. John Doue

    BillW50 Guest

    In news:hk3ebr$33u$-september.org,
    John Doue typed on Sun, 31 Jan 2010 10:18:04 +0200:
    > Thanks Shaun and Bill for your help.
    >
    > While I was waiting for it, I have changed the prefetch settings to
    > prefetch all and not only start-up items, thinking it could not hurt.
    > Well, it did not, but it seems to have solved the issue. Why and how,
    > I am not sure. Time will confirm, or not, this result. Just a first
    > impression.
    >
    > I have plenty of disk space, so this was not the issue.
    >
    > Following up on an obvious thing you mentioned Bill, I have increased
    > the icon cache ... Should have thought of it earlier. On my XP,
    > default is 500. I set to 2000.
    > Shaun, if DisablePagingExecutive is the same as Disable paging of
    > kernel, Xteq systems (very neat to alter settings less blindly) says
    > no to disable it if you use standby power functions (which I do, as
    > most people, I guess).
    >
    > I will give some time to my machine to confirm the problem is solved.
    > If it proves to be, I will try disabling prefetch for programs to see
    > if the change in icon cache is actually sufficient. And if the problem
    > reappears, I will following Bill suggestion to check CPU usage, at
    > first I had not seen the point, now I do! Jetlag certainly (just flew
    > from Home Florida to Finland).
    >
    > Thank you both for your kind help!


    Thanks for the update. And if you find anything new, let us know.

    As for disabling paging, I do this on a number of my computers. This one
    for example. I never had any problems with using standby or anything.
    The only trick I know is to not let the free available RAM drop below
    200MB. Otherwise I don't notice any difference between with it off or
    on. Although I don't know why one would want to turn it off, unless to
    gain more disk space or to eliminate unnecessary writing like on a SSD.

    --
    Bill
    Asus EEE PC 702G8 ~ 2GB RAM ~ 16GB-SDHC
    Windows XP SP2
     
    BillW50, Feb 1, 2010
    #5
  6. John Doue

    John Doue Guest

    On 2/2/2010 1:34 AM, ~misfit~ wrote:
    >
    > Ahh, OK. My main machine (T60) is essentially used as a desktop (but using
    > much much less power and with a most excellent 1400 x 1050 IPS display) so I
    > have all 'power functions' turned off, or set to performance or 'desktop'. I
    > have it set to 'do nothing' when the lid is closed and have disabled
    > hibernate etc.
    >
    > I have an R51 (also with a 1400x1050 IPS screen [these FlexView screens are
    > the shiznit, I'd hate to have to make do with a TN screen now] but with 2GB
    > of RAM) that I take out with me if I need a mobile device (although the T60
    > has the extended battery<shrug>).


    No need to sell me the display: I have the exact same machine. I feel
    sorry when I visit shows room, they no longer sell displays, but
    mirrors. How can buyers accept that? Well, may be I am overestimating
    their judgement ...
    >
    >> I will give some time to my machine to confirm the problem is solved.
    >> If it proves to be, I will try disabling prefetch for programs to see
    >> if the change in icon cache is actually sufficient. And if the problem
    >> reappears, I will following Bill suggestion to check CPU usage, at
    >> first I had not seen the point, now I do! Jetlag certainly (just flew
    >> from Home Florida to Finland).
    >>
    >> Thank you both for your kind help!

    >
    > You're welcome John. I hope that you get over the jetlag soon. I'm told that
    > vodka helps.<g>


    Indeed, as does other hard stuff ... and removing snow from around my
    house, we had almost 3' this night. Not a problem for you ...!

    So far, my Start menu behaves. Thanks.
    --
    John Doue
     
    John Doue, Feb 2, 2010
    #6
  7. John Doue

    ~misfit~ Guest

    Somewhere on teh intarwebs John Doue wrote:
    > On 2/2/2010 1:34 AM, ~misfit~ wrote:
    >>
    >> Ahh, OK. My main machine (T60) is essentially used as a desktop (but
    >> using much much less power and with a most excellent 1400 x 1050 IPS
    >> display) so I have all 'power functions' turned off, or set to
    >> performance or 'desktop'. I have it set to 'do nothing' when the lid
    >> is closed and have disabled hibernate etc.
    >>
    >> I have an R51 (also with a 1400x1050 IPS screen [these FlexView
    >> screens are the shiznit, I'd hate to have to make do with a TN
    >> screen now] but with 2GB of RAM) that I take out with me if I need a
    >> mobile device (although the T60 has the extended battery<shrug>).

    >
    > No need to sell me the display: I have the exact same machine. I feel
    > sorry when I visit shows room, they no longer sell displays, but
    > mirrors. How can buyers accept that? Well, may be I am overestimating
    > their judgement ...



    I'm at a loss as to how people accept those crappy displays too. I hate it
    when I'm looking at someone else's laptop screen over their shoulder if
    they're showing me something. You've only got to be off by a few degrees (or
    have a light reflecting off the screen) and it looks terrible!

    Actually the R51 Flexview is slightly better than the T60 one I have. I've
    been contemplating swapping them around. (I'm fairly sure that they are
    interchangeable (unlike R40 - R51 :-/) as I bought an (Intel graphics) R51
    as parts that had a bad screen and, as I happened to have a spare T60 lid
    with an XGA (TN) panel I tried fitting it to the R51 and it works just fine.
    Therefore my (often faulty) logic suggests that I could likely swap the
    FlexViews around.....

    >>> I will give some time to my machine to confirm the problem is
    >>> solved. If it proves to be, I will try disabling prefetch for
    >>> programs to see if the change in icon cache is actually sufficient.
    >>> And if the problem reappears, I will following Bill suggestion to
    >>> check CPU usage, at first I had not seen the point, now I do!
    >>> Jetlag certainly (just flew from Home Florida to Finland).
    >>>
    >>> Thank you both for your kind help!

    >>
    >> You're welcome John. I hope that you get over the jetlag soon. I'm
    >> told that vodka helps.<g>

    >
    > Indeed, as does other hard stuff ... and removing snow from around my
    > house, we had almost 3' this night. Not a problem for you ...!


    Indeed. It's been far too hot here of late. I don't have AC but have a fan
    by my desk and one in my bedroom that runs all night.

    > So far, my Start menu behaves. Thanks.


    Cool, good to hear.
    --
    Cheers,
    Shaun.

    "Give a man a fire and he's warm for the day. But set fire to him and he's
    warm for the rest of his life." Terry Pratchet, 'Jingo'.
    Nota bene: 'Return to' email is never checked. I changed email clients and
    realised that I don't have a record of the password for that account.
     
    ~misfit~, Feb 5, 2010
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    371
  2. James
    Replies:
    8
    Views:
    11,412
    Sparky
    Oct 19, 2004
  3. Bob Pownall
    Replies:
    1
    Views:
    353
    Bob Pownall
    Feb 6, 2005
  4. Ben Myers
    Replies:
    0
    Views:
    429
    Ben Myers
    Dec 13, 2005
  5. Stef

    TC1100 - SP2 - SLOW SLOW SLOW!

    Stef, Sep 9, 2004, in forum: Tablet PC
    Replies:
    10
    Views:
    695
    Diederik
    Sep 13, 2004
Loading...

Share This Page