Terminal not accepting password

Discussion in 'Apple' started by John Matthew, May 1, 2009.

  1. John Matthew

    John Matthew Guest

    Recently, I tried to run routine maintenance using the sudo command and
    Terminal is not accepting my admin password. This has not happened
    before. Not having any trouble with login - just when using Terminal.
    Any ideas?
     
    John Matthew, May 1, 2009
    #1
    1. Advertising

  2. John Matthew

    Tom Stiller Guest

    In article <49fac02c$0$90270$>,
    John Matthew <> wrote:

    > Recently, I tried to run routine maintenance using the sudo command and
    > Terminal is not accepting my admin password. This has not happened
    > before. Not having any trouble with login - just when using Terminal.
    > Any ideas?


    Perhaps the account from which you're attempting to use sudo does not
    have administrative privileges? Another possibility is that the file
    '/etc/sudoers' has gone missing or is corrupt.

    --
    Tom Stiller

    PGP fingerprint = 5108 DDB2 9761 EDE5 E7E3 7BDA 71ED 6496 99C0 C7CF
     
    Tom Stiller, May 1, 2009
    #2
    1. Advertising

  3. John Matthew <> writes:

    > Recently, I tried to run routine maintenance using the sudo command and
    > Terminal is not accepting my admin password. This has not happened
    > before. Not having any trouble with login - just when using Terminal.
    > Any ideas?


    "sudo" does not ask for the admin password but for the password of the
    user you're logged in as.

    Jochem

    --
    "A designer knows he has arrived at perfection not when there is no
    longer anything to add, but when there is no longer anything to take away."
    - Antoine de Saint-Exupery
     
    Jochem Huhmann, May 1, 2009
    #3
  4. John Matthew

    Tom Stiller Guest

    In article <>, Jochem Huhmann <>
    wrote:

    > John Matthew <> writes:
    >
    > > Recently, I tried to run routine maintenance using the sudo command and
    > > Terminal is not accepting my admin password. This has not happened
    > > before. Not having any trouble with login - just when using Terminal.
    > > Any ideas?

    >
    > "sudo" does not ask for the admin password but for the password of the
    > user you're logged in as.
    >


    Which must be an administrator or a userID known to sudoers. If that's
    not the case, you can 'su' to such a user, supplying the password for
    the *switched-to* account, and then issue the 'sudo whatever' command.

    --
    Tom Stiller

    PGP fingerprint = 5108 DDB2 9761 EDE5 E7E3 7BDA 71ED 6496 99C0 C7CF
     
    Tom Stiller, May 1, 2009
    #4
  5. John Matthew

    Clark Martin Guest

    In article <49fac02c$0$90270$>,
    John Matthew <> wrote:

    > Recently, I tried to run routine maintenance using the sudo command and
    > Terminal is not accepting my admin password. This has not happened
    > before. Not having any trouble with login - just when using Terminal.
    > Any ideas?


    Check the following:

    Caps Lock Key

    That the account in question has admin privileges (actually check it in
    System Preferences / Accounts)

    and if you can, look at the /etc/sudoers file. It needs admin access so
    it might be a bit of a trick to see. It should include the following
    lines:
    root ALL=(ALL) ALL
    %admin ALL=(ALL) ALL

    Try doing a "login user" command with the account in question. This
    will differentiate whether it's a password problem with that account or
    an issue with sudo access.

    --
    Clark Martin
    Redwood City, CA, USA Macintosh / Internet Consulting

    "I'm a designated driver on the Information Super Highway"
     
    Clark Martin, May 3, 2009
    #5
  6. John Matthew

    Király Guest

    John Matthew <> wrote:
    > Recently, I tried to run routine maintenance using the sudo command and
    > Terminal is not accepting my admin password. This has not happened
    > before. Not having any trouble with login - just when using Terminal.
    > Any ideas?


    Check the keyboard layout for Terminal - maybe it's set to a layout that
    is remapping one of the characters in your password. Oh, and the admin
    account *does* have a password, right? As in, not blank?

    --
    K.

    Lang may your lum reek.
     
    Király, May 5, 2009
    #6
  7. John Matthew

    Bob Harris Guest

    In article <%u0Ml.25743$Db2.8679@edtnps83>,
    (Király) wrote:

    > John Matthew <> wrote:
    > > Recently, I tried to run routine maintenance using the sudo command and
    > > Terminal is not accepting my admin password. This has not happened
    > > before. Not having any trouble with login - just when using Terminal.
    > > Any ideas?

    >
    > Check the keyboard layout for Terminal - maybe it's set to a layout that
    > is remapping one of the characters in your password. Oh, and the admin
    > account *does* have a password, right? As in, not blank?


    And check Caps Lock.
     
    Bob Harris, May 6, 2009
    #7
  8. John Matthew

    John Matthew Guest

    In article <>,
    Bob Harris <-Harris.us> wrote:

    > In article <%u0Ml.25743$Db2.8679@edtnps83>,
    > (Király) wrote:
    >
    > > John Matthew <> wrote:
    > > > Recently, I tried to run routine maintenance using the sudo command and
    > > > Terminal is not accepting my admin password. This has not happened
    > > > before. Not having any trouble with login - just when using Terminal.
    > > > Any ideas?


    Still not working.

    > > Check the keyboard layout for Terminal - maybe it's set to a layout that
    > > is remapping one of the characters in your password. Oh, and the admin
    > > account *does* have a password, right? As in, not blank?


    How do I check the keyboard layout for terminal?

    > And check Caps Lock.


    Caps lock is off. Admin account has password, only admin has access to
    run Terminal Please inform as to how to check the keyboard layout for
    terminal.

    >Check the following:


    >Caps Lock Key


    caps lock is off

    >That the account in question has admin privileges (actually check it in
    >System Preferences / Accounts)


    account in question has admin priveleges and is the only one that does
    and is able to run Terminal commands

    >and if you can, look at the /etc/sudoers file. It needs admin access
    >so
    >it might be a bit of a trick to see. It should include the following
    >lines:
    >root ALL=(ALL) ALL
    >%admin ALL=(ALL) ALL


    tried to look at file but password was requested and, of course, access
    denied since my password is not being accepted

    >Try doing a "login user" command with the account in question. This
    >will differentiate whether it's a password problem with that account or
    >an issue with sudo access.


    did "login user" with problem account and received same messages -
    sudo periodic daily weekly monthly
    Password:
    Sorry, try again.
    Password:
    Sorry, try again.
    Password:
    Sorry, try again.
    sudo: 3 incorrect password attempts

    I did notice that every time when I typed in the second alpha-numeric or
    special character of my password, there was a brief flash on the word
    Edit in the Terminal menu bar. Has my computer been hijacked?

    Another anomaly happening recently is that after a time when I have 6 or
    more tabs open in Safari 3.1.2 in Tiger with activity in one or more of
    them, the window will freeze and I have the close that window. I don't
    get a not responding error in force quit - just the window locks up.

    >Perhaps the account from which you're attempting to use sudo does not
    >have administrative privileges? Another possibility is that the file
    >'/etc/sudoers' has gone missing or is corrupt.


    yes account has admin privileges
    how do I restore or correct the /etc/sudoers file - see earlier in the
    post - I tried to access the file and was denied access with password

    I changed password in system prefs/accounts and terminal will not take
    the new password either - the admin account is being denied access and
    there is only that one account on this computer
     
    John Matthew, May 6, 2009
    #8
  9. John Matthew

    Tom Stiller Guest

    In article <4a0131dc$0$90264$>,
    John Matthew <> wrote:

    > I did notice that every time when I typed in the second alpha-numeric or
    > special character of my password, there was a brief flash on the word
    > Edit in the Terminal menu bar. Has my computer been hijacked?


    Have you installed or enabled any 'keyboard substitution' software since
    you last used the 'sudo' command?

    --
    Tom Stiller

    PGP fingerprint = 5108 DDB2 9761 EDE5 E7E3 7BDA 71ED 6496 99C0 C7CF
     
    Tom Stiller, May 6, 2009
    #9
  10. John Matthew

    David Empson Guest

    John Matthew <> wrote:

    > I did notice that every time when I typed in the second alpha-numeric or
    > special character of my password, there was a brief flash on the word
    > Edit in the Terminal menu bar. Has my computer been hijacked?


    I doubt it has been "hijacked". More likely that some setting or third
    party software is interfering with you typing the password.

    That flash indicates that the key you typed triggered a command in the
    Edit menu, so it probably wasn't being entered as a character in the
    password.

    Are you able to type that specific character in another context within
    Terminal, e.g. at the normal shell prompt?

    I will assume that produces the same flash of the Edit menu, and the key
    isn't actually typed. You need to establish why that is happening.

    Are you able to type that specific character in other applications?

    Some possibilities:

    1. System Preferences > Keyboard & Mouse > Keyboard Shortcuts.

    Check for any unusual keyboard shortcuts referencing that key, possibly
    specific to the Terminal application, or globally.

    2. System Preferences > Speech > Text to Speech > Speak selected text
    when the key is pressed.

    If this option is enabled, click the Set Key button and check that it
    isn't set to something in your password. On two computers I've seen this
    somehow get set to an easily typed letter, preventing that letter from
    being used normally. You can't use System Preferences to set an
    unmodified character for this feature, so something else must have
    modified the appropriate plist directly.

    (This would have a system-wide effect, so doesn't seem likely in this
    case.)

    3. Some third party product which is reacting to that key and generating
    a different keypress instead.

    There could be other explanations.

    > >Perhaps the account from which you're attempting to use sudo does not
    > >have administrative privileges? Another possibility is that the file
    > >'/etc/sudoers' has gone missing or is corrupt.

    >
    > yes account has admin privileges
    > how do I restore or correct the /etc/sudoers file - see earlier in the
    > post - I tried to access the file and was denied access with password


    Use a different tool to access it. TextWrangler (free) can open files
    with root privileges after you authenticate as an admin user.

    I expect you will find that /etc/sudoers is fine. The problem is
    whatever is preventing you typing your password in Terminal.

    > I changed password in system prefs/accounts and terminal will not take
    > the new password either - the admin account is being denied access and
    > there is only that one account on this computer


    Create another admin account and try that.

    --
    David Empson
     
    David Empson, May 6, 2009
    #10
  11. John Matthew <> writes:

    (snip)

    > Caps lock is off. Admin account has password, only admin has access to
    > run Terminal Please inform as to how to check the keyboard layout for
    > terminal.


    That's interesting. How did you arrange it so that only admin has the
    ability to run Terminal. That is unusual. Probably not related to
    your problem, but it is hard to know for sure.

    (snip)

    > I did notice that every time when I typed in the second alpha-numeric or
    > special character of my password, there was a brief flash on the word
    > Edit in the Terminal menu bar. Has my computer been hijacked?


    It is a little bit hard to diagnose what is going on. I'm assuming
    you are logged into the mac in an account with admin access, and you
    are typing "sudo command" at the command line from that account, and
    that you are then entering the password from that account.

    The flash seems important. Various keys are interpreted by the
    terminal in special ways (function keys, end, home, escape, delete) -
    these are set in the Preferences under Settings -> Keyboard. (Also
    some things may be determined by the "Encodings" under Preferences.)

    The suggestion that you type your password on Terminal when it is
    being echoed (that is, not into the sudo command) to see if you can
    actually type your password in Terminal given whatever combination of
    password and Terminal preference settings you have.

    What is that character that makes things flash?
     
    Doug Anderson, May 6, 2009
    #11
  12. John Matthew

    John Matthew Guest

    In article <>,
    Tom Stiller <> wrote:

    > In article <4a0131dc$0$90264$>,
    > John Matthew <> wrote:
    >
    > > I did notice that every time when I typed in the second alpha-numeric or
    > > special character of my password, there was a brief flash on the word
    > > Edit in the Terminal menu bar. Has my computer been hijacked?

    >
    > Have you installed or enabled any 'keyboard substitution' software since
    > you last used the 'sudo' command?


    Thanks, Tom! You win the whiz kid . . . uh, I mean the whiz old man with
    beard prize of the day! I added a typing shortcut to Typinator since
    the last time I ran sudo and it had a combination that was also in my
    password. So - lesson learned - quit Typinator or any program like it
    before working in Terminal.
     
    John Matthew, May 6, 2009
    #12
  13. John Matthew

    John Matthew Guest

    In article <1izbicj.1yhz0vwymgog8N%>,
    (David Empson) wrote:

    Thanks David and Doug and all the earlier responders before I discovered
    the key flash - but the cigar has to go to Tom. He posted first with
    the exact problem - Typinator was running.


    > John Matthew <> wrote:
    >
    > > I did notice that every time when I typed in the second alpha-numeric or
    > > special character of my password, there was a brief flash on the word
    > > Edit in the Terminal menu bar. Has my computer been hijacked?

    >
    > I doubt it has been "hijacked". More likely that some setting or third
    > party software is interfering with you typing the password.
    >
    > That flash indicates that the key you typed triggered a command in the
    > Edit menu, so it probably wasn't being entered as a character in the
    > password.
    >
    > Are you able to type that specific character in another context within
    > Terminal, e.g. at the normal shell prompt?
    >
    > I will assume that produces the same flash of the Edit menu, and the key
    > isn't actually typed. You need to establish why that is happening.
    >
    > Are you able to type that specific character in other applications?
    >
    > Some possibilities:
    >
    > 1. System Preferences > Keyboard & Mouse > Keyboard Shortcuts.
    >
    > Check for any unusual keyboard shortcuts referencing that key, possibly
    > specific to the Terminal application, or globally.
    >
    > 2. System Preferences > Speech > Text to Speech > Speak selected text
    > when the key is pressed.
    >
    > If this option is enabled, click the Set Key button and check that it
    > isn't set to something in your password. On two computers I've seen this
    > somehow get set to an easily typed letter, preventing that letter from
    > being used normally. You can't use System Preferences to set an
    > unmodified character for this feature, so something else must have
    > modified the appropriate plist directly.
    >
    > (This would have a system-wide effect, so doesn't seem likely in this
    > case.)
    >
    > 3. Some third party product which is reacting to that key and generating
    > a different keypress instead.
    >
    > There could be other explanations.
    >
    > > >Perhaps the account from which you're attempting to use sudo does not
    > > >have administrative privileges? Another possibility is that the file
    > > >'/etc/sudoers' has gone missing or is corrupt.

    > >
    > > yes account has admin privileges
    > > how do I restore or correct the /etc/sudoers file - see earlier in the
    > > post - I tried to access the file and was denied access with password

    >
    > Use a different tool to access it. TextWrangler (free) can open files
    > with root privileges after you authenticate as an admin user.
    >
    > I expect you will find that /etc/sudoers is fine. The problem is
    > whatever is preventing you typing your password in Terminal.
    >
    > > I changed password in system prefs/accounts and terminal will not take
    > > the new password either - the admin account is being denied access and
    > > there is only that one account on this computer

    >
    > Create another admin account and try that.
     
    John Matthew, May 6, 2009
    #13
  14. John Matthew <> writes:

    > In article <1izbicj.1yhz0vwymgog8N%>,
    > (David Empson) wrote:
    >
    > Thanks David and Doug and all the earlier responders before I discovered
    > the key flash - but the cigar has to go to Tom. He posted first with
    > the exact problem - Typinator was running.


    Glad the problem is solved! It sounded frustrating.
     
    Doug Anderson, May 6, 2009
    #14
  15. John Matthew

    Tom Stiller Guest

    In article <4a01b443$0$90275$>,
    John Matthew <> wrote:

    > In article <>,
    > Tom Stiller <> wrote:
    >
    > > In article <4a0131dc$0$90264$>,
    > > John Matthew <> wrote:
    > >
    > > > I did notice that every time when I typed in the second alpha-numeric or
    > > > special character of my password, there was a brief flash on the word
    > > > Edit in the Terminal menu bar. Has my computer been hijacked?

    > >
    > > Have you installed or enabled any 'keyboard substitution' software since
    > > you last used the 'sudo' command?

    >
    > Thanks, Tom! You win the whiz kid . . . uh, I mean the whiz old man with
    > beard prize of the day! I added a typing shortcut to Typinator since
    > the last time I ran sudo and it had a combination that was also in my
    > password. So - lesson learned - quit Typinator or any program like it
    > before working in Terminal.


    Happy it all worked out.

    --
    Tom Stiller

    PGP fingerprint = 5108 DDB2 9761 EDE5 E7E3 7BDA 71ED 6496 99C0 C7CF
     
    Tom Stiller, May 6, 2009
    #15
  16. John Matthew

    Király Guest

    Doug Anderson <> wrote:
    > That's interesting. How did you arrange it so that only admin has the
    > ability to run Terminal. That is unusual. Probably not related to
    > your problem, but it is hard to know for sure.


    I don't know what he did, but it's easy to do with this command:

    sudo chmod o-x \
    /Applications/Utilities/Terminal.app/Contents/MacOS/Terminal

    That restricts the ability to launch Terminal to admin users only.

    --
    K.

    Lang may your lum reek.
     
    Király, May 7, 2009
    #16
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. LRCR
    Replies:
    1
    Views:
    344
  2. BooFA1010
    Replies:
    0
    Views:
    845
    BooFA1010
    Feb 20, 2009
  3. macman

    Computer not accepting DVDs

    macman, Feb 29, 2008, in forum: Apple
    Replies:
    4
    Views:
    217
    Király
    Mar 2, 2008
  4. speaker

    terminal not accepting login

    speaker, Dec 21, 2008, in forum: Apple
    Replies:
    1
    Views:
    214
    Carl Witthoft
    Dec 21, 2008
  5. heikhama
    Replies:
    0
    Views:
    550
    heikhama
    May 14, 2010
Loading...

Share This Page