Motherboard Forums


Reply
Thread Tools Display Modes

XP drivers for ATI Mobility Radeon HD 3450

 
 
Kev
Guest
Posts: n/a
 
      07-14-2010, 10:58 PM
I have just installed Windows XP on a laptop that was originally made to run
Vista (a Dell Studio 1537). Obviously the official drivers were no use, so
I have had to find suitable XP versions. All of the important components
are now working fine, apart from the graphics card.

The card is an ATI Mobility Radeon HD 3450. Unfortunately there are no XP
drivers for it either on the Dell site, nor on the AMD site. But after some
searching I found something that looks promising here:
http://downloadnew.org/drivers/graph...816.html#dlink

After downloading and unzipping, this turned out to be Catalyst, although I
cannot tell which version it is. It won't install though. It keeps
displaying messages like "Install Manager failed to initialize".

I am not sure what to try next. Any suggestions would be welcome.


 
Reply With Quote
 
 
 
 
Homer Jay Simpson
Guest
Posts: n/a
 
      07-15-2010, 12:50 AM
"Kev" <(E-Mail Removed)> wrote in message
news:3ir%n.247833$w51.238417@hurricane...
>I have just installed Windows XP on a laptop that was originally made to
>run Vista (a Dell Studio 1537). Obviously the official drivers were no
>use, so I have had to find suitable XP versions. All of the important
>components are now working fine, apart from the graphics card.
>
> The card is an ATI Mobility Radeon HD 3450. Unfortunately there are no XP
> drivers for it either on the Dell site, nor on the AMD site. But after
> some searching I found something that looks promising here:
> http://downloadnew.org/drivers/graph...816.html#dlink
>
> After downloading and unzipping, this turned out to be Catalyst, although
> I cannot tell which version it is. It won't install though. It keeps
> displaying messages like "Install Manager failed to initialize".
>
> I am not sure what to try next. Any suggestions would be welcome.
>


Have you tried downloading the latest Catalyst Version 10.6 Display Driver
for Windows XP Professional from AMD's web site?

http://game.amd.com/us-en/drivers_ca...=xp/radeonx-xp

Read the Release notes about AMD Mobility Product Support. The ATI Mobility
Radeon HD 3400 Series is listed as a supported product.



 
Reply With Quote
 
 
 
 
Kev
Guest
Posts: n/a
 
      07-15-2010, 07:52 AM
> Have you tried downloading the latest Catalyst Version 10.6 Display Driver
> for Windows XP Professional from AMD's web site?
>
> http://game.amd.com/us-en/drivers_ca...=xp/radeonx-xp
>
> Read the Release notes about AMD Mobility Product Support. The ATI
> Mobility Radeon HD 3400 Series is listed as a supported product.


Thanks. I'll try this.


 
Reply With Quote
 
Kev
Guest
Posts: n/a
 
      07-15-2010, 10:57 PM
> Have you tried downloading the latest Catalyst Version 10.6 Display Driver
> for Windows XP Professional from AMD's web site?
>
> http://game.amd.com/us-en/drivers_ca...=xp/radeonx-xp
>
> Read the Release notes about AMD Mobility Product Support. The ATI
> Mobility Radeon HD 3400 Series is listed as a supported product.


OK, I have installed this, but what is it meant to do? There are no new
shortcuts in the start menu and the graphics card is still not showing up in
Device Manager.


 
Reply With Quote
 
Kev
Guest
Posts: n/a
 
      07-20-2010, 06:23 AM
> Perhaps the motherboard has built in video that needs to be turned off in
> BIOS? for the add on card to become active?
>
> The device manager should show something concerning whatever video chip or
> card is currently active.
>
> The video driver install log should show that the install process detected
> the added video card and other details, assuming it actually ran properly.
>
> An add on video card generally shows up as a "generic" video card/chip
> when the default video drivers are in use. These drivers are usually part
> of windows, and have Microsoft listed as the originator.
>
> A bad card may cause results similar to those you mentioned.


There is nothing in the BIOS to indicate the presence of built-in video.

Here is a screenshot of Device Manager:
http://homepage.ntlworld.com/zeniths...iceManager.gif


 
Reply With Quote
 
Kev
Guest
Posts: n/a
 
      07-20-2010, 06:23 AM
> Perhaps the motherboard has built in video that needs to be turned off in
> BIOS? for the add on card to become active?
>
> The device manager should show something concerning whatever video chip or
> card is currently active.
>
> The video driver install log should show that the install process detected
> the added video card and other details, assuming it actually ran properly.
>
> An add on video card generally shows up as a "generic" video card/chip
> when the default video drivers are in use. These drivers are usually part
> of windows, and have Microsoft listed as the originator.
>
> A bad card may cause results similar to those you mentioned.


There is nothing in the BIOS to indicate the presence of built-in video.

Here is a screenshot of Device Manager:
http://homepage.ntlworld.com/zeniths...iceManager.gif


 
Reply With Quote
 
Homer Jay Simpson
Guest
Posts: n/a
 
      07-20-2010, 07:38 PM
"Kev" <(E-Mail Removed)> wrote in message
news:VMb1o.303121$w51.67603@hurricane...
>> Perhaps the motherboard has built in video that needs to be turned off in
>> BIOS? for the add on card to become active?
>>
>> The device manager should show something concerning whatever video chip
>> or card is currently active.
>>
>> The video driver install log should show that the install process
>> detected the added video card and other details, assuming it actually ran
>> properly.
>>
>> An add on video card generally shows up as a "generic" video card/chip
>> when the default video drivers are in use. These drivers are usually part
>> of windows, and have Microsoft listed as the originator.
>>
>> A bad card may cause results similar to those you mentioned.

>
> There is nothing in the BIOS to indicate the presence of built-in video.
>
> Here is a screenshot of Device Manager:
> http://homepage.ntlworld.com/zeniths...iceManager.gif
>


You can use a free tool like Mobility Modder - ATI Version v1.2.0.0
available here:

http://www.hardwareheaven.com/modtool.php

to modify the latest Catalyst drivers to work with your laptop instead of
waiting for Dell to release one, which they never will.



 
Reply With Quote
 
Homer Jay Simpson
Guest
Posts: n/a
 
      07-20-2010, 08:04 PM
"Kev" <(E-Mail Removed)> wrote in message
news:VMb1o.303121$w51.67603@hurricane...
>> Perhaps the motherboard has built in video that needs to be turned off in
>> BIOS? for the add on card to become active?
>>
>> The device manager should show something concerning whatever video chip
>> or card is currently active.
>>
>> The video driver install log should show that the install process
>> detected the added video card and other details, assuming it actually ran
>> properly.
>>
>> An add on video card generally shows up as a "generic" video card/chip
>> when the default video drivers are in use. These drivers are usually part
>> of windows, and have Microsoft listed as the originator.
>>
>> A bad card may cause results similar to those you mentioned.

>
> There is nothing in the BIOS to indicate the presence of built-in video.
>
> Here is a screenshot of Device Manager:
> http://homepage.ntlworld.com/zeniths...iceManager.gif
>


I don't know if you've installed the Intel GM45 Express Chipset Family
driver, but it should resolve the PCI Device, SM Bus Controller, and Unknown
device under Other devices.

The driver is available at Dell's web site under Windows Vista 32-bit,
Chipset category, for the Studio Laptop 1537. This same 32-bit driver is
also used for Windows XP.

Here's the link but it will most likely be split over more than one line in
your mail/news reader so just join the lines together to get the complete
URL:

http://support.dell.com/support/down...&fileid=265073



 
Reply With Quote
 
Homer Jay Simpson
Guest
Posts: n/a
 
      07-20-2010, 08:12 PM
"Kev" <(E-Mail Removed)> wrote in message
news:3ir%n.247833$w51.238417@hurricane...
>I have just installed Windows XP on a laptop that was originally made to
>run Vista (a Dell Studio 1537). Obviously the official drivers were no
>use, so I have had to find suitable XP versions. All of the important
>components are now working fine, apart from the graphics card.
>
> The card is an ATI Mobility Radeon HD 3450. Unfortunately there are no XP
> drivers for it either on the Dell site, nor on the AMD site. But after
> some searching I found something that looks promising here:
> http://downloadnew.org/drivers/graph...816.html#dlink
>
> After downloading and unzipping, this turned out to be Catalyst, although
> I cannot tell which version it is. It won't install though. It keeps
> displaying messages like "Install Manager failed to initialize".
>
> I am not sure what to try next. Any suggestions would be welcome.
>


Someone has posted a 32-bit Windows XP Drivers Package for the Dell Studio
1537 here:

http://www.samsware.com/Downloads/15...32_Drivers.rar



 
Reply With Quote
 
PhxGrunge
Guest
Posts: n/a
 
      07-20-2010, 08:16 PM

"Homer Jay Simpson" <(E-Mail Removed)> wrote in message
news:i24tvb$g0p$(E-Mail Removed)-september.org...
> "Kev" <(E-Mail Removed)> wrote in message
> news:VMb1o.303121$w51.67603@hurricane...
>>> Perhaps the motherboard has built in video that needs to be turned off
>>> in BIOS? for the add on card to become active?
>>>
>>> The device manager should show something concerning whatever video chip
>>> or card is currently active.
>>>
>>> The video driver install log should show that the install process
>>> detected the added video card and other details, assuming it actually
>>> ran properly.
>>>
>>> An add on video card generally shows up as a "generic" video card/chip
>>> when the default video drivers are in use. These drivers are usually
>>> part of windows, and have Microsoft listed as the originator.
>>>
>>> A bad card may cause results similar to those you mentioned.

>>
>> There is nothing in the BIOS to indicate the presence of built-in video.
>>
>> Here is a screenshot of Device Manager:
>> http://homepage.ntlworld.com/zeniths...iceManager.gif
>>

>
> You can use a free tool like Mobility Modder - ATI Version v1.2.0.0
> available here:
>
> http://www.hardwareheaven.com/modtool.php
>
> to modify the latest Catalyst drivers to work with your laptop instead of
> waiting for Dell to release one, which they never will.
>
>


Go to http:\\www.omegadrivers.net for all mobility and regular ATI drivers.

They are already modded for mobility video cards.


 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: nVidia Quadro FX 3400 and 3450 (for gaming?) Benjamin Gawert Nvidia 15 01-09-2009 05:17 PM
Vista enterprise with Quadro FX 3450, should I use the vista driveror the newest driver from nVidia? hotister@hotmail.com Nvidia 1 08-05-2008 07:14 PM
Too much memory usage with recent catalyst drivers for Ati Radeon 9600 Mobility olrt ATI 1 02-28-2006 04:44 PM
Mobility X600 and Radeon Mobility 9700?? NYC XYZ Laptops 0 03-23-2005 08:22 PM
Recovery of pachard bell Club 3450 gh Packard Bell 0 10-09-2004 09:40 AM


All times are GMT. The time now is 07:47 PM.


Welcome!
Welcome to Motherboard Point
 

Advertisment