160GB drives show as 131GB drives

Discussion in 'Asus' started by Paul M, Aug 12, 2004.

  1. Paul M

    Paul M Guest

    I just installed a pair of 160GB Maxtor drives on my P4C800 and the system
    is only recognizing them as 131GB drives. Anyone know why and a solution to
    correct? Thanks.
     
    Paul M, Aug 12, 2004
    #1
    1. Advertisements

  2. Paul M

    KingGuardian Guest

    This info may help....check the ASUS web site or your motherboard driver cd
    for the file...

    http://support.intel.com/support/chipsets/iaa/sb/CS-009299.htm
     
    KingGuardian, Aug 12, 2004
    #2
    1. Advertisements

  3. Paul M

    Michael S. Guest

    which operating system and if XP is it SP1?
     
    Michael S., Aug 12, 2004
    #3
  4. Paul M

    Alex Guest

    I had the same problem.. WinXP without Service pack 1, cant recognise disks
    bigger than 137Gb or something.

    I had to get a Service pack 1 disk and use that.

    OR....

    If you download Service pack 2, Slipstream it into Your original XP disk.:)

    Slipstreaming info : http://www.neowin.net/articles.php?action=more&id=94
     
    Alex, Aug 12, 2004
    #4
  5. Paul M

    Michael S. Guest

    Paul M--are you using WinXP without SP1??

    MikeSp
     
    Michael S., Aug 12, 2004
    #5
  6. Paul M

    Kevin Miller Guest

    Even before I installed SP1a, XP recognized my 160G drives just fine.

    Kevin Miller

    "Either way, it is bad for Zathras."
     
    Kevin Miller, Aug 12, 2004
    #6
  7. Paul M

    Mark G. Guest

    Recognized mine just fine too after setting it up with Partition Magic 8
    rather than the software it came with.
     
    Mark G., Aug 12, 2004
    #7
  8. Paul M

    Paul Guest

    The boundary is caused by "48bit LBA". The address info is in a different
    format, when addressing a disk larger than 137GB (how disk manufacturers
    measure it). Your hardware supports 48bit LBA, in that the BIOS should
    be able to recognize the drive and address it. But you also need
    OS driver support, so the OS can do the same thing.

    There is a registry entry EnableBigLBA, that you can search for
    in Google. With a WinXP with SP1 already included, that registry
    entry might be there or might not (not sure).

    http://support.microsoft.com/default.aspx?scid=kb;[LN];303013
    http://support.microsoft.com/default.aspx?scid=kb;[LN];305098 (Win2K)

    As for the rest of the posters in this thread, who think they have a
    good install, be warned. For tools that prep a disk and only access
    the origin end of the disk, it may look like the drive is all set
    to go, when in fact it is not.

    My recommendation to large disk owners is:

    1) Back up critical information you cannot afford to lose on
    the new drive. This experiment, if it fails, will zap the
    contents of the disk. If this is a virgin disk and a fresh
    install of WinXP etc, you have nothing to lose, so skip this
    step. For those people who have their MP3 collection already
    moved to the new disk, don't do this test unless the MP3
    collection, email, settings etc. are currently backed up!

    2) Fill the disk with some large (1GB size is good) files. If you
    haven't succeeded in installing it correctly, the first file
    that writes to the 137GB mark, will result in the instant
    corruption of the file system. This is because, if you aren't
    truly in 48 bit mode, the address "wraps around" to zero and
    starts over again, and this wipes out the info at the beginning
    of the disk. Fill the disk in an orderly fashion, to make sure
    you hit the area just above 137GB.

    3) If you fill the disk with test files, and your system can
    survive a reboot with the full disk, then chances are the
    install of the big disk is a good one. If you fail the test,
    and the disk is gone, read the KB articles above, and try
    again.

    The reason for this experiment, is you don't want to find out
    in six months time, when you add an MP3 that brings the collection
    to exactly 137GB, that the disk isn't installed correctly. Your
    last backup could be too old to do you much good.

    HTH,
    Paul
     
    Paul, Aug 12, 2004
    #8
  9. Paul M

    Dr Teeth Guest

    Could it have had SP1? Without SP1 XP will *not* recognise 160 Gb
    drives.

    Cheers,

    Guy

    ** I may not be perfect, but I'm
    ** English, and that's the next best thing!
     
    Dr Teeth, Aug 14, 2004
    #9
  10. Paul M

    tokinkosh Guest

    Weird, glad I saved my money and got the p4p800-e deluxe cause I just put
    two 160 gig drives in raid mode for a 320 gig drive and works flawlessly.
    Windows XP SP2 and the drives are serial.
     
    tokinkosh, Oct 24, 2004
    #10
  11. Paul M

    GlassVial Guest

    I just installed a pair of 160GB Maxtor drives on my P4C800 and the system
    Flash the bios?

    -GV
     
    GlassVial, Oct 24, 2004
    #11
  12. Paul M

    Digby Guest

    Digby, Oct 24, 2004
    #12
  13. Paul M

    LeeBos Guest

    Sounds like you need an up to date OS, slipstream your XP CD to SP1 or SP2 and
    reinstall the OS. That should fix it.
     
    LeeBos, Oct 25, 2004
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.