2nd problem with P4P800-E Deluxe problem -- USB and 3rd IDE visible at boot but gone in Windows

Discussion in 'Asus' started by Greg Conquest, Sep 23, 2004.

  1. On my ASUS P4P800-E Deluxe, I have:

    - the board's built-in USB controllers and rear panel connectors (USB
    ports 1,2,3, and 4)
    - the board's USB_56 connected to the rear USB//Game/MIDI bracket
    - the board's USB_78 connected to my case's font panel's VCC1, USB+,
    USB-,ground and VCC2, USB+, USB-, ground connectors

    All this on a WinXP Pro SP2 system. I have not installed the USB 2.0
    drivers from ASUS.

    When I start my system, a USB keyboard or USB floppy drive is
    accessible from any of the USB ports. I can navigate the BIOS with the
    keyboard, but when Windows boots, no USB devices are accessible. The
    USB functionality disappears upon boot.

    Under Device Manager, Universal Serial Bus controllers, I have:
    4 working Intel 82801EB USB Host Controllers (24D2,24D4,24D7,24DE)
    1 working Standard Enhanced PCI to USB Host Controller
    5 conflicted USB Root Hubs (yellow exclamation point)

    Can anyone tell me what is going on?

    At boot, the two IDE drives I have connected to my Promise controller
    (set to IDE more in BIOS) are also detected, but they are not visible
    in Windows -- not even in Administrative Tools -- Computer Management
    -- Disk Management.

    So I have disappearing USB and Promise/IDE controllers disappearing.

    Thanks for any help.
    Greg Conquest

    PS My other problem,
    "installed wrong driver (RAID vs. IDE) for P4P800-E Deluxe Promise
    FastTrak -- can't uninstall and change! Help please." article posted
    yesterday is also still unresolved.

    ------ Greg Conquest ------
    Greg Conquest, Sep 23, 2004
    1. Advertisements

  2. Greg Conquest

    Nom Guest

    A quick look at your other post
    "installed wrong driver (RAID vs. IDE) for P4P800-E Deluxe Promise
    FastTrak -- can't uninstall and change! Help please"
    shows that your Windows Installation is well and truly shafted !

    In this order :

    Reformat, and Reinstall Windows XP.
    Install Service Pack 2.
    Insert the CD that came with your Motherboard, and install all the drivers.
    Visit Windows Update, and install all available Updates and Drivers.

    I've got the same board, and I've had no issues whatsoever.
    Nom, Sep 23, 2004
    1. Advertisements

  3. Greg Conquest

    Wim Zefat Guest

    Op Thu, 23 Sep 2004 14:15:39 +0900 schreef Greg Conquest:
    That last one should read Intel 8210EB USB*2* Enhanced Host Controller.
    Download and install the latest Intel chipset driver (if you haven't
    already done that) and reboot. If that doesn't solve it, simply delete the
    Standard Enhanced PCI to USB Host Controller from Device Manager, then let
    Windows redetect it (Action -> Find changed devices, or something like that
    in Device Manager). Windows should now find the right USB2 Controller.
    Can't really help you with that (I don't use the Promise controller). Did
    you try changing the driver without first deleting it? (Update driver from
    de driver tab in Device Manager, then point it to the driver you want.) Or
    starting in Safe Mode (press F8 on startup), then uninstalling the old and
    installing the new driver?


    Wim Zefat, Sep 23, 2004
  4. Greg Conquest

    Paul Guest

    Have you checked the USB Configuration setup in the BIOS ?
    (Section 4.4.6 of the manual.) A poster in Google claims
    his defaults to enabling four ports, so at least have a look
    in that setup and see if everything there makes sense.

    For the conflicted Root Hubs, is there any additional info
    in the Device Manager for them ?

    The four devices 24D2,24D4,24D7,24DE are USB 1.1 controllers.
    There is a controller for every two USB ports. For example,
    one controller feeds the two ports on the USB56 header, and
    one controller feeds the two ports on the USB78 header. The
    USB2.0 controller handles all the ports that are running at
    USB2 rates at the moment. The reason for this, is the USB2.0
    controller could talk to the PCI bus at 60MB/sec theoretically,
    so you really cannot afford to have more than one of these USB2.0
    controllers. So, the five entries for the controllers make
    sense, and suggest all controllers are enabled.

    I'm told that the Root Hubs normally show up when a device is
    plugged in. But, as they are conflicted, you'll have to trace
    further and see if there is an error reported for them or not.

    I'd recommend usbman.com as a reference web site, but the
    site is misbehaving right now.

    As for your PDC20378 problems, I'm at a loss as to what to
    suggest next, that would be likely to work. I have fooled with
    the AGP slot on my P4C800-E, and I can change it from operating
    in AGP mode, to operating in PCI mode, and back again. That is
    necessary some times, to get AGP drivers to install properly.
    I think that involved playing with the .inf file in the
    driver folder, but I don't remember the details now.

    Paul, Sep 23, 2004
  5. Thanks Paul, Wim, and "Nom" for the suggestions. I did take Nom's
    quick advice and:
    1) use the running XP to slipstream SP2 into my WinXPProSP1 CD.
    2) reformat the previously used 80GB boot drive (NTFS)
    3) reinstall WinXPProSP2 from the single, new CDR.
    4) begin reinstalling drivers.

    After reinstallation:
    1) I was of course able to choose the IDE driver for the Promise
    2) saw that all USB devices appear fine (entries were the same, but
    speed was USB2 (640MB read or write in less than 30 seconds to
    external hard drive -- USB and firewire performing almost the same)
    3) My other internal hard drives were visible. I'm formatting them now

    A new problem similar to one of the old ones did creep up again, I am
    using a Japanese keyboard, yet the keyboard driver I chose on this new
    OS install wasn't what I should have chosen. I had a HID keyboard as
    the driver, and it was limiting me from changing the driver to any
    other entry, because there were no other entries for HID. I
    uninstalled HID, and it would reappear at boot or at Add New Hardware
    -- even though I tried to do everything manually..

    So, I tried updating to an entirely different keyboard -- Fujitsu
    109/110 Key Japanese Keyboard in my case, and it worked!So, I am using
    a Fujitsu driver for my Logicool keyboard. I could never find
    Microsoft's standard Japanese 109/110 Key Keyboard driver.

    There seems to be something wrong with XP's aggressive driver
    monitoring/install. Yesterday, with the IDE and RAID drivers for the
    Promise Controller, I was totally unable to "update" from RAID to IDE
    because the update, IDE, was no newer than RAID driver and XP refused
    to comply. The workarounds I tried were stymied by XP repeatedly and
    in all circumstances keeping the drivers somewhere ready to
    re-install. The one tactic I didn't try was uninstalling and
    reinstalling while in Safe Mode. That might have worked.

    Thanks again, everything is looking fine now -- except for an
    occasional zz warping zz of the video. It was especially bad during
    the OS install, but I'll address that issue later.

    Greg Conquest


    ------ Greg Conquest ------
    Greg Conquest, Sep 24, 2004
  6. Greg Conquest

    Nom Guest

    Hurrah :)
    It's because it stores cached versions of all driver files, and installs
    them if it think it needs to.
    Delete the device from Device Manager, first noting the names of the files
    it's using from the "Driver Details" button in the "Driver" tab of the
    device's properties - they'll be something like Sil680.SYS and SilRAID.DLL
    or whatever.

    Search for the above File Names, and note their locations.

    Now reboot your machine with the XP CD in the drive, and select the Recovery
    Console - once in the recovery console, you can delete the driver files as
    noted above, from the locations noted above.

    On restart, XP will realise it has no driver files, and prompt you for
    them - you're now free to install any driver that you like.

    Bear in mind you should only have to do this VERY rarely - in almost all
    cases, you can force a specified driver by selecting the Advanced option,
    then "Don't search, I'll choose a driver to install" and directing it to the
    specified folder.
    If it was happening during the install, ie pre-driver-installation, then
    it's almost certainly a hardware issue with either your Graphics Card or
    your Monitor !
    Nom, Sep 27, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.