1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

600x wont boot if new CDRW/DVD is in ultrabay

Discussion in 'IBM Thinkpad' started by n8ghz, Apr 22, 2004.

  1. n8ghz

    n8ghz Guest

    Put in a new CDRW/DVD combo drive. LG GCC-4240N (built Feb-2003)
    Hot-swapped it in, and on resume, XP recognized it and I burnt a few
    CDR's
    and a CDRW.

    BUT...when I try to reboot...it wont !

    Gives me the black screen with the 'insert floppy' graphic indicating
    that I hit the F1 key...if I do..it gives me the I9990305 error and
    stops completely.

    If I rack-out the CDRW/DVD drive, it will boot normally

    If I put the old 24x CD reader in..all is well too.

    Nothing in ultrabay is also ok.

    Bios is ITET47WW

    Have the ITET55WW on boot floppy, but cant run it because of totally
    dead
    battery (wont charge at all..even on external charger)

    Help !!!

    thanks
    John, N8GHZ hamcall
     
    n8ghz, Apr 22, 2004
    #1
    1. Advertisements

  2. n8ghz

    E Brown Guest

    Odds are you've got the CD drive as your primary boot device in the
    boot order listing in your BIOS and it's having trouble with the new
    drive. Change your BIOS settings to boot from the hard drive first and
    see what happens.
    Must be the manufacturer - I switched to a Toshiba CDRW/DVD in my
    600X and it is bootable, but the original CD drive was a Toshiba as
    well.
    Emanuel
     
    E Brown, Apr 23, 2004
    #2
    1. Advertisements

  3. n8ghz

    n8ghz Guest

    Thanks for your reply, I have tried all combinations of Startup
    settings in Bios...CD is not cuurently selected at all. Right now,it
    is set to HD and nothing else. I have set it to floppy,then HD when
    external floppy in plugged-in and I want to boot from floppy (like
    when using IBM boot-floppy to flash HD or CD or system BIOS)

    What it acts like is that this new CDRW drive is MASTER and so is (?)
    the HDD1
    in the normal HD slot. I have looked closely at the original CD reader
    (also an LG) to see if there are any master/slave jumpers, but see
    nothing that resembles anything to change. I have not looked at the HD
    yet. But I doubt if I could make it slave without stopping it from
    booting at all.
    The plastic header that pushes on to the CDRW connector to allow it to
    adapt to the internal ultrabay connector only goes on one way, and is
    then held on by 2 screws. SO there is nothing you can do with any of
    those pins anyhow.

    Please understand that I do not care if I can boot FROM the CDRW/DVD.
    I would be perfectly happy to put the old CD reader in on those rare
    occasions that I need to boot from CD. What I do want..is to be able
    to boot from the standard HD and NOT have to pull this drive out just
    to be able to do so.

    If the darned PCMCIA card/ external drive-bay would work in XP ..I'd
    move the
    CDRW to that position..but XP dont support the 16bit PCMCIA adapter
    card.
    XP finds it,but wont run it.(have searched these threads for that
    too..guess IBM even says it is not supported in XP)

    I bet if I had something that would read the MASTER/SLAVE settings..I
    am guessing that would prove my theory.
     
    n8ghz, Apr 23, 2004
    #3
  4. n8ghz

    JHEM Guest

    Doesn't matter if they ARE both Master, they're on different IDEs, e.g.
    Primary and Secondary.

    Do you have the latest BIOS installed?

    FWIW, I've got the LiteOn LSC-24081 24X CD-RW/DVD combo drive in my old 600X
    and have no BOOT difficulties.

    Regards,

    James
     
    JHEM, Apr 23, 2004
    #4
  5. n8ghz

    n8ghz Guest

    Thanks James. You are correct. Since my first post, I remembered a
    utility I had from Nero that does some ID work on CD drives. I ran
    some tests with it.
    Yes this problematic drive and the original CD are both 'masters' and
    the laptop drivebay is apparently the secondary IDE controller. The HD
    is also 'master' but it is on the primary IDE buss. This confuses me
    even more, as I thought I have an answer. It gets a little weirder..I
    d/loaded all 6 floppy images from IBM to flash the CDRW. I tried all
    6, starting with disk 1,
    and none of them indicated that they contained a newer version.
    I must add that I was using the external floppy-drive and had the
    'new' CDRW installed at all times. The machine would boot from the
    floppy each time.
    In all 6 tries, the IBM flasher disks saw the CDRW as secondary/master
    and the HD as primary/master...the same as I had previously
    ascertained with the Nero tool.

    To respond to your question of whether I have the 'latest' bios...the
    answer is NO. I have the original version that came in the laptop
    version 1.03 ITET47WW

    ( I stated this in 1st message )

    I have a floppy ready with the latest bios version 1.11 ITET55WW
    but cant run it due to totally useless battery.

    I am going to grab a (hopefully) operational battery off of Ebay and
    do the bios upgrade ASAP.

    Beyond that..I have no clue

    John
     
    n8ghz, Apr 23, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.