8k9a-Epson parallel printer problem

Discussion in 'Epox' started by ChrisGG, Jan 4, 2004.

  1. ChrisGG

    ChrisGG Guest

    Hi

    I have an Epson stylus colour 600 printer that worked perfecly with my
    old Intel motherboard. Then I upgraded the motherboard to an 8k9a (rev
    1.0) with the latest bios, and I cannot get the printer to work - the
    status monitor always says it's off-line when I try to print a page in
    Windows(from a variety of apps.). The CPU is an XP 1900+ T'bred B and
    it's not overclocked. The PSU is new and well within its capabilities.
    I am using the same HDD as before with the same OS (98SE, with all
    updates applied except I'm still using IE5.01)and software etc - all I
    have done is installed the latest VIA drivers. I tried rolling back to
    previous VIA drivers, (4.35 and 4.42 IIRC), but that made no
    difference. It has been suggested elsewhere that changing the parallel
    port setting in the bios from ECP+EPP to just EPP might work, but it
    doesn't. Nor do SPP or "normal" modes, nor does changing the ECP DMA
    channel. I've also tried various versions of the printer driver
    downloaded from driverguide.com, but none works properly. I have
    searched the web (including the Epson and Epox sites) and usenet
    groups again and again. I went at this for two full days at least,
    swapping and installing and testing, and if I do get it to print
    something then it leaves great big gaps in the printout, or refuses to
    print properly over the network - always something is wrong.

    Next to that PC I have another with an Epox MVP3G5 socket 7 mobo
    running the same 98SE using the same VIA chipset drivers and the same
    printer driver, and when connected using the same bi-directional
    parallel printer cable it all works perfectly!

    I can only think that there must be a problem with the parallel port
    on the 8k9a. I tried contact cleaner to no avail. Perhaps there is
    some strange disagreement between Epox and Epson about the
    implementation of the parallel port because I have read more than one
    report of this type of problem with Epsons.

    Help would be much appreciated!

    Chris
     
    ChrisGG, Jan 4, 2004
    #1
    1. Advertisements

  2. ChrisGG

    Graham W Guest

    Very strange! How about trying to add a parallel port PCI card and see
    if it can talk to that?
     
    Graham W, Jan 5, 2004
    #2
    1. Advertisements

  3. ChrisGG

    ChrisGG Guest

    Yes, I would if I had one. Someone at Epox has suggested that I should
    try to re-install Windows, so I guess I'll take that option at some
    point - I was planning to do a clean install when I upgrade the HDD in
    a few weeks, anyway. In the meantime I'll just have to keep the other
    PC turned on as a glorified printer server!

    Cheers
    Chris
     
    ChrisGG, Jan 5, 2004
    #3
  4. ChrisGG

    Graham W Guest

    Just a thought - is the parallel port still mapped to 0x378h and IRQ 7?
     
    Graham W, Jan 6, 2004
    #4
  5. ChrisGG

    ChrisGG Guest

    Yes, it is, and device manager reports no conflicts. Maybe if I have
    some spare hours I'll start messing with this, but I don't want to
    upset the rest of the system which runs very well.

    Chris
     
    ChrisGG, Jan 7, 2004
    #5
  6. ChrisGG

    taifuun Guest

    Look the LPT settings under printer properties in windows, data format,
    spool settings, etc...
     
    taifuun, Jan 13, 2004
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.