8KNXP memory upgrade?

Discussion in 'Gigabyte' started by KatManDEW, Feb 12, 2005.

  1. KatManDEW

    KatManDEW Guest

    I have two 512MB DDR2 400 PC2-3200 memory modules in my 8KNXP and I
    want to add two more. Is this the right stuff, and a good price?
    http://www.buyaib.com/index.asp?PageAction=VIEWPROD&ProdID=2349
    The part number on my current memory is D512M400SA

    Another thing - I have BIOS version F5. What do I have to gain by
    upgrading the BIOS? Everthing seems to work fine now.

    Many thanks!
     
    KatManDEW, Feb 12, 2005
    #1
    1. Advertisements

  2. KatManDEW

    Mercury Guest

    Hi,

    Is this a rev 1 board?
    If so, then try adding ram - a matched pair (IE same make model) same as or
    better than you have already - LEAVE your current ram in the slots it is in!

    F6 was the bios that sorted a few ram issues, these issues were history
    around version F10 or so.

    So, I would have bios F5 backed up to the backup bios, install new ram, load
    setup defaults, up ram voltage 0.1v, and test with memtest86.
    Consider upgrading the bios to F10 or so, but dont' jump into F12 if you are
    installing RAID as there is apparently an issue with it on F12(?).

    Do one thing at a time, so that you know what breaks.

    BTW: i have 2gb on my rev 1: 1gb (2x512) corsair and 1gb of fast cheap
    stuff.

    Regards,
    -Tim
     
    Mercury, Feb 12, 2005
    #2
    1. Advertisements

  3. KatManDEW

    KatManDEW Guest

    I assume this is a rev 1 board since I got it 1 1/2 years ago.

    Thanks for the info.

    Don
     
    KatManDEW, Feb 12, 2005
    #3
  4. KatManDEW

    Gibbs Guest

    Gibbs, Feb 13, 2005
    #4
  5. KatManDEW

    KatManDEW Guest

    Wow! I'm glad you caught that. Thanks! I ordered the "most popular"
    selection from that web site.

    The types of memory available today are mind boggling. Much more
    complicated than when I built my first IBM XT clone ;-) That Crucial
    system for selecting memory is just the ticket. I'll use that from now
    on.

    Many many thanks for the help!
     
    KatManDEW, Feb 13, 2005
    #5
  6. KatManDEW

    KatManDEW Guest

    I have dual, mirrored, SATA drives. Doesn this create a problem for
    BIOS upgrading?

    Thanks.
     
    KatManDEW, Feb 14, 2005
    #6
  7. KatManDEW

    Mercury Guest

    read the notes for every intervening bios updae between what you have now
    and what you are going to. Check the read me's for the raid drivers, check
    the Intel and Silicon Image web sites...

    One of the early bios updates stated soemthing along the lines of Upgrade
    the Windows drivers First. IE install the more recent Windows XP RAID
    drivers (this applied to Intel ICH5R) then upgrade the BIOS. That was a long
    time ago, so proceed with caution and I recommend an image of the drives are
    taken first.

    If you have dual RAID 1 then you must be using both SATA raid's(IE SIL and
    Intel), so check for SIL details tooo.

    GB has been slow updating the ICH5R firmware, possibly the SIL firmware too.
    There are much more recent Intel drivers out - includes functionality for
    ICH6R (915 and 925 mobos) - these work fine in 8KNXP rev 1 - I use bios F10.

    BOL
     
    Mercury, Feb 14, 2005
    #7
  8. KatManDEW

    Bob Davis Guest

    I have the same board (8KNXP rev. 1) running RAID0 on ICH5R, with bios 13a
    and the latest RAID drivers. You are getting good advice so far, but I
    would consider the 13a bios because of an apparent problem with installing
    WinXP and RAID with earlier versions. I don't know the details of this
    issue, but I upgraded a month or so ago and it is stable.

    When I moved from PATA (single) to SATA (single), I updated my RAID drivers
    to the most current, then when I moved again to SATA RAID I was ready. I've
    had no issues with any bios I've tried so far, but if you upgrade be sure to
    save your old F5 as the backup first.

    As for adding more RAM, find the same brand and type, and buy a matched
    pair. That is your best bet for stable operation. When installed, run
    Memtest86 (latest version) for at least a few hours to test the RAM. Older
    versions may give false negatives, as I ran into when I upgraded to 2gb
    about one year ago.

    Before doing anything it'd also be good to make a total system backup.
     
    Bob Davis, Feb 16, 2005
    #8
  9. KatManDEW

    KatManDEW Guest

    Many thanks for all the info! I got the recommended memory from
    Crucial. I was worried because it does not have the same chip count as
    my original memory, but I installed it and it works! I ran through one
    complete set of testing with Memtest86 with no errors.

    I have dual "mirrored" SATA drives. I don't know which RAID mode that
    is. The vendor helped me set it up. When I check the Gigabyte BIOS
    download page, for the F6 BIOS it says;
     
    KatManDEW, Feb 18, 2005
    #9
  10. KatManDEW

    Bob Davis Guest

    Let it run repeatedly overnight just to be sure. If you must mix RAM with
    another brand, I would put Crucial at the top of the list.
    You have two options for RAID, ICH5R (on-chip) and SIL-3112 (on-board), and
    I know the former will run RAID1 but not sure of the latter. You should be
    able to tell by watching the boot process when the RAID controller bios
    screen pops up. Regardless, you have four SATA connectors on the board, all
    clumped together, and ICH5R pair are those closest to the front of the case.

    If you are connected to the ICH5R controller, update those drivers and go to
    the F13a bios. I've been using f13a for a month now with no issues, running
    ICH5R RAID0, so I feel safe recommending it. It has a fix for RAID systems
    installing WinXP, which is why I upgraded. Before updating your bios, save
    your old F5 to backup. For the RAID drivers, copy them to a floppy disk and
    when you update the 82801-ER driver point to that disk. For safety, create
    a system restore point beforehand.
     
    Bob Davis, Feb 18, 2005
    #10
  11. KatManDEW

    KatManDEW Guest

    It seems I'm not running ICH5R. I'm connected to the two SATA ports
    towards the back of the board/case, and I get a SIL-3112 meggase at
    boot up. The two front ports are connected to two unused external
    connectors on the back of the case. That being the case, I shouldn't
    need to update the CH5R SATA RAID driver before upgrading the BIOS,
    right?

    Can I connect another pair of SATA drives to the unused SATA ports.
    and if so do they need to be "mirrored", and can I mirror them if
    needed?

    I'll run the mem test all night tonight.

    Thanks again!
     
    KatManDEW, Feb 19, 2005
    #11
  12. KatManDEW

    KatManDEW Guest

    I tried to update my BIOS from the Qflash utilitty, and it looked like
    it worked, but it still says F5 when I boot.
     
    KatManDEW, Feb 19, 2005
    #12
  13. KatManDEW

    Bob Davis Guest

    You should see the bios version of the new bios, not the old. Keep in mind
    that this board has a quirk, that if you abort the boot process immediately
    after POST (i.e., reset), it may revert to the backup bios indefinitely
    until you change it. I haven't tried this with 13a, but some earlier bios
    versions did this.

    Go back into Qflash and specify "Main" as your boot bios, then see what
    shows at POST. If it is still F5 you should try the upgrade process again.
    I can't imagine why it wouldn't show correctly if the flash process reported
    success.
     
    Bob Davis, Feb 20, 2005
    #13
  14. KatManDEW

    Bob Davis Guest

    No, no need to update since you're you're running on SIL-3112.
    Your unused ports are on the ICH5R controller, and you can run one single
    drive, two singles, one RAID0 array, or one RAID1 array. It might even do
    JBOD, but I can't recall.
    If it passes an all-night run, you're good to go.
     
    Bob Davis, Feb 20, 2005
    #14
  15. KatManDEW

    KatManDEW Guest

    OK. I got the BIOS updated. The last part of the process, after it
    reads the file from floppy, didn't occur the first time I tried it.

    Only remaing bug I have is a SCSI/RAID controller with a yellow
    exclaimation on it in in Device Manager. It says "Windows cannot load
    the device driver for this hardware because there is a duplicate
    device already running in the system." It's been there since I first
    got the PC and everything appears to be working fine. Could this be
    the ICH5R controller?

    And of course I still have no joy with USB 2.0 devices in the front
    ports. But I got a internal card reader with a spare USB port on it,
    and connected it to the second pair of USB headers, and 2.0 devices
    work with it.
     
    KatManDEW, Feb 20, 2005
    #15
  16. KatManDEW

    Bob Davis Guest

    When you click on the "+" to the left of the SCSI/RAID Controller section do
    you see
    "Intel(R) 82801ER SATA RAID Controller"? Is there a yellow "!" next to it?
    If so, this is the ICH5R controller, and you should either disable it in the
    bios or install the driver for it.

    If I were you I'd install the driver and have it ready in case you want to
    use it in the future.
    That may be an issue with the case ports, not the mobo, as the USB headers
    on that board are all USB 2.0 and devices connected to them should work in
    high-speed mode.
     
    Bob Davis, Feb 20, 2005
    #16
  17. KatManDEW

    KatManDEW Guest

    Bob;

    You are a very helpful person. I am indebted to you for your generous
    help.

    The yellow "I" device is just listed as SCSI/RAID Host Controller".
    The next device listed is "Silicon Image SiI 3112 SATA Raid
    Controller" and it is working properly (no yellow "I"). I downloaded
    and tried to install the Inten ICH5R drivers, but the installation
    reported "Incompatable chipset" and aborted. I agree that I should
    install the driver for it so I will be ready to use it in the future.
    I checked the case ports, down to the connecters that connect to the
    motherboard header for continuity, and the appear to be wired
    correctly. I am baffled as to what else could be wrong with the case
    ports. Tere are two dual USB headers at that location on the
    motherboard, the second of which connects to a pair of USB connections
    on a "slot plate" on the back of the PC, and these two work fine with
    USB 2.0 devices.

    BTW: The BIOS upgrade seems to have corrected a problem with not
    POSTing with some of my new USB devices connected. It would hang
    before the memory test, but is breezes right past that normally now.
    It also seems to boot faste - before XP starts to load.

    Many many thanks. I wish I knew a way to repay you for all the help.
     
    KatManDEW, Feb 21, 2005
    #17
  18. KatManDEW

    Bob Davis Guest

    I appreciate the kind words. You're welcome.
    I'm sure this is the ICH5R controller that is not being ID'ed specifically
    by the OS since there are no drivers installed for it. Not sure why you are
    getting an incompatibility error message, but if you don't need the ICH5R
    controller at this time I would disable it in the bios. First, right-click
    on the item with the yellow "!" and uninstall it. Then reboot, enter the
    bios, and disable the "on-chip" SATA controller. Make sure you don't
    disable the "on-board" controller since it is the one your are using! The
    "SCSI/RAID Host Controller" entry in Device Manager should not be there when
    you reboot into XP again.

    As always, make sure you are thoroughly backed-up before doing any bios
    changes or updates! Murphy may be watching and ready to pounce.

    I seem to recall something about an incompatibility problem with my install
    of the ICH5R SATA RAID controller drivers, which if so obviously was
    resolved, but there is nothing in my copious notes, so I'm clueless. Write
    down the exact error message and do a Google search enclosing the phrase in
    quotes." Check both "Web" and "Groups" in Google and you should find
    something. If this doesn't help, add "ICH5R" or "81802-ER" after the quote.

    BTW, I keep a log of *everything* I do to the computer, hardware- or
    software-wise. This helps to trace problems that may crop up later, and is
    a Notepad TXT file that is accessible by an icon on my desktop. Here's an
    example over the past month. The references to "2200," etc., pertain to the
    time of day.

    02/21/05/2200: Uninst. NN v2.0.1, re-inst. NN v2.1.0
    02/19/05/1400: Inst. QuickTime v6.5.2. Uninst. bundled iTunes.

    02/16/05/1700: Uninst. Digital Pict. Magic, then re-inst. Shows NEF's in WE.

    02/16/05/2230: Inst. REST2514.EXE (Restore CF files)

    02/16/05/2330: Upgr. Digital Pict. Magic to v1.1.016

    02/10/05/1530: Inst. Linksys cable modem

    02/08/05/2100: Upgr. to NC 4.2.

    02/06/05/1200: Upgr. to Adobe Camera Raw v2.4 (plug-in). Had to delete
    Nikon*.8bi files again from NV upgrade below.

    02/04/05/2200: Upgr. to NV 6.2.3.

    ~02/01/05: Cable modem cutting out sporadically for past week. Cox tech
    says problem is with modem. Ordered new modem (Linksys) 02/04/05.

    01/19/05/1230: Inst. USB Mobile Rack

    All I can think of is that the cables or ports are not compatible with USB
    2.0. I would check the specs on the case to be sure, and maybe call their
    tech support for help. Try swapping USB headers on the mobo to see if the
    problem stays with the front panel. If it does then there is a problem with
    the front panel. If the problem goes away you know it is an issue with the
    header, but I'd put money on the front panel as the culprit.
    It's good that you updated the bios. I don't have the qualms about doing
    these upgrades with this mobo, if there is a need, now that a backup is
    available. In the past I would always have a spare bios chip handy in case
    of an update failure, which never happened, but now it seems to be something
    we don't need to worry about anymore. Just make sure you have the old,
    previously working bios version on the backup chip before updating.
     
    Bob Davis, Feb 22, 2005
    #18
  19. KatManDEW

    KatManDEW Guest

    Thanks again Bob. I'll Google the ICH5R problem, and swap the USB
    header. I'll bet it's the front panel because the bottom header works
    when connected to my new internal card reader which has an extra USB
    port on it.
     
    KatManDEW, Feb 26, 2005
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.