8RDA3+ SATA PROBLEM

Discussion in 'Epox' started by Sharp, Mar 10, 2005.

  1. Sharp

    Sharp Guest

    Hi

    I have an Epox 8RDA3+ rev1.x motherboard.
    WindowsXP fails to detect my Western Digital SATA HDD.
    Have latest BIOS.
    Enabled SATA in BIOS.
    SATA is set to the first boot device.

    Been told that you have to install the SATA driver during XP installation.
    If I have already installed winXP, then what I can do about this?
    I dont want to re-install winXP.

    Cheers
    Sharp
     
    Sharp, Mar 10, 2005
    #1
    1. Advertisements

  2. Sharp

    DaveL Guest

    How about "add hardware" in control panel, "show all devices", "have disk".

    DaveL
     
    DaveL, Mar 10, 2005
    #2
    1. Advertisements

  3. Sharp

    DaveL Guest

    I forgot you want this to be your boot drive. I guess you were wanting to
    ghost over your XP installation to the SATA drive. I don't know if that is
    possible. You would need a boot disk with SATA support. Maybe after
    loading sata driver and then installing ghost onto your hard drive..... ?

    DaveL
     
    DaveL, Mar 10, 2005
    #3
  4. Sharp

    R. C. White Guest

    Hi, Sharp.

    If you want to use that SATA drive as your boot device, then drivers for it
    must be integrated into your copy of WinXP during Setup. And the only way
    provided to do this is to run WinXP Setup again, press F6 when invited, and
    let Setup install it from a floppy diskette. This is not necessary for a
    SATA drive to be used as a secondary drive, but it is required to use it as
    the boot device. Even if you use something like Ghost, the ghosted drivers
    on your new drive will be the ones for your old boot device, not for your
    new SATA drive, and you'll still need to run Setup again.

    The only way WinXP Setup knows to get drivers that are not included on the
    WinXP CD-ROM is to load them from a floppy diskette. My EPoX 8KDA3+ came
    with onboard SATA RAID, but I don't use either SATA or RAID yet. (I boot
    from SCSI and have 2 IDE drives for data.) So I haven't installed SATA
    drivers, but I did have to use the F6 and floppy to install drivers for my
    SCSI host adapter.

    My 8KDA3+ User's Manual has instructions (in Section 5, S-ATA RAID
    CONFIGURATION) for how to "Prepare driver floppy" from the drivers on the
    CD-ROM that came with the mobo. Your 8RDA3+ probably has similar
    instructions. I haven't had to try it yet, but I expect that I will need to
    do this when I install a SATA drive - even without RAID - as my boot device.

    When you have the floppy ready, boot from the WinXP CD-ROM. During the
    hardware detection phase, early in Setup, watch for the message that flashes
    briefly at the bottom of the screen to Press F6 to install mass storage
    drivers, or something to that effect. Press F6, then wait. Setup will seem
    not to notice and will continue copying hundreds of files; then it will stop
    with instructions for using that floppy to install the drivers. After that,
    Setup will boot from that SATA drive for the first time and run the GUI
    phase to complete the installation.
    You'll want to do an "in-place upgrade", also known as a repair install.
    This completely reinstalls WinXP itself, but preserves your installed
    applications and data - and most of your tweaks. The official instructions
    for this are in this KB article:
    How to perform an in-place upgrade (reinstallation) of Windows XP
    http://support.microsoft.com/default.aspx?scid=KB;en-us;q315341

    Follow the instructions for Method 2 and note that you do NOT press "R" for
    Repair the first time it is offered, in Step 3. Press Enter here and then
    "R" when you get to Step 5. You might prefer MVP Michael Stevens' version
    of the same instructions:
    http://michaelstevenstech.com/XPrepairinstall.htm

    Either way, of course, you'll want to visit Windows Update as soon as you
    get your firewall and antivirus back in place to be sure that you have all
    critical updates.

    If you find a quicker and/or easier way to handle this, please let us know.

    RC
     
    R. C. White, Mar 11, 2005
    #4
  5. Sharp

    Playtimer Guest

    Hi!
    I have the same problem here. I have a Epox EP-8RDA3+ (rev.3x)
    motherboard, and I simply can't install brand new Western Digital (WD
    1600JD) 160GB S-ATA hard disk.
    I tried everything. BIOS is latest version, it's all set there, and I
    can see the device in BIOS.
    But, when i start installing Windows XP (SP1) it cracks.
    I know about S-ATA/RAID drivers from floppy, it all goes well, but
    when the setup wants to create a partition to install Windows, it
    stops and I get the message "can't format the partition-write error!
    The disk may be damaged, or You should check the connections..." and
    other yada yada.

    Then I tried to create partitions using "Partition Magic 8.0", and I
    get the same result. Can't format the partition (either as FAT 32 or
    NTFS). It blocks at 40 or 50% of work.

    I thought the disk is damaged, but it isn't. I moved it to another
    computer with Abit NF-7 S motherboard, and it works great. The
    Windows installation goes smooth, partitioning too, it all seems
    fine.

    The strange thing is, this ABIT mobo has the exact same S-ATA
    controller as my Epox (it's Silicon Image SI1312).
    And another thing... When I put Maxtor S-ATA hadr disk for testing on
    my Epox, it works just fine. When I put Western Digital IDE disk, it
    just won't work!
    So, I guess it's about compatibility between Epox and Western Digital,
    but I just can't believe this is happening!

    Does anyone have some advice? Please help!
    Thanks,
    Play
     
    Playtimer, Apr 24, 2005
    #5
  6. Sharp

    Sharp Guest

    Hi!
    I would e-mail Epox and what they have to say about it.

    Alternatively, have you tried to download the latest chipset drivers for
    your motherboard?
    As well as SATA associate drivers.

    Let me know how it goes.

    Cheers
    Sharp
     
    Sharp, Apr 24, 2005
    #6
  7. Sharp

    Sharp Guest

    You can also try installing winXP using the maxtor drive.
    Once installed, remove the drivers and device, and put in the Western
    Disigital.
    On boot, winXP should recoginse a new drive, and install the default drivers
    for it.

    Cheers
    Sharp
     
    Sharp, Apr 24, 2005
    #7
  8. Sharp

    Playtimer Guest

    Thanks for answering, Sharp! I'm about to mail Epox right now, hoping
    they have some sort of solution for this. Will let You all know
    what's new soon!
    Play
     
    Playtimer, Apr 24, 2005
    #8
  9. Sharp

    Playtimer Guest

    Well, I just got email from www.epox.nl , I must say their support is
    great! They have sent me new modified BIOS version which has
    obviously not available on the site (I suppose it's some beta
    version) with new Silicon Image SiI1312A v42.50 drivers.

    Testing today!

    Play
     
    Playtimer, Apr 25, 2005
    #9
  10. Sharp

    Sharp Guest

    Cool! let us know how it turns out.
    I'm sure it will work fine.

    Cheers
    Sharp
     
    Sharp, Apr 25, 2005
    #10
  11. Sharp

    suemccartin

    Joined:
    Oct 25, 2006
    Messages:
    5
    Likes Received:
    0
    Maxtor only for me.......

    I've been a maxtor fan for years, here's another reason why. Now we just have to hope that Maxtor fixes Seagate and not the other way around (seagate is awful at least on their ide products).
     
    suemccartin, Oct 25, 2006
    #11
  12. Sharp

    GinsuGuy585

    Joined:
    Nov 26, 2006
    Messages:
    2
    Likes Received:
    0
    If the new bios works, can you send me a copy?


    I just bought 2 sata drives and have the same issue.
     
    GinsuGuy585, Nov 26, 2006
    #12
  13. Sharp

    marko

    Joined:
    Jan 8, 2010
    Messages:
    1
    Likes Received:
    0

    I know that your post is more than 4 years old but can you send me that bios too? I have the same problem with my motherboard. Pleaseeeeeeeee... I really need it.
    Website epox.nl does not work any more.
     
    marko, Jan 8, 2010
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.