A7N8X-E Deluxe SATA "Device not Detected, utility disabled"

Discussion in 'Asus' started by B. Ruiz, Jr., Dec 11, 2003.

  1. B. Ruiz, Jr.

    B. Ruiz, Jr. Guest

    Board was working fine for a day. Now when booting, SATA controller
    BIOS will report there is a problem and to press F4 to enter raid
    utility. When I press F4, the message "device not detected, utility
    disabled" will appear. The system halts with a boot failure message.
    Strange thing is that both drives are identified by the SATA BIOS (by
    their make and size). I assumed this was due to a problem with the
    primary drive, so I disconnected the primary, and tried rebooting with
    just the secondary connected (running raid-1). The same thing
    happens. I am stuck. Is this a RAID problem? If so, how do you get
    into the utility to rebuild the raid. Is this a controller problem?
    I have already ordered another board to see if this fixes it, but was
    wondering what else I could try before swapping them. Any help would
    be appreciated.
     
    B. Ruiz, Jr., Dec 11, 2003
    #1
    1. Advertisements

  2. B. Ruiz, Jr.

    Ben Pope Guest


    I take it you are using RAID then? There's a windows utility, not sure what
    it can do 'cos I don't have RAID.

    I recommend using the latest BIOS (1007) and drivers (1.0.0.40) and seeing
    if the problem persists.

    Info in my FAQ.

    Ben
     
    Ben Pope, Dec 12, 2003
    #2
    1. Advertisements

  3. B. Ruiz, Jr.

    owlbird Guest

    Hi, it's easy. Please visit http://www.ptdd.com and download Partition
    Table Doctor to help you
     
    owlbird, Dec 12, 2003
    #3
  4. B. Ruiz, Jr.

    JBM Guest

    I just bought the registered version of this file.
    Mcafee said it was infected with the W32/Valla.a virus
    I've sent ptdd.com an e-mail about it.
    reboot.exe is the file that's infected.
    The virus doesn't do much, just puts a statement about
    world peace at the end of files. Could eat up a lot of drive
    space.
     
    JBM, Dec 13, 2003
    #4
  5. B. Ruiz, Jr.

    JBM Guest

    Received two emails from support at ptdd.com the first said that
    their security scanner found no problems. Then two hours later
    the second email said there was a problem in reboot.exe.
    And there was an attachment containing pdd.zip without
    reboot.exe. So it looks like they fixed the problem
     
    JBM, Dec 13, 2003
    #5
  6. I have exactly the same problem. Did Partition Table Doctor fix it?
     
    RichardBarrett, Dec 17, 2003
    #6
  7. B. Ruiz, Jr.

    dnc_tn Guest

    Since it is "dual channel" memory, does this mean I "have to" use two
    sticks of ram or can I still use one stick of ram. I read the
    documentation and still couldn't get this information.

    I'm a Newbie trying to build a system with this board is why I ask.

    I want to use a single stick of "pc3200 512meg nonECC unbuffered" of
    Ram.

    thanks.
     
    dnc_tn, Dec 17, 2003
    #7
  8. You can use a single stick of RAM, and it will run happily in
    single-channel mode.
     
    Peter R. Fletcher, Dec 17, 2003
    #8
  9. B. Ruiz, Jr.

    dgk Guest

    Sure, that's what I have now. I was able to overclock much better with
    just one stick.
     
    dgk, Dec 17, 2003
    #9
  10. B. Ruiz, Jr.

    Ed Guest

    It will work with 1, 2 or 3 sticks of any compatible ram for that board,
    but to utilize dual channel memory feature on the mobo itself (which
    only results in about a 5% boost) you would want to install 2 or more
    sticks of ram in one of the following sequence: Sockets 1&3, Sockets 2&3
    or Sockets 1,2&3.

    HTH,
    Ed
     
    Ed, Dec 17, 2003
    #10
  11. Can anybody help, please?

    I have an A7N8X deluxe 2.0 with dual Maxtor 160GB SATA drives
    which I tried to configure as RAID-1. A problem
    occurred when copying from primary to secondary. Now I, too, get
    the "Device not Detected, utility disabled" message after the BIOS
    runs and can't move beyound this.

    I've tried updating the BIOS to Uber 1007 and that has no effect.
    MaxBlast3 can't see the drives at all when run from Windows on
    an IDE drive. Powermax just fails. SiliconImage's SATARaid Windows
    utlity can't see the drives. But they're there because the BIOS
    reports them and even offers me the option to boot Windows 2K from
    them (it crashes, of course).
    What do I do next? There seems no way back.
    Does anyone have experience of Partition Table Doctor in fixing
    this problem?

    Any help would be much appreciated.
     
    RichardBarrett, Dec 18, 2003
    #11
  12. B. Ruiz, Jr.

    dnc_tn Guest

    Already have 2 of the 3 ram banks full with '256Meg pc3200 nonECC
    unbuffered RAM', wanted to know if I can use that last remaining bank
    for a 512M stick or do I have to "Match" everything up, like all 256's
    or all 512's or all 1gig's etc...

    many thanks.
     
    dnc_tn, Jan 12, 2005
    #12
  13. B. Ruiz, Jr.

    Paul Guest

    If you have 256+256 in slot 1 and slot 2, balance it with
    a 512MB stick in slot 3. Slot 1 and slot2 are on one
    channel, while slot 3 is on its own channel. (You can see this
    for yourself, by looking at the motherboard, and noting
    where the termination resistors and Vtt filter caps are
    located. You'll see orderly columns of tiny components
    for those two functions, one set of terminations per
    channel.)

    The memory interface interleaves between channels, so if
    each channel has an equal amount, you get dual channel
    behavior all the way to the top of memory. The Nforce2
    is different than the Intel and AMD controllers, as
    they use the "Uber DIMM" concept, and two DIMMs are
    essentially treated as a single 128bit wide DIMM. The
    Nvidia design treats the two channels as separate 64bit
    suppliers of bandwidth, and DIMM matching requirements are
    relaxed. For the Nforce2 apparently, only matching the
    quantity of memory on each channel, is all that is
    required for best results. The memory can only run
    as fast as the slowest stick being used, so mixing a
    dud 512MB with two 256MB Corsair sticks, would be a
    mistake if you want to get the best use of the more
    expensive memory.

    I modified a copy of memtest86, and added the ability to
    test memory bandwidth as a function of memory address.
    If you put 512+512 on one channel, and a single 512MB
    stick on the second channel, then 2/3 of the memory space
    runs at dual channel bandwidth. This is the result I got
    when the channels weren't matched - I had 1.5GB total
    memory in this unbalanced configuration, and the top
    512MB of it is slower than the rest.

    http://groups.google.ca/[email protected]

    Address Memory bandwidth
    (Hex) (MB/sec)
    08000000 1435 ; (This is address 128MB)
    10000000 1435
    18000000 1435
    20000000 1435
    28000000 1435
    30000000 1435
    38000000 1435
    40000000 916 ; (This is address 1GB)
    48000000 916
    50000000 916
    58000000 916

    Few applications are as memory dependent as the memory
    test program above, so real applications won't see such an
    extreme difference. Many people note only a 5% difference
    or so, between single and dual channel, which is a lot less
    than the measurement here is showing. Maybe someday, someone
    will run one of those Photoshop test suites, and give us the
    real story on the difference between single channel and dual
    channel on this board.

    HTH,
    Paul
     
    Paul, Jan 12, 2005
    #13
  14. B. Ruiz, Jr.

    Helinut Guest

    Im sure the above poster has a far greater knowledge than me, but there is
    one thing I think he has missed.
    The A7N8X motherboard has a version called A7N8X-X. If you have this board,
    it is not a dual channel board so "balancing" the channels doesnt matter.
    However I suppose it is irelevant as I would also say go for 512Mb as there
    is no need to balance the memory on a non dual channel board.
     
    Helinut, Jan 13, 2005
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.