A7N8X-E deluxe + SiL 3112 + 1TB Spinpoint problem

Discussion in 'Asus' started by tanky, Oct 7, 2008.

  1. tanky


    Oct 7, 2008
    Likes Received:
    Evening everyone. Incoming long post!

    I hope you all might be able to help me with this one.
    I have a PC here that runs as a home server. It's running Windows XP Pro.
    The motherboard is an A7N8X-E Deluxe that has the Silicon Image 3112 SATA controller. This has worked in the past, when this PC was my main machine, it had a 37GB Raptor in it. Now, it just has a 320 GB IDE drive.
    With it now serving media for my Pinnacle Showcentre, the harddisk is full so I've bought a Spinpoint F1, the 1TB version.
    I connected the drive to it but it hung just after POST, the bit where it says the controller BIOS version. I assume this is because the drive has 3 Gb/s interface and the controller has a 1.5 Gb/s interface. I would have hoped the controller would have fallen back, but this one doesn't.
    SiI BIOS version is 4.2.27 and driver is
    I tried to update the BIOS, but the siflashtool halts with error "no silicon image controllers were detected". Most odd. Device manager says it's there, there's no drive on it though.
    If I try to update the driver to using device manager, Windows rejects my choice saying it could not find a better match etc etc. In other words, the current driver is better than the one I want to install, when it's clearly a later version.

    I've tried Samsungs 1.5G utility to change the interface speed of the drive (to 1.5 so that an old mobo can see it) but you have to boot from a cd rom to use it and of course, my system hangs before you get that far. If I remove the drive, it boots up into windows just fine. Without the drive attached I can also run the 1.5g util, though it's pointless with no drive for it to work on.

    To rule out a faulty drive, I connected the drive to my main PC (the one I'm using now) and that finds the drive in BIOS and in Windows. If I use the Sansung 1.5 bootable CD ROM util, the util fails miserably, running out of memory and all kinds of rubbish.

    I hoped there might be a way of changing the HDD controller properties from within Windows, but I've not yet found anything that will do it.

    I've bought a cheap PCI SATA controller card and that will arrive in a few days, hopefully I can persuade that to run the drive, but until then, I'm sort of at a dead end...

    Unless any of you fine gentlemen know better!


    tanky, Oct 7, 2008
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.