A7N8X series "incomplete RAID set" bug - my experiences and solution

Discussion in 'Asus' started by Andy C, Jul 19, 2005.

  1. Andy C

    Andy C Guest

    Hi all,

    I've just experienced a RAID 1 bug with my A7N8X-E Deluxe that caused me a
    lot of trouble. It was the "incomplete RAID set" bug that's been reported
    here a few times as I've noticed from Googling the newsgroups. However,
    none of the archived messages I saw mentioned the final outcome of the
    problem for the users who experienced it. Specifically, there was no
    report of whether or not the users had been able to recover their date.

    I am happy to report that I was able to recover my data. Because of this,
    I thought I'd report how I did so in the hope of helping someone else who
    might also be experiencing the same problem.

    The problem occurs completely out of the blue, with an error message at
    bootup that says "Incomplete RAID set! Please press <Ctrl+S> or F4 to enter
    RAID utility". When you try to enter the RAID utility, you get the
    message, "No device detected, Utility disabled! Press any key to
    continue...". Assuming the RAID 1 set is not the boot drive, you'll get a
    normal boot, but the logical RAID drive won't be seen. Because of this
    "Catch-22" situation, it appears that you're stuck - you need to get into
    the RAID utility to fix the problem, but can't because the machine won't
    let you.

    It turns out the problem is due to a buggy BIOS in that section of the BIOS
    that's provided to ASUS by the RAID chip vendor, Silicon Image. Some good
    documentation on this can be found at the URL below (watch for word wrap).

    http://groups-beta.google.com/group....mainboard.asus&rnum=1&hl=en#28ecacc04b1759df

    This post indicates that Silicon Image updated their BIOS and has the
    Silicon Image version numbers of their corrected BIOS. The Silicon Image
    BIOS version numbers don't match the ASUS BIOS version numbers though.
    Because of this discrepancy, the poster, Paul, didn't know if the ASUS BIOS
    versions he posted actually had the Silicon Image fixes incorporated into
    them. He posted that version 1013 for the A7N8X0-E Deluxe was the latest.

    I downloaded and installed version 1013 for the A7N8X0-E Deluxe and it
    ended up fixing my problem, but not without jumping through several hoops
    to get there. I'll describe that next. In the text that follows, the text
    of the BIOS messages might not be exactly correct, as I didn't write them
    down. However, the basic ideas are there.

    After flashing this new BIOS and rebooting, I received a message to the
    effect that the RAID array had to be rebuilt, and that I should enter the
    RAID utility. I was glad the "incomplete RAID set" message went away. I
    entered the utility successfully, and chose the "rebuild now" option. I
    used the prompts on the right instead of the confusing selection, as it was
    impossible to tell which of the two menu items was really the selected one.
    The rebuild took a couple of hours for two 300 GB disks. I thought I'd be
    home free afterwards, but it was not to be. After rebooting again, I
    received a message something like "RAID array in critical state. Enter
    RAID utility". I entered the utility, which was a pain because it seemed
    the computer didn't want to trap the Ctrl-S keystroke. I had to try
    rebooting a few times for it to work. When I got back into the RAID
    utility, one of my disks was marked as "Current" and the other as
    "disconnected". Try as I might, there was nothing in the RAID utility that
    allowed me to remove the "disconnected" status from the second drive. I
    didn't have the guts to try the "Delete RAID set" option for fear of losing
    my data. I'm glad I didn't.

    Since one drive was marked as "Current", I tried rebooting into Windows,
    and lo and behold, Windows now recognized the drive and all my data was
    still there! But only one disk was active. I remembered seeing something
    somewhere about a GUI RAID utility. Turned out I had it on my disk. It's
    called "Java SATA RAID", which is bundled with the drivers for the Silicon
    Image RAID controller. I installed and ran it. Turns out this utility has
    tons more options than what's in the BIOS. There was an option to remove a
    drive from the RAID set. I did so. The drive was now no longer marked as
    "disconnected". I rebooted, hoping to be able to rebuild the RAID array in
    the BIOS utility. However, I got a nasty surprise, as the BIOS RAID
    utility just locked up on me. I powered off, then tried again a few more
    times with the same result. Turns out the GUI utility put the controller
    in a state that the BIOS utility didn't know how to get it out of. I
    re-ran the Java SATA RAID. This time, I chose the option to add the drive
    I had previously removed back in to the RAID set. After doing this, I
    rebooted again and got into the BIOS RAID utility. This time it worked
    fine, and allowed me the option to rebuild the RAID array again. I didn't
    have much confidence that this would fix the problem, since it didn't fully
    fix it the first time. I was also wondering whether the problem was due to
    having one bad drive. I chose to rebuild the RAID set. This also took
    about two hours.

    The result - fixed! No error messages at bootup. Both drives marked as
    "current". I've apparently not lost any data at all. So I am a happy
    camper now.

    Well, that's it. I hope the story of this little misadventure of minw
    helps someone out there who might rightfully be freaking out over this
    problem.

    Good luck,
    Andy
     
    Andy C, Jul 19, 2005
    #1
    1. Advertisements

  2. Andy C

    antiproduct

    Joined:
    Jun 20, 2012
    Messages:
    1
    Likes Received:
    0
    Thanks.

    Good thing google indexes these things. I had to register just so I could thank you Andy. A small business I help out had a "server" running with this board. The bug you described just started today. Glad I was able to find this. Thanks for posting all the information about it.
     
    antiproduct, Jun 20, 2012
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.