A7N8X: USB Card Reader not working

Discussion in 'Asus' started by Loom, Jun 23, 2003.

  1. Loom

    Loom Guest

    Hi,

    my internal 6-in-1 card reader is giving me headaches:

    after installation is install the 4 removable card deivces correctly,
    eveything is running smooth. But after the next boot the card reader isn't
    recognized anymore. Windows XP is halting for 10 seconds during boot, then
    the power LED of the cardreader goes off and that's it. Every once in a
    while it works, let's say every 10 bootup cycles.

    Strange enough, but if you unplug and the replug the usb cable while running
    windows, eveything works again. Up to the next boot, then it breaks again.
    The 2 USB and the firewire port of the reader are still working all the
    time.

    Then I hooked the device to a powered USB Hub where it get recognized
    everytime. Just not with the motherboard USB plugs. No matter which ones.

    It's definatly no software problem, since it also doesn't work on a freshly
    installed Windows XP with the recent nvidia drivers.

    Any help is greatly appreciated
     
    Loom, Jun 23, 2003
    #1
    1. Advertisements

  2. Loom

    Tony Cue Guest

    Then I hooked the device to a powered USB Hub where it get recognized
    Surely this would indicate that there is not enough power to the device?
    What size/brand PSU are you using? If it works fine with a "powered" USB
    hub, there's your problem!

    My IntellMouse occasionally powers off, I just unplug it, put it back in and
    all is fine.
    --
    Regards,
    Tony. (Remove Q to reply via e-mail)

    "Tell me, Mr. Anderson, what good is a phone call if you're unable to
    speak?"
    Agent Smith, The Matrix...
     
    Tony Cue, Jun 23, 2003
    #2
    1. Advertisements

  3. Loom

    Loom Guest

    Surely this would indicate that there is not enough power to the device?
    Thanks, but I don't think it's the PSU, it's an 350W Enermax.

    And don't forget, it's working if you unplug it and plug it in again.
    The device itself shouldn't consume more power then let's say a mouse.

    From all I read now, the Nforce2 chipset is not only very picky about
    memory, but also
    on USB.

    Michael
     
    Loom, Jun 23, 2003
    #3
  4. Loom

    bongdaddyboo Guest

    Ditto, but both a combined CF/SM reader, a single SM reader and a Creative
    Muvo.
    Same again here.
    And again....
    Bingo. That's how you solve it (more below)
    Here goes:

    It's apparently a know problem that Nvidia are aware of and their published
    solution is to use a USB 2.0 compliant hub. A USB 1.1 hub won't do the
    trick.

    Here's why:

    For some reason, certain hardware - USB card readers, USB thumb drives, USB
    MP3 players, USB hard discs (all USB 1.1 btw, not newer USB 2.0 versions) -
    doesn't seem to fully adhere to the specification for timing signals as per
    the USB spec, or at least Nvidia's interpretation of the USB spec that
    they've implemented in the Nforce2 chipsets, and as such the timing signals
    for these devices exhibit some "jitter", thus causing some of the behaviour
    you've described above.

    Without going into too much more detail, the way to get around this problem
    is to connect a USB 2.0 hub inbetween the motherboard and the USB device
    causing problems. USB 2.0 hubs apparently have some additional curcuitry
    that reclocks the timing signal, and by feeding the 1.1 device through the
    2.0 hub, the supposed "jitter" is removed and the motherboard receives a
    clean and jitter-free timing signal from the 1.1 device. Result = the USB
    1.1 kit works without a single problem now.

    I'd recommend you try that solution as it's definitely worked for me. I
    know there's a little extra expense involved initially, but it's definitely
    worth it just to have the attached kit working all the time.

    HTH
     
    bongdaddyboo, Jun 23, 2003
    #4
  5. Loom

    Loom Guest

    my internal 6-in-1 card reader is giving me headaches:
    Thanks!

    I read that NVidia explanation before. From my point of view it's just
    ridiculous that it's
    not working. I'm beginning to regret that I bought the Nforce Board. A lot
    of strange things
    going on beside that. Not to speak from the infamous BIOS death symptom.
    Don't want to hold
    breath everytime I save CMOS settings. Why didn't they include a second BIOS
    chip in the retail
    package? Well, let's wait for the KT600.

    But back to topic: The external hub where the cardreader is working is just
    a plain USB 1.1 hub,
    and not a 2.0 as Nvidia explained.

    So what's going on here? I definately won't buy another hardware because
    it's not that comfortable to
    connect the cardreaders backpanel cord to an external hub because it's only
    15 centimetres short.

    Damn! :-(

    One could think that USB is a brand new cutting edge technology. Shouldn't
    happen.

    Michael

    Michael
     
    Loom, Jun 23, 2003
    #5
  6. Loom

    bongdaddyboo Guest

    Other than this particular problem my A7N8X-Deluxe has been a peach to be
    honest.
    It's quite odd. I've actually tried it with a 1.1 hub and it doesn't work.
    Whack the 2.0 hub in and Bingo, it works!

    The 2.0 hub's definitely running 2.0 mode as well, as I've got an Epson
    scanner through it as well as a 2.0 external drive enclosure.

    It's got me stumped really, but the FUD via smoke and mirrors that Nvidia
    feeds us has me convinced they're right!! Either that or they've arsed the
    design of the chipset slightly and are trying to pass the blame to the
    manufacturers of the "faulty" hardware.... because after all, Nvidia's
    I know. Doesn't happen on an old MSI KT3-UltraARU board I've got either....
    make your own conclusions.
     
    bongdaddyboo, Jun 23, 2003
    #6
  7. Loom

    bongdaddyboo Guest

    Paul wrote:

    <SNIP: quoted contents of above link>

    That's the info I came across recently.
    You'd think they would do that.
    Ah. Now from what I can remember, I've disabled spread spectrum on the KT3.
    I'd have to make a journey to confirm though as my sister's got the board
    now. Can't remember offhand how spread spectrum's set on this Asus board
    but it's probably something worth checking I think, although I definietly
    remember it had the 1003 BIOS when installed and SS wouldn't "stick" as
    you've said above. Now it's got the latest 1004 BIOS for the 1.06 board
    I'll drop in, check it out and report back.
     
    bongdaddyboo, Jun 24, 2003
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.