A8N-SLI Deluxe and linux - anybody got wake on LAN working?

Discussion in 'Asus' started by jwk, Jul 10, 2005.

  1. jwk

    jwk Guest

    I'm having trouble getting wake on LAN to work in linux.

    This is my situation:

    linux-2.6.13-rc1-mm1 on both machines
    full-duplex 1000 mbit switch
    A8N-SLI Deluxe bios version 1006 (1011 doesn't shutdown the machine
    properly...)
    the A8N-SLI Deluxe is connected via the forcedeth network card.

    wake-on-lan with

    etherwake -i eth0 <MAC-address of forcedeth port)

    doesn't work. Neither does

    etherwake b -i eth0 <MAC-address of forcedeth port)

    However, and this is the strange part, if I unplug the cable on the
    A8N-SLI Deluxe, it starts. So I know the motherboard is capable of
    waking up and I think my BIOS settings are OK, it's just that it
    doesn't when I send it the magic packet.

    If it works for you, what BIOS are you at and what settings in the BIOS
    do you think make it work?

    Thanks,
    Jurriaan
     
    jwk, Jul 10, 2005
    #1
    1. Advertisements

  2. jwk

    jwk Guest

    For the record, it seems that this is something in the cards firmware,
    which you turn on by

    ethtool -s eth0 wol g

    Just in case anybody uses google and find this thread.

    Jurriaan
     
    jwk, Jul 11, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.