A8N5X & SATA

Discussion in 'Asus' started by Injun Ear, Aug 10, 2008.

  1. Injun Ear

    Injun Ear Guest

    Trying to get XP to boot on a WD3200 SATA drive on the A8N5X Mobo.
    I Keep getting "Error Loading OS"

    I ran the WD disk and set up the drive
    I can see the drive in BIOS
    I can run XP on an IDE drive and see the SATA drive in My computer
    I can ghost XP from the IDE to the SATA
    If I do a repair install on the SATA and press F6, it can't see the
    drivers I copied to a floppy.
    If I do the repair install on the IDE and press F6, it loads the drivers.
    If I ghost the repaired install from the IDE to the SATA it still won't
    boot.
    If I run the repair install on the SATA without the F6, it still won't boot.
    I can run the repair console and do Fixboot and get same results.

    Where is the correct SATA driver for this MOBO. I tried downloading
    SATA drivers from ASUS, but all I get are 3 files...raidmgmt.ini,
    sata.bmp and sata.exe. F6 doesn't recognize any of these. I downloaded
    drivers from the Western DIgital site and it recognizes them when I'm
    running the IDE drive, but not when I'm trying to repair the
    installation on the SATA drive.

    Anybody have any suggestions??
     
    Injun Ear, Aug 10, 2008
    #1
    1. Advertisements

  2. Injun Ear

    Injun Ear Guest

    Nope, I tried it with a floppy in the drive. The Sata.exe does
    absolutely NOTHING. I found another one that makes a floppy, and I did
    it. But when I tried it with F6, it wouldn't load anything.
     
    Injun Ear, Aug 11, 2008
    #2
    1. Advertisements

  3. Injun Ear

    Paul Guest

    If you want a small download, try this page.

    http://tastycomputers.com/support/download/nvidiaraid-4.htm

    This file is 437KB and is self extracting.
    http://tastycomputers.com/_private/downloads/nvidia/chipset/f6_nforce4sata_666.exe

    disk1
    idecoi.dll
    nvata.cat
    nvata.inf
    nvata.sys
    nvatabus.sys
    nvcoi.dll
    nvide.nvu
    nvraid.cat
    nvraid.inf
    nvraid.sys
    nvraidco.dll
    nvuide.exe
    txtsetup.oem

    That page also has some instructions.

    "If you have an NVIDIA nForce 4-SLI chipset and are using Parallel ATA (IDE)
    hard drive(s) or SATA drives without a RAID configuration, you should be able
    to use the Microsoft native storage driver built into Windows." i.e. WinXP SP1 or later

    What a floppy filled with those files would be good for, would be:

    1) A RAID array connected to the Nforce4, and already set up as an array
    by using the BIOS RAID setup screen. (nvraid.sys etc)

    2) While the Microsoft driver can be used for an EIDE disk on a ribbon cable,
    I believe the above floppy would also be capable of installing an optional
    Nvidia IDE driver (nvata.sys). Such a driver may have an additional level
    of caching. As a proponent of the "keep it simple" school of computer
    installs, I like to avoid such things. The Microsoft driver offers the
    broadest compatibility, when it comes to hardware and also software tools.

    In other words, I don't think the 437KB floppy image above is going to help,
    but if you wish to experiment, it is available. There might have been
    something similar, offering the same kind of named files, on the
    motherboard CD.

    The "txtsetup.oem" helps the Windows installer understand what the floppy
    drivers offer. I don't know if a floppy filled with random files, and
    an INF, would be accepted by the Windows installer or not. It might
    require the txtsetup.oem file, as some "glue". The txtsetup.oem file
    is a text file, and can be read using Notepad.

    HTH,
    Paul
     
    Paul, Aug 11, 2008
    #3
  4. Injun Ear

    Injun Ear Guest

    I already have that. I downloaded it yesterday. But when I try to
    install to the SATA drive and press F6, it gets to the part where it
    says no mass storage. and kicks me back out. I hit S like it says and
    nothing. If I try that while installing to the IDE, it shows some
    drivers. But if I load them onto the IDE and then ghost that to the
    SATA, still no good. According to what all the websites are saying, I
    shouldn't need a driver if I'm not doing RAID. This is just a single
    SATA drive. Just got it from WD. It's a recertified drive to replace
    one that I sent back under warranty. I wanted to this SATA drive in my
    backup computer.

    I had no trouble at all ghosting the images when I installed a new 500
    GB SATA drive in THIS computer that I'm on right now. This one is an
    Intel Q6600 on a Gigabyte MOBO, W/Intel chipset.
     
    Injun Ear, Aug 11, 2008
    #4
  5. Injun Ear

    Injun Ear Guest

    Well, I wiped the disk clean and did a clean install and it works. No
    F6 drivers, no nothing. Just works. Thanks to all for your help.
     
    Injun Ear, Aug 11, 2008
    #5
  6. Injun Ear

    Injun Ear Guest

    This is what I discovered. You DON'T NEED any F6 SATA driver if you are
    only running one hard drive. All you need to do is a clean install from
    scratch. Format the drive as part of the install process. It'll work!!!
     
    Injun Ear, Aug 12, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.