Access denied by access control list

Discussion in 'Apple' started by David Ryeburn, Mar 6, 2010.

  1. Background: Three computers, two connected to our combination ADSL
    modem/Ethernet and wireless router by Ethernet, the third connected
    wirelessly. One computer (G5 iMac) misbehaves as described below, and didn't
    do this until probably today. The other two computers do not have this
    problem. All three are running Mac OS 10.4.11.

    The problem is that if the G5 iMac tries to connect to any website within
    the blogspot.com domain, or to blogger.com, I get the following message.

    Forbidden

    You were denied access because:

    Access denied by access control list.

    This happens regardless of the browser used (I tried seven of them). I *can*
    reach www.google.com.

    I created a new user, giving it administrative privileges. The same thing
    happened. I rebooted using an external Firewire drive as boot drive. That
    worked normally. While booted from the Firewire drive, I ran DiskWarrior
    (nothing wrong) and Disk Utility in both Repair Files and Repair Permissions
    modes. Nothing was found wrong.

    It seems to me that something is wrong inside the system software, but what?

    David
     
    David Ryeburn, Mar 6, 2010
    #1
    1. Advertisements

  2. Then

    (1) Why wasn't it on the router until a couple of days ago? This inability
    to go to things in the blogspot.com domain, or to blogger.com, only
    appeared a couple of days ago. The same router, unmodified by me or to the
    best of my knowledge by anyone else, has been there (as a part of the
    combined ADSL modem + router + WiFi setup, all in one little gadget) for
    nearly a year.

    (2) If it's on the router then how come I can go to these domains with my
    Digital Audio G4 (Ethernet connected just like my wife's G5 iMac which is
    the computer with the new problem) and with our MacBook (connected
    wirelessly)? They all use the same router.

    (3) Why is the G5 iMac capable of going to these domains *IF* I boot it up
    from an external Firewire drive?

    I suppose I can solve the problem by completely re-installing Mac OS 10.4.11
    and all applications on the G5 iMac. My wife has an awful lot of things on
    that computer, and I do not look forward to doing that with pleasure.

    David
     
    David Ryeburn, Mar 7, 2010
    #2
    1. Advertisements


  3. The MAC address of the G5 iMac is the same when I boot it from the Firewire
    drive (which works OK) as it is when I boot it from its internal drive
    (which didn't work OK). So that can't be.

    It might get a different local 192.168.1.xy IP address. It might even get a
    different local 192.168.1.xy IP address from one time to another when I boot
    from the internal drive, and then reboot from the same internal drive. But
    the router presents one and only one IP address to Telus, my ISP.

    ....

    I don't remember (and now I can't tell), but the errors with Safari,
    Firefox, Camino, SeaMonkey, iCab, Netscape 9, and some ancient OS X version
    of Mozilla were all pretty much the same.

    ....


    None of the browsers had any trouble reaching any other sites that we use.
    They all had problems with blogger.com and blogspot.com. In particular there
    was no problem with google.com. I don't know about blogit.com or
    blogster.com.

    And now it's too late to check. I said "They all had problems" in the
    preceding paragraph, not "They all have problems", because today the doggone
    thing is working fine, just as it did for years. I didn't change anything .
    Maybe blogger.com or blogspot.com did, but if so I don't understand how they
    could distinguish the iMac booted from its internal drive from the iMac
    booted from the Firewire drive, or from the other computers. Doesn't the
    rest of the Internet just see the one IP address the router gets from Telus,
    and that's that?

    David
     
    David Ryeburn, Mar 7, 2010
    #3
  4. David Ryeburn

    J.J. O'Shea Guest

    I suspect that you (or someone else with admin access) set an ACL block list.
    You might want to go to
    <http://arstechnica.com/apple/reviews/2005/04/macosx-10-4.ars/8> and/or
    <http://www.ehow.com/how_2117633_block-access-websites-macos-x.html> and have
    a look at how to set, and unset, ACLs.
     
    J.J. O'Shea, Mar 7, 2010
    #4
  5. David Ryeburn

    Király Guest

    I had to sit through a semester of David's first year calculus lectures.
    Grammar was fine, but the sheer speed of it all... I'm grateful he took
    a sip from his coffee fairly often so I could get everything written
    down.
     
    Király, Mar 7, 2010
    #5
  6. But you passed, and you learned something, right?

    David
     
    David Ryeburn, Mar 8, 2010
    #6
  7. Or (and admittedly this is a way-out-there SWAG), what DNS name server
    are you using? The one that Telus supplies to you or something like
    OpenDNS? I used OpenDNS until I discovered they were blocking specific
    sites for whatever criteria they failed to report. A flame to their
    admin and a switch to my ISP's DNS servers and I'll never look back.
     
    Michael Vilain, Mar 8, 2010
    #7
  8. David Ryeburn

    Király Guest

    I did, yes I concur.
     
    Király, Mar 8, 2010
    #8
  9.  
    David Ryeburn, Mar 8, 2010
    #9
  10. I'm pretty much convinced the problem has to have been in this room. And not
    between keyboard and chair.
    That's reasonable. If it happens again (I hope not), what should I do? By
    the way, inspecting the hosts file revealed nothing peculiar (today). It was
    identical to the one on my (unaffected) Digital Audio G4.

    David
     
    David Ryeburn, Mar 8, 2010
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.