Accessing BIOS in ASUS K55N laptop

Discussion in 'Asus' started by Rhino, May 25, 2013.

  1. Rhino

    Rhino Guest

    Does anyone know how to access the BIOS in a new ASUS K55N laptop
    running Windows 8?

    Most of the articles I've found say it should come up when you hit F2
    upon seeing the ASUS logo but it's not happening for me. Some articles
    mention some kind of security feature to keep someone from booting into
    the BIOS and using it to break into the computer but I have yet to find
    anything that tells you how to satisfy the security so that you can
    actually see the BIOS. I can't find anything in the manual about this.

    I'm trying to deal with a minor malware issue on the laptop as I'm
    dealing with much bigger issues on my desktop and getting into the BIOS
    is turning out to be as big a can of worms as dealing with my large hard
    drive is on the desktop.

    It seems like EVERYTHING has to turn into a major hassle, even something
    as basic as getting into my BIOS....
     
    Rhino, May 25, 2013
    #1
    1. Advertisements

  2. Rhino

    Paul Guest

    http://dlcdnet.asus.com/pub/ASUS/nb/K55VM/E7187_eManual_K55VM_K55VS_Z104.pdf

    Pg.33

    [F2] to enter BIOS
    [esc] for popup boot menu

    And in the index, look for the Appendix around page 80 or so.
    When I clicked a hot link in the document, it took me to the wrong
    page. But scrolling the document down to around 2/3rds of the way,
    you'll find the Appendix. And it has some pictures of BIOS screens.

    If the thing is password protected, there'd be a password prompt.
    And if it has some "whizzy" security method, such as a finger print
    reader, there would likely still be a prompt visible somewhere. It
    wouldn't be very friendly to just sit there with a black screen and
    not do something.

    Paul
     
    Paul, May 26, 2013
    #2
    1. Advertisements

  3. Rhino

    Rhino Guest

    Thank you for your help, once again!

    Unfortunately, F2 (I assume you mean FN-F2) is NOT working. I have tried
    that umpteen times after finding that suggestion in various google
    searches.

    I assume I need the BIOS because I am trying to change my boot sequence
    (temporarily) so that it can boot from a USB drive so that I can fix a
    small problem there.

    I've now spent several HOURS trying to figure out how to get into my
    @%$*^%*%(*&%^ BIOS (or UEFI as it is apparently called now). This is
    RIDICULOUS. It should be easy to get into the BIOS and always has been
    on every other computer I've owned.

    I've also tried F1, F10, Esc, Del and a few other things, all of which I
    was assured would (or should) work but NADA. That pesky BIOS just
    refuses to come up.

    I am getting so frustrated you wouldn't believe it. Nothing, even
    something as simple as getting into my BIOS, seems to be possible
    without hours of effort! I keep wanting to do one or two simple things
    as a confidence builder but everything turns into a huge hassle.

    I'm just going to stop messing with the laptop and use it to backup my
    C: drive for the hard drive issue on the desktop. That's the most
    important issue on my plate, at least as far as computers go. Even
    supposedly "easy" problems will just have to wait.....

    Thanks again!
     
    Rhino, May 26, 2013
    #3
  4. Rhino

    Paul Guest

    Do you have a USB keyboard handy ? Try plugging it into the
    laptop, and press F2 or Escape from there, and see if it behaves
    any differently. Also, look for LEDs to light on the keyboard,
    as proof the keyboard is getting power. My keyboard has three
    LEDs, and that's how I can tell it is powered.

    Paul
     
    Paul, May 26, 2013
    #4
  5. Rhino

    Rhino Guest

    The laptop keyboard is working fine. I can type emails, surf the web,
    turn the speakers on and off (Fn-F10), etc. etc. It's just the BIOS that
    won't come up for love or money. I think it may be this security
    precaution thing to keep strangers from changing the BIOS without your
    consent. Someone mentioned it on a website but didn't bother to explain
    how it works. I'm guessing there's some technique to satisfy it - like
    provide a password - but that's just a guess; I haven't been prompted
    for a password! Besides, I don't think I ever set a BIOS password when I
    set up the machine; if I did, I don't remember doing so. I've never been
    in the laptop BIOS.

    --

    It's also refusing to copy from the network share for the desktop C:
    drive to the folder I set up on the laptop D: to receive the image of
    the C: drive. It's STILL complaining that it needs permission from the
    administrator for that even though I gave it read and write access.

    I can't seem to get ANYTHING to work today, no matter how simple it
    seems to be.

    I'm going to go try the water tap. At the rate things are going, it'll
    explode and the house will flood....

    Maybe the Luddites were on to something....
     
    Rhino, May 26, 2013
    #5
  6. Rhino

    Paul Guest

    The BIOS key is just F2, not Fn-F2.

    That manual I downloaded, shows the F keys as a separate row. The Fn
    key, triggers the "blue" definition of the keys.

    And while the manual is chock full of "password" features, I'm still
    not seeing anything that matches the symptoms ("ignore keyboard").

    There are two implementations for passwords. In the "naive" implementation,
    just two passwords, are stored in CMOS RAM. Pulling the CMOS battery,
    erases the passwords, and allows access to the machine. My desktop computer
    works that way.

    On "business laptops", a separate 2K EEPROM, rather than CMOS RAM, is
    used. You can pull out any and all batteries, and it will do you no good.
    The manual in such a case, will mention returning the machine to the
    factory or to a repair center, to have the password reset. Or a dude in
    Eastern Europe promises to do it for around $50. That method involves
    making an electrical connection, as far as I know. It's not keyboard
    magic or a special program or anything. It's some way of re-programming
    the password EEPROM.

    And that EEPROM, is not the same thing as the BIOS chip, which is a
    completely separate and larger capacity device, by comparison.

    A business laptop must be treated differently, than a "naive" non-business
    machine. It's the kind of machine, that you *do* set the password, in
    order to prevent malicious visitors from setting the password on you.
    For high security machines, this is a favored "joke" - not that I consider
    this to be funny. Machines armed to the teeth with passwords, are pure misery.
    I would much rather just have a single password on the hard drive, and
    full disk encryption, than go through all sorts of "lock the laptop"
    baloney. It's more likely to backfire, and lock you out of the machine.
    Since all the info of interest is on the hard drive, FDE is all you
    really need. The rest of the thing could be left open.

    Paul
     
    Paul, May 26, 2013
    #6
  7. Rhino

    Rhino Guest

    I have gotten into the BIOS. You were right. It was just F2, not Fn-F2.

    You have no idea how frustrating that was! I've done several google
    searches and read umpteen of the hits that came up, plus posted to an
    online forum and whenever they suggested F2 (or F1 or F10), I always
    assumed that they were implying Fn-F2. I wasn't sure about that but it
    seemed to be right because if I want to toggle my sound, F10 alone
    doesn't do it, I need to do Fn-F10. Therefore, it seemed reasonable that
    I would need to do Fn-F2 whenever I wanted to get into the BIOS. I
    replied to each post that gave me a suggestion and explained in my
    reply, like I did to yours, that I had actually tried Fn-F2 and none of
    the others ever came back and said "No, use F2 alone, NOT Fn-F2". I
    suppose they hadn't come back after offering their suggestion.

    For what it's worth, I am 98% sure I did try F2 at least once but given
    the finicky nature of getting into the BIOS, I didn't tap it enough
    times or at precisely the right time so it failed to work.

    I found options for two or three different passwords in the BIOS, none
    of which were set yet. I also found a secure boot option, which claimed
    to be enabled already. I'll be darned if I can tell what the secure boot
    option does. I didn't have to jump through any hoops to get to my BIOS
    (aside from the standard one of hitting the right key at the right time).

    While there is personal stuff like email addresses and private emails
    that I wouldn't want others to see, I am very reluctant to start
    slapping passwords on this or any other computer. For one thing, I've
    already got a gazillion different accounts and passwords and it's a
    definite hassle to maintain records of them. (I'd never backed up my
    password list from the desktop so when it was in the shop, I still
    couldn't use the laptop to do some of what I needed to do because the
    passwords were in the shop with the computer.) Another reason I'm
    reluctant to password-protect a computer is an incident we had at work
    20 years back. I don't remember the details now but I know that we had
    to get onto a particular machine and the password was no longer known
    for some reason and even our wiliest tech couldn't think of any way into
    that machine. I don't remember if he EVER figured out how to get into
    that machine or whether we just had to find some way to do what we
    wanted without it. Since then, I've always figured that if I password
    protected a computer, I was bound by Murphy's Laws to have it come back
    and bite me one day so I didn't password-protect any computer.

    I'm still tempted to do so on occasion and may live to regret that I
    haven't but, so far, I'm sticking with that policy.

    Thanks again for your help, Paul. You're the only one that came back
    after I said I'd done Fn-F2 to set me straight.

    Now, a brief detour into this malware problem on the laptop and the file
    permission problem in copying my desktop C: to my laptop, and I can get
    back to the Main Event of the day, my desktop and it's troublesome 3 TB
    drive....
     
    Rhino, May 26, 2013
    #7
  8. Rhino

    satishsood1 Guest



    I have ASUS K55VM.
    Alt+F2 works with my system.
    You may try the same.
     
    satishsood1, Dec 13, 2013
    #8
  9. Rhino

    vanlam.nilp Guest

    Press ESC or Alt+F2 when logo Asus appear. To make sure you can access the BIOS, you should Restart the computer and do this.
     
    vanlam.nilp, May 14, 2014
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.