1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Acquiring/running Windows XP Tablet PC Edition on non-tablet PC

Discussion in 'Tablet PC' started by palfvin, Jun 1, 2006.

  1. palfvin

    palfvin Guest

    I've purchased an external tablet/monitor (from buslink) and want to run
    Tablet PC applications with it using a "conventional" PC. Can you tell me my
    options for acquiring a version of Windows XP Tablet PC Edition to run?

    Thanks,
    Pete Alfvin
     
    palfvin, Jun 1, 2006
    #1
    1. Advertisements

  2. You can't get it unless you are a MSDN subscriber.
     
    James Kendrick, Jun 1, 2006
    #2
    1. Advertisements

  3. palfvin

    Chris H. Guest

    As James indicated, if you're a developer, use your MSDN subscription.
    Otherwise, the only place Windows XP Pro and the Tablet PC Edition 2005 is
    available is pre-installed on a Tablet PC.
     
    Chris H., Jun 1, 2006
    #3
  4. What Tablet PC applications do you want to run:? The only thing you CANT get
    is the input panel and journal/sticky notes. You can download the
    recognizers and run most tablet pc software without the Tablet PC OS.

    Search google for "Tablet Recognizer Pack"
     
    Josh Einstein, Jun 1, 2006
    #4
  5. palfvin

    facebrake Guest

    Limit of frustration has been met. Please, someone help me restore my
    now mundane microlaptop to its former tablety effervescence.

    I own an ACER travelmate c110. Up until today, it had XP Tablet Ed
    2005 preinstalled. I decided I was going to use this tablet for work.
    This is when the trouble starts: I recognized that I'd deleted a few
    pieces of software shipped with the system and had no way to reinstall
    them (so I thought) short of reinstalling the OS. I proceeded to do
    this by attempting to boot from the restore CDs using my external USB
    DVD drive.

    The restore CDs would boot, but hung before actually beginning the
    restore process. I then tried to restore from the HDD images, which
    apparantly don't exist for some reason. Then I read on the MS site
    that 'Windows XP SP2 includes Tabled PC edition 2005..' and given that
    I own a spare copy of XP left over from a computer I trashed when I
    bought my Dell, I decided to simply reinstall the full OS using that.
    No problem, I thought.

    As you know, and I *now* know, tablet PC edition isn't in fact included
    in SP2. Updates didn't help. I got most everything else working
    beautifully but now ZERO digital ink funcitons work; as far as this
    thing is concerned the WACOM HID does not exist and the wacom site
    advises against installing the drivers without Tablet PC edition or the
    SDK..

    I'm not a developer and I'm stuck with a nice tablet PC running XP with
    none of the flashy functions I deserve, and a useless copy of tablet PC
    2005 embedded in images I have no way of installing.

    Can someone tell me how to make my tablet handy again?

    If there is no recourse and I will be unable to use my tablet edition
    2005, please at least help me get the digital ink functions working so
    i can use AlphaTap and the franklin covey stuff with it.

    Regards,
    Shane
     
    facebrake, Jun 10, 2006
    #5
  6. palfvin

    Chris H. Guest

    You should have recovery media with the unit, furnished by Acer. I believe
    there are three Recovery CDs (perhaps more or less) furnished with the unit.
    Take a look in your User's Guide. If you don't have the CDs, and purchased
    the C110 from Acer, I would contact them and order replacement media. They
    can charge you a nominal shipping and handling fee, but the purchase price
    of the OS was already paid when you bought the Tablet PC. If you bought it
    from a private party, you need to contact them.
     
    Chris H., Jun 10, 2006
    #6
  7. palfvin

    facebrake Guest

    I have the CDs, all fine and dandy - but the bootable CD hangs when it
    tries to load the device driver necessary to continue with the
    reimaging. I've stepped through the autoexec.bat, and it hangs on the
    command "a:\duse init >NUL"

    The searches I've done in google turned up one poor soul with the same
    problem, a year and a half ago. Acer wouldn't help him and essentially
    said he needed to just buy their drive, which is a firewire drive and
    works with the recovery disks. However, I searched for thier drive,
    and it's $250 for an external, which doesn't even write DVDs. I didn't
    get this in the first place because of the price, and I already owned
    an external DVD burner at the time.

    There Must be a way to make these recovery CDs work over USB.. or some
    other route I could take to make this all work out!
     
    facebrake, Jun 10, 2006
    #7
  8. palfvin

    terri Guest

    You could try using an external floppy drive and see if you can boot with it
    to either load the driver or try to navigate to the CD/DVD.

    Many early Tablets used specific drives. I know that some Toshiba owners
    had luck using a Sony drive rather than the Toshiba. I have a Targus drive
    that works with my Toshiba.
    --
    Terri Stratton
    Microsoft Windows MVP - Tablet PC
    Microsoft Featured Community
    http://thetabletpc.net
    Owner/Publisher
    http://themediacenterpc.net
    http://writepc.com (a new site for Ultra-Mobile PCs)
     
    terri, Jun 10, 2006
    #8
  9. palfvin

    facebrake Guest

    Gosh, I love it when I'm able to find someone who actually provides a
    SOLUTION to a problem within the means specified rather than a way to
    avoid it by spending extra money on useless stuff!

    Luckily I found just such a guy on an obscure tablet forum, and for
    posterity (since USENET was unable to satisfy my queries before) here's
    the solution I found - WHY it works and where I found it, complete with
    a nice chunk of keywords.

    Acer travelmate c110 tablet will not restore to factory original from
    external USB cd or dvd optical drive that is not the STOCK firewire
    drive (which Acer charges too much for) because their Disk 1 - system
    disk contains a MSDOS utility called DUSE for mounting the CD drive
    that does not support a majority of external USB drives. The included
    restore CD 1 will typically hang after booting during execution of
    autoexec.bat on the line [ a:\duse init >NUL ] because of this
    incompatibility.

    The solution is a bit involved and -might- require the purchase of at
    least one ISO manipulation utility to fix it; this outline is verbose
    instructions for creating a new, compatible system disk for use with
    your USB drive using the ORIGINAL ACER disk and modifying the boot
    image included.

    Original solution is credited to user 'leekej' at
    http://www.tabletpcbuzz.com and the original posts by him are at [
    http://www.tabletpcbuzz.com/forum/topic.asp?TOPIC_ID=22587 ] ... I've
    changed and added a bit here because the instructions were vague but
    complete enough to allow me to make a working system disk eventually.

    ----------------------

    - Search for and download 'usb_cd.sys'.. Google it.

    - Use a utility (I used the evaluation version of ISOBuster) to create
    and save an ISO file of the system disk. YOu may now remove the system
    disk and throw it away, or shatter it with a hammer, since it's
    essentially garbage to you if you've gotten this far. You COULD choose
    to save it for posterity.

    - Open that ISO file with ISOBuster and EXTRACT the BootImage.img from
    the 'Bootable CD' information in the left pane. You could possibly
    extract the 110BOOTIMG.BIN as a source of the same information if your
    utility doesn't access the boot sector the same way; these images
    appear identical. You can stop using ISOBuster now.

    - Another utility (I used the evaluation version of WinImage) to open
    the Boot Image and..
    . delete 'duse.exe' from the image
    . replace with 'usb_cd.sys'
    . extract 'autoexec.bat' and 'config.sys'
    . edit those two files appropriately (see below)
    . remove the originals from the image
    . replace with the ones you edited
    . save the new Boot Image. *phew*
    . YOu can stop using WinImage now.

    - ANOTHER utility (I used WinISO since I own it) to open the ISO file
    you made earlier. This utility has a menu option 'Bootable CD' and in
    that dropdown there's an option to 'Load Boot information from file'..
    select taht option and select the new Boot Image you just made. SAVE
    the ISO file now.

    - Use your favorite burner to burn the ISO.. creating your new, USB
    ready bootable system restore CD.

    You'll probably get some funky errors with the restore app since it's
    not great - I found that ejecting and reinserting the system disk the
    first time it asks for disk 2 is a good idea.. and any time you get a
    read error, just eject and reinsert the correct disk. I just finished
    with this and it worked perfectly, now my tablet works like a tablet
    again.

    Also I didn't bother to check if the three above mentioned utilities
    are capable of doing all the steps I mentioned individually.. I was
    partly following someone else's steps at the time. More power to ya if
    you can just do it with one app.

    Here's the edits for the autoexec and config..

    ---------config.sys

    [MENU]
    MENUITEM USBCD, Only For USB CDROM Boot Up
    MENUITEM 1394CD, Only For 1394 CDROM Boot Up

    [USBCD]
    device=a:\himem.sys
    device=usb_cd.sys /D:CD-R01
    ;device=a:\Emm386.exe noems
    dos=high,umb
    devicehigh=ramdrive.sys /E 4096
    ;devicehigh=a:\duse.exe verbose drives=2 xfer=8 sec=2048 late cdwait=0
    cdd=CD-R01 VFLOP

    [1394CD]
    device=a:\himem.sys
    dos=high,umb
    devicehigh=ramdrive.sys /E 4096
    SHELL=A:\Command.com /P /E:512
    DEVICEHIGH=INI1394.SYS /BOOT=A
    DEVICEHIGH=I1394CD.SYS /D:CDROM1

    [COMMON]



    ---------autoexec.bat

    @echo off
    REM
    REM Acer Recovery CD AUTOEXEC.BAT file
    REM Copyright 1999 Acer Incorporated
    REM
    REM ----------------------------------------

    set Master=z:
    set SRC=z:

    cls
    echo Checking the status of your hard disk...
    echo.
    rem Checking hard disk status
    goto Format

    :Format
    REM Hard disk exist and formated.
    a:\tools\smartdrv.exe
    set HDD=FORMATED
    call a:\SetRamdr.bat
    IF NOT '%RAMDRIVE2%'=='' GOTO ramok
    GOTO xit


    :ramok
    set COMSPEC=%RAMDRIVE2%\COMMAND.COM
    copy a:\command.com %RAMDRIVE2%\ > NUL
    copy a:\Tools\*.* %RAMDRIVE2%\ > NUL
    path=%RAMDRIVE2%\;%MASTER%a:\Disusb20.com
    goto %config%

    :USBCD
    ;a:\duse init >NUL
    lh A:\MSCDEX.EXE /D:CD-R01 /S /M:5 /V /L:z
    a:\tools\smartdrv.exe -z >NUL
    copy z:\model.dat %RAMDRIVE2%\ > NUL
    REM
    A:\tools\Power.exe >NUL
    %RAMDRIVE2%
    recovery.bat
    goto xit


    :1394CD
    :ramok
    lh A:\MSCDEX.EXE /D:CDROM1 /S /M:5 /V /L:z
    %RAMDRIVE2%\smartdrv.exe -z >NUL
    copy z:\model.dat %RAMDRIVE2%\ > NUL
    LH %RAMDRIVE2%\Power.exe >NUL
    %RAMDRIVE2%
    recover.bat
    goto xit

    :xit

    -------------------------------------

    If this post helps you, drop me an email to let me know I saved you
    from the eight hours of cursing and being inconsolably irritated I just
    suffered.

    -faBr
     
    facebrake, Jun 11, 2006
    #9
  10. palfvin

    Chris H. Guest

    Excellent information, and thanks for posting. The Tablet PC Buzz is hardly
    "obscure" though, since it is about the foremost (and original) Tablet PC
    forum on the web. :cool:



     
    Chris H., Jun 11, 2006
    #10
  11. I'd hardly call Tablet PC Buzz "obscure". It's far more popular than any
    other tablet forum, including this one.

    --
    Josh Einstein (Tablet PC MVP)
    Einstein Technologies
    Tablet Enhancements for Outlook - Try it free: www.tabletoutlook.com
    Chock full of inky goodness!


     
    Josh Einstein, Jun 11, 2006
    #11
  12. palfvin

    facebrake Guest

    Conceded. Perhaps it's me being old-school, but I'd always referred to
    Usenet as the pinnacle of free idea exchange, and it's always the first
    place I look when I need answers to my technical problems. 98% of the
    time, it's the only place I have to search.. so I suppose it's only
    subjectively speaking that other things are obscure.

    Since solving my issue I've found a wealth of great information on that
    site, it's an excfellent resource. I'll be sure to check there first
    should anything else come up.
     
    facebrake, Jun 11, 2006
    #12
  13. <> shared these words of
    wisdom:

    Thanks for sharing your recipe!

    Obviously ssome of the manufacturers tied their set-up procedures too
    tíght to their proprietary hardware.
    It's just the same with HP/COMPAQ where the Recovery CD will not run
    if any other CD-drive is used except a HP/COMPAQ drive in the multibay
    cradle ...

    Rainald
     
    Rainald Taesler, Jun 18, 2006
    #13
  14. palfvin

    Chris Guest

    I've tried this and I get a couple of quick errors about incorrect lines in
    Config.sys (I've double-checked it, tho)... then it loads MSCDEX and sits for
    a minute and then gives me the old ARF (Abort, Retry, fail) when trying to
    read drive Z.

    Any ideas?

     
    Chris, Jul 21, 2006
    #14
  15. palfvin

    Chris Guest

    Hrm... I "Aborted" and it actually kept going... so maybe it is working now.

     
    Chris, Jul 21, 2006
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.