Airport & 3Com router; WPA, WEP problems

Discussion in 'Apple' started by AnToNio, Feb 8, 2004.

  1. AnToNio

    AnToNio Guest

    I am trying to get an additional thing working and that ie either WPA or
    WEP and am not very succesfull in that. On the iBook is an Airport
    Extreme, OS X 10.3 with the latest updates.

    On my (3Com 54) router I have following possibilities:

    Enable WPA with 'manual preshared key' or 'preshared passphrase' or
    'enterprise mode'. Here I opted for 'pre shared passphrase', since that
    enabled me to type in some name or whatever.

    However when I type that in 'password' in the airport pane then I cannot
    contact the network, reason 'wrong password'.

    Second possibility is Enable WEP, het I tried both the options '40/64
    bit encryption' and' 128 bit encryption', in both I selected the
    suboption 'passphrase'. However same happen to me on the iBook
    nopassword is accepted.

    On the ibook I also tried logging in manually, then I get several option
    (like encryptiontpe, leap, etc). Since I understand none of thee option
    I tried them all but in vain. Password is never accepted.

    Van you (or anyone else) shed some light on this subject?
     
    AnToNio, Feb 8, 2004
    #1
    1. Advertisements

  2. AnToNio

    BCLee Guest

    Maybe that's your problem, I upgraded to Airport software version 3.3
    a few days ago, and as a result I was unable to connect to my 3COM
    router w/WEP encryption which I've been using without problems with 3
    different macs for 2 years. I kept getting generic "there was a
    problem conecting" message, if I deleted the password and re-entered
    it, I got a message similar to yours. My wife, who was still using
    version 3.1 of the Airport software, was having no problems with
    exactly the same settings I had. So I reverted to 3.2 using
    instructions I found on the Apple.com discussion forums (a few people
    have been having problems with the 3.3 update) and all seems to be
    fine (again) now.

    If all else fails, you might try that, and hopefully Apple will
    release a 3.4 update very soon.
     
    BCLee, Feb 10, 2004
    #2
    1. Advertisements

  3. AnToNio

    AnToNio Guest

    Will have a look into that.
    How is your experience with this router. Mine is bad, As soon as there
    is a waal or floor between the two the signal strenght drops with 25%,
    so with a floor and wall there only remains 50%.
     
    AnToNio, Feb 10, 2004
    #3
  4. AnToNio

    me Guest

    I hacked at this till it worked on my daughter's iBook. I'm not mac
    literate so this is form memory and my have a few errors in it, but I
    think it will give you enough clues to get this going.

    It seems since the 3.3 update that password entry field no longer accepts
    the $xxxxx format for WEP 128 bit hex. Typing in the hex password with the
    $ or without didn't work (from memory). From the airport applet up in the
    menu bar you can get to a dialog called "Closed Network" (I think you
    select Other to get this). That dialog has a dropdown selection list. The
    selection that is shown is WEP Password which is what you think would be
    right - but it isn't. Click to show the list and instead select WEP
    40/128-bit hex. Underneath that is Network Name and entry field to key the
    network names (ESSID) in. Underneath that is the Password entry field.
    There you key in the 128 bit wep hex password and you do not prefix with
    $.

    This is from memory and I'm not sure exactly about the $ bits and where
    that worked and didn't. I think I got it right above, but I'm hoping that
    there's enough here anyway to lead you to the same thing that got it
    working for me.

    The 3.3 update didn't break things for us until the WEP password on our
    netgear WAP was changed. That's when I saw that no matter what I did it
    walsy said "incorrect password" on the mac network preferences screens
    until I got to that "Closed Network" dialog above with the selction list
    for WEP 40/128-bit hex.
     
    me, Feb 10, 2004
    #4
  5. AnToNio

    BCLee Guest

    My experience is good, but the range is about what you describe. High
    in the room it's in, and about 75% in the next room. It covers my
    entire apartment, so it works for me. Most other routers seem to have
    about the same range, and I'm actually happy about that because my
    apartment complex is filling with wireless routers (I can usually see
    a minimum of 7 networks) and if their signal strength was better, I'd
    soon be running into interference problems. I already had to move to
    a new channel once.
     
    BCLee, Feb 13, 2004
    #5
  6. AnToNio

    AnToNio Guest

    I have similar problems BUT I do not want to use these hexcodes, I want
    to use the passphrase.
     
    AnToNio, Feb 17, 2004
    #6
  7. AnToNio

    Chris Brown Guest

    The passphrase is an Airportism. If you're using a generic 802.11 access
    point you will need to use the full WEP key.
     
    Chris Brown, Feb 17, 2004
    #7
  8. You can try putting it in double quotes when you enter it in the
    Airport password dialog, but I've never gotten that to work.
     
    Matthew Russotto, Feb 17, 2004
    #8
  9. AnToNio

    AnToNio Guest

    Not correct! There are many routers that accept a passphrase.
     
    AnToNio, Feb 17, 2004
    #9
  10. AnToNio

    Bob Harris Guest

    The algorithm that Microsoft used to convert the passphase to hex is
    different from the algorithm used by Apple. Most non-Apple base
    stations use the Microsoft algorithm.

    As a result the only common WEP key form is hex.

    Bob Harris
     
    Bob Harris, Feb 18, 2004
    #10
  11. AnToNio

    AnToNio Guest

    So Apple once again decided to go its own lonely way!
     
    AnToNio, Feb 18, 2004
    #11
  12. AnToNio

    Jose Marques Guest

    Using a passphrase is not part of the standard. They _all_ went their own
    lonely way.
     
    Jose Marques, Feb 18, 2004
    #12
  13. Apple came up with its algorithm first. And unlike the algorithm
    used by other companies (I do not think it is due to Microsoft, but I
    could be mistaken), Apple's doesn't reduce your effective key size to
    21 bits in 40-bit WEP mode!
     
    Matthew Russotto, Feb 18, 2004
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.