1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

ARM based processor with TRACE32

Discussion in 'Embedded' started by yajforforum, May 13, 2014.

  1. yajforforum

    yajforforum Guest

    Hi All,
    I am using ARM based SoC, and using Lauterbach to bring it up.
    I using u-boot as my boot loader, and I did DDR register settings fo
    800MHz DDR3 and I am able to load my u-boot code, and u-boot is bootin
    when I load using Lauterbach.

    I can see the console messages and u-boot prompt. From there I would lik
    to flash the u-boot in FLASH memory using u-boot commands.


    But the issue is, when the u-boot console messages are up, after some time
    say 3-5 min the JTAG communication fails and the Trace 32 status bar show
    the message "Emulation Debug Port Fail" message.

    I have checked the DDR register settings,
    JTAG clock is reduced and checked.
    Selected the correct CPU core.

    Could anyone suggest what are the other things can be checked?

    (The same works for DDR part 667MHz. )
    We change the DDR3 part and change the settings and the emulation fails i
    this case after booting the u-boot from Lauterbach.

    Thanks and Regards,
    Jay
     
    yajforforum, May 13, 2014
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.