1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

ARM9 Debugging with Chameleon POD ?

Discussion in 'Embedded' started by Amontec Team, Laurent Gauch, Jan 26, 2004.

  1. Hi,

    We just want to advice you that our Chameleon POD product and our Raven
    configuration was tested successfully for ATMEL ARM9 AT91M4200 Debug.

    We have tested using GNU GDB tools, OCD Commander and Greenhills.
    (including breakpoint)

    Our Chameleon POD can operate as a true Raven with a max JTAG 8MHz TCK.
    Comes with an 20-pin adapter for only EUR159.-- (worldwide 3 days shipping)

    A low cost solution for students, labs and hobbyist.

    Laurent
    www.amontec.com
     
    Amontec Team, Laurent Gauch, Jan 26, 2004
    #1
    1. Advertisements

  2. Amontec Team, Laurent Gauch

    John Guest

    On Tue, 27 Jan 2004 00:35:00 +0100, "Amontec Team, Laurent Gauch"

    Hello Laurent,

    I've never heard of the AT91M4200 - do you mean the AT91RM9200?

    I have tried to use your Chameleon POD with an AT91RM9200 based system
    (Cogent CSB337) and have never been able to get breakpoints to operate
    correctly.

    Once the first braekpoint has been hit, I have never been able to
    continue code execution.

    GDB version tried have been 5.2,5.3,6.0 and earlier, using the pod as
    a wiggler and Raven (at all possible speeds).

    Can you clarify your post to say which Atmel device, GDB version, and
    ocdemon libremote version you have used.
     
    John, Jan 28, 2004
    #2
    1. Advertisements

  3. Amontec Team, Laurent Gauch

    John Guest

    Hello?
     
    John, Feb 3, 2004
    #3
  4. Hi John,

    There are software and hardware breakpoints.

    We do not have test hardware breakpoint, we don't know how to use it for
    AT91RM4200, we have to work on.

    Software breakpoint was checked successfully using
    Linux:
    GDB 5.0
    Windows :
    Cygwin 1005.5.0.0
    Insight 5.2.1
    (OCDRemoteLib coming with the Insight 5.2.1)

    Laurent Gauch
    www.amontec.com
     
    Amontec Team, Laurent Gauch, Feb 4, 2004
    #4
  5. Hello,

    I've acquired a chameleon pod hardware and downloaded configuration software
    from your site. I've successfully configured the the POD as RAVEN device.

    Then I've switched to my Linux machine which is DELL inspiron 7000 running
    Mandrake 9.1 system.
    Attached the pod to my at91rm9200dk board

    I've downloaded and installed OcdLibRemote package from
    http://www.ocdemon.com/OCDemonLinux.html

    I've launched OcdLibRemote -c ARM9 -a 0&

    and gave to my gdb the command:
    target remote 192.168.0.182

    I've got following results from the gdb
    Remote debugging using 192.168.0.182:8888
    Couldn't establish connection to remote target
    Remote communication error: Connection reset by peer.

    The OcdLibRemote exited

    I've relaunched it under strace and found that upon connection request it
    tries to open the device /dev/ocdemonpp-1
    which is non-existent on my system, so i did a mknod for it using MAJOR and
    MINOR dev numbers from /dev/ocdemonpp0 which DID exist.

    I've relaunched :
    OcdLibRemote -c ARM9 -a 0&
    and got
    [1] 3355
    Started listening socket on port 8888.
    OcdLibRemote ARM9: RAVEN via LPT 0 at speed : 1

    and again gave target command to GDB...
    this time the response was:

    Remote debugging using 192.168.0.182:8888
    Ignoring packet error, continuing...
    Ignoring packet error, continuing...
    Ignoring packet error, continuing...
    Couldn't establish connection to remote target
    Malformed response to offset query, timeout
    (gdb)

    I've tried again with: target remote 192.168.0.182:8888
    and this time got:
    Remote debugging using 192.168.0.182:8888
    Couldn't establish connection to remote target

    and the OcdRemoteLib said:
    OCDemon initialization error : Not In Background


    Please advice...  
    Vadim
     
    Vadim Lebedev, Feb 6, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.