AS8 usb 2.0 not working

Discussion in 'Abit' started by andrew, Jan 4, 2005.

  1. andrew

    andrew Guest

    I just installed the AS8 on my system and the USB sockets all are running at
    1.1. Anytime I insert a 2.0 thumb drive or external hard drive, a balloon
    pops up saying, "This device can perform faster... The USB Device can
    perform faster if you connect it to a Hi-Speed USB 2.0 port".

    So I insert the install CD, and when I click on USB2.0 it says to download
    and install SP1. I have SP2 installed.

    I right clicked on each individual port and updated the drivers, which it
    did successfully, but didn't solve the problem.

    I also checked the website here for a driver but found nothing.

    Do I need to change something in the bios? Anyone have an idea as to how to
    get the ports running at full speed?

    System:
    3.2 Pentium 4
    AS8 Motherboard
    1 Gig Ram
    ATI Radeon 9700 Pro
    Win XP SP2

    Thanks!
     
    andrew, Jan 4, 2005
    #1
    1. Advertisements

  2. andrew

    ô¿ô¬ Guest

    First question are you sure the case actually has 2.0 ports?

    Look in Device Manager under "Universal Serial Bus Controllers" and see if
    "Enhanced PCI to USB . . ." is there. It's needed for USB2.0.

    If it's there, your case ports are not 2.0 capable.
    - -
    ô¿ô¬
     
    ô¿ô¬, Jan 4, 2005
    #2
    1. Advertisements

  3. andrew

    andrew Guest

    Thanks for the quick reply...

    Yes, my case (Antec SuperLanBoy) does have USB 2.0 ports.

    Also, my motherboard is USB 2.0 capable. There is even a section in the
    abit user manual that discusses installing 2.0 drivers, but all it tells me
    is to install the latest Service Pack from Microsoft.

    When checking Device Manager, I see the following things...

    Generic USB Hub
    Intel(R) 82801EB USB Universal Host Controller - 24D2
    Intel(R) 82801EB USB Universal Host Controller - 24D4
    Intel(R) 82801EB USB Universal Host Controller - 24D7
    Intel(R) 82801EB USB Universal Host Controller - 24DE
    USB Printing Support
    USB Root Hub
    USB Root Hub
    USB Root Hub
    USB Root Hub

    Now on the four that start with Intel, I had inserted the motherboards
    install disc (which has a USB Driver section, see original post), and I
    right clicked on them and updated/installed the driver, but it still doesn't
    work.

    Does this shed any light on my problem?
     
    andrew, Jan 4, 2005
    #3
  4. andrew

    ô¿ô¬ Guest

    Yes and No. Looking at your post, you don't have 2.0 drivers installed.
    The "Enhanced. . .Controller" has to be present for you to have 2.0
    capability.

    I do not have the same motherboard as you so unsure what bios features you
    may have. My bios (Abit A8V) has under "Integrated perphials/OnChip PCI
    Devices" the option to "Enable USB 2.0 Controller".

    Hopefully yours has something similiar. Sorry I can't be of more help.
    - -
    ô¿ô¬
     
    ô¿ô¬, Jan 4, 2005
    #4
  5. Yes, you should also see an

    Intel(R) 82801EB USB2 Enhanced Host Controller - 24DD

    ....at the bottom of that list. The fact that you don't indicates that the
    USB 2.0 controller either isn't enabled, or you haven't loaded the drivers
    for it.

    Firstly check the Integrated Peripherals section to make sure the USB 2.0
    controller is enabled. Note that there's one setting in there that enables
    the USB (1.1) functionality, and another for USB2, and both need to be
    enabled.

    If that's all okay, you need to load the Intel Chipset Drivers. If you've
    done that, and still get no luck, look in Device Manager for an "Unknown
    Device" with a yellow questionmark next to it. If you find one, click it,
    click the Update Driver button in the taskbar, let the wizard search
    automatically, and it should have its driver installed and enabled.
    --


    Richard Hopkins
    Cardiff, Wales, United Kingdom
    (replace .nospam with .com in reply address)

    The UK's leading technology reseller www.dabs.com
    Get the most out of your digital photos www.dabsxpose.com
     
    Richard Hopkins, Jan 4, 2005
    #5
  6. Yes, you should also see an

    Intel(R) 82801EB USB2 Enhanced Host Controller - 24DD

    ....at the bottom of that list. The fact that you don't indicates that the
    USB 2.0 controller either isn't enabled, or you haven't loaded the drivers
    for it.

    Firstly check the Integrated Peripherals section of the BIOS to make sure
    the USB 2.0 controller is enabled. Note that there's one setting in there
    that enables the USB (1.1) functionality, and another for USB2, and both
    need to be enabled.

    If that's all okay, you need to load the Intel Chipset Drivers. If you've
    done that, and still get no luck, look in Device Manager for an "Unknown
    Device" with a yellow questionmark next to it. If you find one, click it,
    click the Update Driver button in the taskbar, let the wizard search
    automatically, and it should have its driver installed and enabled.
    --


    Richard Hopkins
    Cardiff, Wales, United Kingdom
    (replace .nospam with .com in reply address)

    The UK's leading technology reseller www.dabs.com
    Get the most out of your digital photos www.dabsxpose.com
     
    Richard Hopkins, Jan 4, 2005
    #6
  7. andrew

    andrew Guest

    Richard-

    Your answer fixed the problem for me.

    The USB2 driver was being put under the Other Devices section of Device
    Manager, and I was overlooking it. After I updated it's driver, it worked
    perfectly and the 24DD driver showed up under the USB section of Device
    Manager.

    Thanks so much for your help, as well as Mr. Smiley Face!
     
    andrew, Jan 4, 2005
    #7
  8. Hey Andrew, glad to see you got it fixed!

    For what it's worth, the reason why you had this problem is because you
    installed the Intel Chipset Drivers before installing XP Service Pack 2. If
    you'd done it the other way round, the USB 2.0 section of the controller
    would have been recognised immediately. Probably worth remembering for
    future reference!
    --


    Richard Hopkins
    Cardiff, Wales, United Kingdom
    (replace .nospam with .com in reply address)

    The UK's leading technology reseller www.dabs.com
    Get the most out of your digital photos www.dabsxpose.com
     
    Richard Hopkins, Jan 4, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.