Aspire 8920G not reading Blu-ray discs (HELP!)

Discussion in 'Acer' started by MPG, Jun 11, 2008.

  1. MPG

    MPG Guest

    We bought an Acer Aspire 8920G recently. When we got it, one of the
    first things I did was pop in the sampler Blu-ray disc that came with
    the laptop and bask in the HD goodness. The other day, we made a trip
    to Hollywood Video and picked up a couple BD titles to enjoy. To my
    dismay, neither of these dics played in the laptop. The system could
    not even recognize the discs.

    When one of these is inserted, you can hear the drive trying to read
    the disc for a while before giving up. Auto-play does no start. In
    Windows Explorer, the drive does not show the label for the BD and
    double-clicking on the drive does not do anything. We also tried to
    play the discs in Acer Arcade Deluxe. When we do this, the program
    tells us to insert a movie disc into the drive.

    I tested both of these of these discs in a standalone Blu-ray player
    and they all worked great. What can we do?

    Funny enough, the sampler BD that came with the laptop still works
    great...
     
    MPG, Jun 11, 2008
    #1
    1. Advertisements

  2. MPG

    MPG Guest

    Yes, I am sure.
     
    MPG, Jul 9, 2008
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.