ASROCK problem

Discussion in 'Asus' started by Rhino, Oct 31, 2013.

  1. Rhino

    Rhino Guest

    I'm having trouble getting my desktop computer to boot up today.

    I'd left it on continuously for two or three days and finally shut it
    down when I went to bed last night. When I tried to boot it up this
    morning, I got basically nothing.

    The fans start immediately but I don't even get the single beep. I'm not
    seeing a Windows logo or even the first screen which tells me what do
    press to get into the BIOS. Pressing F2 does not get me to the BIOS when
    I start pressing it repeatedly from the moment I powered up.

    I thought it might simply be that the video cable had gotten dislodged
    but I checked it where it connects to the monitor, where it goes into
    its extension and where it goes into the case and all connections seem
    tight. I also opened the case and looked for anything that might not be
    seated properly, particularly hard drives, but everything seems to be
    properly seated.

    I'm not very good with this kind of hardware issue so I need some advice
    on what to check next.

    The desktop has been working fine since I reseated the SATA cables (see
    my post in September for details). I'm not sure what caused this latest
    problem. I have two cats and it's always possible they bumped something
    as they walked around the computer but that's about the only vague
    glimmer of an idea I have.
     
    Rhino, Oct 31, 2013
    #1
    1. Advertisements

  2. Rhino

    Paul Guest

    When you're having problems, the best direction is to
    "simplify" the system and retest.

    For example, you can fully power off the system, pull the
    plug, then remove the DIMMs and store them in an antistatic
    bag. If the system has a video card (non-integrated video),
    you can remove the video card as well.

    Now, power up the system, and listen for a repeating beep code.
    That will be an error beep code. The BIOS firmware and the
    processor running it, make that repeating code. That tells
    you the processor is working. If you add the RAM back in,
    the beep code pattern should change. Finally, adding in the
    video card, should again remove all error reasons, and then you'll
    be back to just the one beep at startup.

    It's possible for the reset button to getting stuck. The
    board stays in reset and gives your symptoms.

    Check that the ATX12V cable is fully seated. A good
    board isolates ATX12V from 12V on the main cable, and
    the processor won't get any 12V if the ATX12V isn't
    plugged in. The cables have latches to prevent them
    from working loose.

    Clearing CMOS can sometimes help, if something got
    corrupted there. (Again, that's a procedure you
    do with the power cord unplugged, to prevent damage.
    BIOS settings must be reloaded later if you decide
    to try that one, like enabling AHCI or whatever.)

    If you have a multimeter, you can connect the black
    lead of the multimeter to the chassis, then touch
    the red probe to the top of the CMOS CR2032 coin cell
    and check that it's around 3V or so. Some motherboards,
    they refuse to start if the battery is flat. Since your
    motherboard isn't that old, it would be hard to understand
    the battery being flat already, but it's something to
    check.

    That's all that comes to mind right now. Remove stuff,
    listen for a beep code. If you can't get a response
    under any circumstances, next you'd do a check
    on the power supply. With the multimeter, you'd check
    for operating voltages on the thing. You'd also make
    sure the fan is spinning on the supply (as proof
    that the motherboard sent PS_ON# a logic low or
    grounded zero volt signal). If the power supply
    is running, there is a kind of "POWER_GOOD" signal
    on the main cable, as well as all the main voltages
    to check.

    (Pinout and details, here.)

    http://www.formfactors.org/developer/specs/ATX12V_PSDG_2_2_public_br2.pdf

    So when it's simplified, you have power supply,
    motherboard, processor. You can stick the meter on
    the power supply, to eliminate that (all voltages within 5%,
    the power status signal OK). And then that
    leaves motherboard or processor. Processors hardly
    ever fail (you can reseat the processor to verify
    it's not a contact problem). That leaves bad motherboard.

    I probe the back of the ATX main cable where the wires
    go in, to get voltage readings. But you need a strong
    light to be able to see that, and some motherboards
    don't make access to the main cable, all that easy.
    The nylon shell has just enough room
    to put the voltage probe red lead down in the
    shell, until it comes in contact with the metal
    of the pin in there.

    You check 3.3V, 5V, 12V, -12V, +5VSB are within
    5% of nominal. Check PS_ON# is low (close to zero
    volts). The power supply fan wouldn't run without
    that being true. That's what turns on the supply.
    And whatever signal indicates POWER_GOOD, that one
    is probably a logic 1, high value, and would be
    around 5V.

    When I say 5% of nominal, on 12V that means the
    voltage level will be between 11.4V and 12.6V. The
    power supply isn't infinitely accurate or anything,
    and will always be off a bit. The power supply
    typically uses "bulk regulation" and on the primary
    side there is only one control that says "make more
    voltage or make less voltage". So the individual voltages
    are only established by turns ratio, and are not
    controlled individually as such. The most heavily
    loaded rail ends up on the low side, because of
    how the bulk regulation works. But it should
    still stay within the 5% range.

    There is a picture of a power supply schematic here,
    if you like pretty pictures. While this won't
    make any sense the first time you look at it,
    it grows on you. Modern supplies have more
    circuitry than this, and this much circuit
    "just makes the voltages". Some will have
    a bit more monitoring. And a few modern ones,
    the architecture is entirely different (two
    stage regulation).

    http://www.pavouk.org/hw/en_atxps.html

    Paul
     
    Paul, Nov 1, 2013
    #2
    1. Advertisements

  3. Rhino

    Rhino Guest

    Thanks for all the info, Paul. I have some more for you; I hope it makes
    sense.

    I think you've already dug up my motherboard model number but here it is
    again: ASRock N68C-GS FX.

    I hadn't seen your reply yet - I don't have internet at my new place yet
    so have to go to the library or a friend's place to go online - so I
    went about the problem somewhat differently. I tried booting from my
    Unbuntu 12.04 LTS CD but had the same issues as when I booted from XP on
    the hard drive. I also tried booting from an old Knoppix CD that I had
    lying around; same issues again.

    The monitor is a Samsung T260 and it is clearly getting power since it
    cycles through the HDMI/Digital/Analog options. (I'm not sure how to put
    this correctly but when I power up the computer and if the monitor is
    on, it displays HDMI in the upper left corner for several seconds, then
    Digital, then Analog. I assume this is because there are connections for
    HDMI, DVI and RGB at the back and it is not sure where the signal will
    come from so it checks all three.) Anyway, I noticed that after it
    cycles through all three options two or three times, it displays an
    error message: Check signal cable.

    That made me believe the cable was faulty or improperly seated so I had
    a look at it. It seemed to be seated just fine. There was an RGB male to
    RGB female cable running out of the monitor; then, there was an RGB male
    to RGB male connected to the end of that, serving to extend the cable;
    then the RGB male end went into the back of the tower. But everything
    seemed snug so I wasn't sure what to do next. I unplugged the RGB cable
    where it went into the monitor and tried reseat it. It was a bit of a
    struggle to get the orientation right so I looked at the end of the
    cable and saw that two of the middle row of pins looked wrong: one of
    the pins seemed to be missing entirely, and the other seemed to be
    pushed halfway back into the plug. That looked like exactly the kind of
    thing that could cause my problem so I removed that cable entirely and
    just ran the RGB male to RGB male cable directly from the monitor to the
    tower; all of its pins on both ends seemed fine. But I still get the
    "check signal cable" message from the monitor so that obviously DIDN'T
    solve the problem. So I'm back to being confused about what is wrong.

    For what it's worth, I tried connecting the RGB cable from my monitor to
    my laptop and then used F8 to cycle between the various options like "PC
    Screen only", "Extend", "Duplicate" and "Second screen only". This made
    it clear that the monitor has no problem displaying the desktop of the
    laptop so the monitor itself (and apparently its RGB port) would appear
    to be fine.

    Could the RBG port on the mobo be failing? Maybe I just need a "gender
    bender" to convert the monitor cable to female at the tower end so that
    I can use the male RGB port which is right above the female RGB port.

    I'm guessing that there's nothing else wrong. Does that make any sense?
    Like I said, I'm lousy at this hardware stuff ;-)

    Unfortunately, I had to put my voltmeter in storage (out of town) and
    don't have easy access to another one. I also downsized dramatically
    during my move and got rid of various old monitors, cables, and such
    things that would come in really handy right now for diagnostic
    purposes. That, and the lack of internet access at home, make this
    problem a lot harder to solve than it otherwise would be....

    I'm not sure if I'll see your reply to this before I go offline again
    for the day so, if I don't, I'll try the other stuff you suggested when
    I get home (or at least as much as I can without a voltmeter). But I'm
    thinking the "check signal cable" message is the Big Clue we need to
    sort this out. I wish I had thought to mention that when I first posted
    but I didn't see this symptom until today....
     
    Rhino, Nov 1, 2013
    #3
  4. Rhino

    Paul Guest

    But the PC beep is all important.

    You said the fans are spinning, but there is no beep.
    Fans means the power supply is delivering some +12V
    on the main cable. We know that much.

    If the computer case speaker doesn't beep once at powerup,
    then the CPU probably isn't executing the BIOS firmware.
    It's either crashed, or it's not getting power (ATX12V
    2x2 connector).

    If you are getting the standard single beep at power up,
    we can move on to something else.

    Based on "no beep", it's either motherboard, CPU, or power
    supply.

    Paul
     
    Paul, Nov 1, 2013
    #4
  5. Rhino

    Rhino Guest

    Darn. I was hoping it was something as simple as a bad cable. This
    sounds like it is going to be expensive to diagnose and fix and money is
    NOT something I have on hand these days.

    I'll figure out what I can on my own (and with your help)....
     
    Rhino, Nov 2, 2013
    #5
  6. Rhino

    Paul Guest

    Turn off the power, pull the DIMMs, put them in an
    antistatic bag so they don't get damaged. Turn on
    the machine, and listen for beeps. If there is no
    RAM, the processor can still run, and the code
    it runs controls the beep pattern. Hearing it
    beep in such a situation, is proof the processor
    still works.

    If that processor did not have the square 2x2 ATX12V
    connected, then it could not beep. Your system was
    working, and only if somehow that connector worked
    itself loose, would that theory be practical.

    Checking the power supply is going to be a more
    "techy" procedure. If you have a multimeter, you can
    check the voltages. Otherwise, you can replace the
    supply (if you think that is cheaper than going to
    a shop and paying a diagnosis fee). And there's still
    no guarantee it's not the motherboard.

    Is the power supply brand new ? Or was it
    moved from an older system ? Does the supply
    have a history of problems ?

    My worst experience here, with diagnosing things,
    is I ended up buying duplicates of practically
    everything in the computer. And then the
    "home repair" idea isn't as attractive. If you
    get lucky on the "swap and test" thing, sometimes
    you come out ahead.

    When my RAM suddenly started throwing errors here,
    just on a whim I adjusted Vnb (Northbridge) by
    a step on the controls, and the errors stopped.
    And that saved me a few dollars. I've had a fair
    number of sticks of RAM that outright failed,
    and when it happens, it's in the 1.5 to 2 year
    timeframe. The RAM in that case, was "generic"
    and didn't have a famous brand name on the sticks.
    I bought the RAM locally. It "seemed like a deal",
    and now, I don't buy crap like that any more.
    My trick now, is to read the reviews for products,
    before I buy them.

    If RAM fails, and low memory locations cannot
    hold valid contents, that sometimes makes a
    motherboard "fail silently". My Nforce2 board
    did that one day. A stick of Ballistix RAM
    decided to have one of the chips completely
    die on it, and the motherboard couldn't even
    beep.

    But that probably doesn't happen all that
    often. When sticks of RAM get errors, usually
    it's just a few bits on the DIMM with stuck-at
    failures. Entire chips croaking, isn't as common.
    And I didn't even overvolt those DIMMs. It
    wasn't a "stress failure".

    Pulling the DIMMs, I could get a "beep" from
    the motherboard, so I knew my motherboard,
    power supply and processor were OK. Since I'd
    just pulled the RAM, I then knew there was somethine
    seriously wrong with the RAM. Further testing
    (in single channel mode), revealed the dead chip.

    Paul
     
    Paul, Nov 2, 2013
    #6
  7. Rhino

    Rhino Guest

    Thanks, Paul. I will try what you've suggested. In fact, I had planned
    to try it this past weekend but forgot to save your suggestions to a
    file before going offline. But I'm going to save them now and then try
    it when I get home. I can certainly remove the RAM and see if I get a
    beep. Let's see what that reveals and go from there....
     
    Rhino, Nov 4, 2013
    #7
  8. Rhino

    Rob Guest

    If still no beeps and your system has a separate graphics card,
    remove the graphics card and try powering up again.
    If you now get beeps, it's a dead graphics card (although
    sometimes removing and re-inserting such cards can 'fix'
    the problem.)
    If the graphics are on the motherboard, this is of no help of
    course.
    HTH
     
    Rob, Nov 6, 2013
    #8
  9. Rhino

    Rhino Guest

    Sorry for the delay in following up; I got sidetracked by other matters.

    I took the DIMMs out this morning (with the power disconnected) and then
    powered up: I got three long beeps, repeated several times with a short
    pause between each group of three. I powered off, put the DIMMs back in
    and powered up again, expecting to see the same issue: no beeps at all
    and reboot not proceeding. But instead, I got a single short beep, some
    pops from the speakers, and then Ubuntu booted up (I still had the
    Ubuntu 12.04 CD in the tray). Ubuntu behaved normally so I shut down and
    removed the CD and rebooted to XP. XP also came up fine. I'm a little
    puzzled about why removing the DIMMs and putting them back in fixed
    anything but I'm not inclined to look a gift horse in the mouth ;-)

    The thing that bothers me is that I get two or three loud pops when I
    boot up (either Ubuntu or XP); more importantly, the audio is distorted
    when I play an audio file in XP (didn't try it in Ubuntu) it is pretty
    badly distorted. I'm not sure what to make of that. Audio was fine
    before this incident began. I thought that I was past my audio problems
    with the USB gizmo. I'd appreciate any tips on how to get the sound
    working better....
     
    Rhino, Nov 8, 2013
    #9
  10. Rhino

    Paul Guest

    Sounds like the DIMM wasn't making good contact.

    This is actually one of the reasons for pulling the DIMM :)
    You get the wiping action of a fresh insertion.

    *******

    With regard to a USB audio solution, pops could happen
    if there are transients on +5VSB. Either the power supply
    is not completely happy on the +5VSB output rail, or some
    hardware in your computer is placing a significant load
    on +5VSB.

    At one time, the user could control the source of the
    USB bus voltage, by means of motherboard jumpers.
    On an old system, you could change power sources,
    and do that change on a "USB stack" basis. Two USB
    ports would share a single jumper. Some motherboards
    would have four or five jumpers to play with.

    You'd leave the USB keyboard stack set to +5VSB (so you
    can do "wake via keyboard). And leave any other ports
    powered by the +5VSB rail.

    *******

    OK. Good news. Your motherboard has two 1x3 power
    headers with a jumper on each. So as a user, you
    do have some control over the USB Vbus source.

    PS2_USB_PWR1 PS/2 stack, as well as USB0,USB1,USB2,USB3 ports

    USB_PWR2 USB4 .. USB9 (six ports total)

    In the interests of science, turn off the computer,
    unplug it, wait 30 seconds, move both jumpers to
    the 1_2 position for +5V operation. The +5V rail
    in your computer, is a lot stronger than the +5VSB
    rail.

    Power up, listen for pops. Tell us whether it's fixed.

    If it is fixed, the issue could be too much current flow
    through the USB_PWR type headers. Asrock loves to save
    a few cents, by running too many ports through a USB_PWR jumper.
    On an older Asus motherboard, it was two ports only, per
    each 1x3 header.

    The action of moving the jumper, will help from a second
    perspective. It'll be a fresh wiping action, in case
    the jumper wasn't making good contact.

    One of the 1x3 headers is on the upper left hand corner of
    the motherboard. The other 1x3 header is on the lower right.
    Each one shares one inrush capacitor, over six or so ports.
    Again, not that wonderful. The capacitor near a USB connector,
    is to "hold up" or maintain the Vbus voltage, when a new
    USB device is plugged in. USB devices are hard on the
    Vbus voltage, as any bypass capacitor inside a USB peripheral,
    draws an inrush of current. The capacitor on the motherboard,
    near the header, is there to battle with that.

    If you leave both jumpers in the 1_2 position, the only
    side effect would be losing "wake on keyboard" capability.
    Just as an example of why the ports were running from
    +5VSB in the first place.

    Paul
     
    Paul, Nov 8, 2013
    #10
  11. Rhino

    Rhino Guest

    Sorry for the delay in following up on this thread but I have some news.

    Today, I finally decided to try what you suggested. I powered down the
    computer, pulled the power cord and waited 30 seconds as you suggested.
    I opened the case and found the two headers you mentioned (with some
    help from the motherboard manual). I found that the upper left one was
    set on 2_3 and the lower right one was set on 1_2. I was going to change
    the upper left one to 1_2, as per your advice, but found that it was
    virtually inaccessible due to the copper butterfly cooler on the CPU.
    Since I couldn't figure out how to remove the cooler - I misplaced the
    instructions during my recent move and couldn't go online - I simply
    closed the case again until I could research the technique.

    Just for the heck of it, I powered up the computer again and the sound
    was suddenly working just fine. My games and videos all had normal
    sound, not badly distorted sound. I'm not inclined to look a gift horse
    in the mouth and I try to follow the old rule "If it works, don't fix
    it" so I'm just going to hope that it keeps working rather than mess
    with it further.

    I have to admit I'm a little perplexed over why removing the power cable
    for a few minutes fixed this problem though. That doesn't seem
    particularly reasonable. My best guess is that the act of moving the
    computer so that I could get at moved a cable (or caused the USB port
    holding the cable to move) in some small way to resolve the problem (at
    least temporarily).
     
    Rhino, Nov 20, 2013
    #11
  12. Rhino

    Paul Guest

    Some jumpers and headers, use thin metal plating, and
    a bit of corrosion can be present. Just touching the jumper
    without pulling it, can be enough to restore operation.

    Perhaps the power was flaky, because of the jumper to header
    pin contact.

    Paul
     
    Paul, Nov 20, 2013
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.