Asus 440BX P3BF and hard drive not recognized

Discussion in 'Asus' started by Pham, Jan 19, 2004.

  1. Pham

    Pham Guest

    Hello,

    I know this card is a bit old, but I'm still running with an ASUS 440BX
    P3BF (rev. 1004) and it has a slight problem to recognize my hard
    drive.

    The hard drive is a Hitachi 80 Go 7200 RPM 2 Mo, UDMA100
    7K250 (HDS722580VLAT20).
    I haven't had any problem with a previous IBM 7200RPM UDMA100 80 Go
    before and it strucks me that this hard drive isn't recognized.

    Do I have to change hard drive or motherboard or is it a trick to get it
    recognized ?

    I haven't been able to let me manually define it with headers, sectors
    and cylinders (somehow it doesn't want me to put more than 255
    cylinders...)

    The LBA, LARGE, Normal option don't work either.

    Let me know if you have that kind of problem before, I would really
    appreciate any help or hints !

    Thanks in advance.
     
    Pham, Jan 19, 2004
    #1
    1. Advertisements

  2. Pham

    daytripper Guest


    You don't mention the bios revision, but it sounds likely your bios is too
    ancient to recognize an 80GB drive.

    Update the bios to version 1.08-beta4. Don't let the "beta" scare you, we've
    been using it for well over a year on multiple systems without issue...

    /daytripper
     
    daytripper, Jan 19, 2004
    #2
    1. Advertisements

  3. Pham

    Pham Guest

    I mentioned the bios revision 1004 (from 19/10/1999).
    I have downloaded the bx3f1006 revision, but after reading the
    readme.txt I haven't found anything related to my problem to the
    changes.

    What is strange, is that my ohter IBM 80GB UDMA100 hard drive IS
    recognized perfectly !
    Do you have also a P3BF motherboard ?

    Thank you for your help !
     
    Pham, Jan 19, 2004
    #3
  4. Pham

    Pham Guest

    Ok I've downloaded the 1008f304.zip file.
    Then how do I flash the bios ?

    I don't wich utility to use ?

    Thanks !
     
    Pham, Jan 19, 2004
    #4
  5. Pham

    Roy Coorne Guest

    Pham wrote:
    ....
    Use aflash.exe
    ftp://ftp.asuscom.de/pub/ASUSCOM/BIOS/BIOS_FLASH_UTILS/DOS/AFLASH/

    Create a Windows boot disk and boot from that,
    at prompt A:\
    type aflash.exe and enter
    etc. (carefully follow instructions)
    Important: Set BIOS to default values before _and_ after flashing,
    then you may return to your customized values.

    Roy <P3B-F Rev.1.04 with BIOS 1008 beta 004>
     
    Roy Coorne, Jan 19, 2004
    #5
  6. Pham

    Roy Coorne Guest

    Pham wrote:

    ....

    Use aflash.exe to be copied from

    ftp://ftp.asuscom.de/pub/ASUSCOM/BIOS/BIOS_FLASH_UTILS/DOS/AFLASH/

    Unzip both aflash and 1008f304.zip on a disk
    (write down the exact name of the unflashed BIOS file on this flash
    disk - you need it when flashing)

    Boot your PC and go to BIOS, set BIOS values to default,
    now reboot your PC from a Windows boot disk,

    at the prompt A:\ introduce your flash disk and type aflash.exe
    enter
    follow instructions carefully
    reboot after flashing, go to BIOS and set BIOS values to default,
    reboot (and customize your BIOS values, if necessary)

    Roy <P3B-F Rev.1.04 with BIOS 1008 beta 004>
     
    Roy Coorne, Jan 19, 2004
    #6
  7. Pham

    daytripper Guest

    fwiw, as all of my P3B-F boards were *hardware* revision 1.04, it wasn't
    obvious you were referring to the bios revision...

    Bios 1008f304.zip is at:
    ftp://ftp.asuscom.de/pub/ASUSCOM/BIOS/Slot_I/INTEL_Chipset/i440BX/P3B-F

    DOS flasher aflash221.zip is at:
    ftp://ftp.asuscom.de/pub/ASUSCOM/BIOS_FLASH_UTILS/DOS/AFLASH

    Inside of aflash221.zip is aflash.eng, an English text file explaining how to
    use the flasher utility on your board.

    If you don't have a bootable DOS partition, make a boot diskette, or go to
    bootdisk.com and download a bootable image, stick it on a diskette with the
    unzipped flasher and bios data (remember the file names), boot off the
    diskette, then execute the flasher and give it the bios file name when asked.

    btw, did you mean to say that both the drives - the working one and the
    non-working one - were 80GB? That *may* indicate the bios update may not fix
    the problem with the non-working drive.

    otoh, I'm surprised either one worked with that old of a bios revision -
    unless you used a bios overlay (eg: Disk Manager or Drive Rocket, etc) in the
    first place. Which would explain a lot, and which would also strongly indicate
    a bios update is proper...

    /daytripper
     
    daytripper, Jan 19, 2004
    #7
  8. Pham

    Pham Guest

    Ok I've updated the bios to 1.008-beta4 but it still doesn't work !
    I now can manually set the 16383 cylinders, 16 heads and 63 sectors
    (before I couldn't put 16383 but 255 maximum) but I always got the
    message : "Primary master failed" at boot time.

    And yes, I meant that I've got a 80GB IBM hard drive which worked
    perfectly from the very beginning !

    The IBM hard drive, I've bought it one year and a half ago. The Hitachi
    just yesterday. Are there some problem with the very recent hard drive ?
    Do I really have to give back the new hard drive ?

    Thank for your help !
     
    Pham, Jan 20, 2004
    #8
  9. Pham

    Pham Guest

    Thanks it works !
    But the updated bios still don't recognized my hard drive...
     
    Pham, Jan 20, 2004
    #9
  10. Pham

    daytripper Guest

    You should not manually set the CHS data. You should set the bios to
    autoconfigure the drive in LBA mode, and just make sure you've allowed the
    drive to use DMA.
    Do you really know if the new drive is good or bad yet?

    Have you checked the drive to see if it is configured to use the Master/Slave
    Drive Select jumpers, or if it is using Cable Select? I don't think Cable
    Select will work on a P3B-F...

    /daytripper
     
    daytripper, Jan 20, 2004
    #10
  11. Pham

    Pham Guest

    Neither of the options (Large, LBA, normal, manual, auto) works.
    I always got 'Primary disk failed'.
    Err...no. I just received it today. The drive is powered up with no
    apparent problem (normal sound).
    I have to admit that I've never seen a new hard drive already dead from
    the very beginning...
    But yes, I shall try it on another computer...
    It uses the Master/Slave jumpers.
    I've done exactly like I did with my previous IBM.

    For what it worth, It seems that the Hitachi is in fact an IBM 80GB
    180GXP. And my previous one (which works) was an IBM 80GB 120GXP.
    Strange isn't it ?

    Thanks for your help.
     
    Pham, Jan 20, 2004
    #11
  12. Pham

    daytripper Guest

    If I recall correctly, IBM sold its disk drive business to Hitachi last
    year...
    For as little as I've offered, you're quite welcome. I suppose at this point I
    will hope your new drive is DOA and you get a warranty replacement soon :)

    /daytripper
     
    daytripper, Jan 20, 2004
    #12
  13. Pham

    Pham Guest

    Do you think that buying a brand new ATA controler card will help the
    bios to recognize the card ?
    Using ATA card doesn't help at all ?
     
    Pham, Jan 20, 2004
    #13
  14. Pham

    Pham Guest

    Do you really know if the new drive is good or bad yet?
    I answer to me : I've just checked the drive on a brand new motherboard
    thanks to a (rich) friend : the drive is dead !
     
    Pham, Jan 20, 2004
    #14
  15. Pham

    daytripper Guest

    Hey, it happens. At least you now have the latest/greatest bios and an
    apparently fully functional motherboard ;-)

    cheers (and better luck with the replacement)

    /daytripper
     
    daytripper, Jan 20, 2004
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.