Asus A7N8X-Deluxe with SCSI boot drives and PATA to SATA drive slave conversion

Discussion in 'Asus' started by lwoody7110, Apr 17, 2006.

  1. lwoody7110

    lwoody7110 Guest

    Hi all

    I have a problem with migrating my PATA drives to SATA on my
    A7N8X-Deluxe board.

    Researching before posting makes me think this a common problem and I
    post in case this has been resolved.

    Issue and setup
    Motherboard as above with 1013 BIOS
    I have an IBM SCSI controller hosting 2 x 36Gb SCSI drives as RAID 1
    I have an Adaptec board running a DLT tape drive
    I have 2 x PATA drives connected to the primary IDE channel
    Originally installed Small Business Server 2003 with only SCSI drives
    installed. Added PATA once OS was up and running - so MBR is located
    on the SCSI drives.
    This has run fine for 18 months or so.

    On replacing the PATA for SATA drives, the system fails to boot. The
    SATA drives are detected during BIOS detection. I hear the system
    message "Now booting from operating system" at which point Windows
    loads. Now, I hear a beep as the system reboots. I do not see the
    Windows loader screen.

    If I detach the SATA connectors from the drives, Windows boots -
    reconnect, symptoms above return.

    I also know the SATA HDD & controller works as I connected the SATA
    data connector once Windows loaded and Windows/Disk Manager detected
    and formated the SATA drive.

    BIOS boot order set to SCSI. All other boot options disabled.

    Any ideas or is this boot order a "feature" of this motherboard?
    lwoody7110, Apr 17, 2006
    1. Advertisements

  2. It's a feature of ALL motherboards that the boot order for SCSI devices
    (indeed the enumeration order) depends on where they show up on the PCI
    bus - typically things nearest the PSU end get selected for booting
    first. Sadly I bet the on-board SATA controllers come out ahead of even
    the first PCI slot (SATA is pseudo SCSI). You may be able to figure it
    out with MSInfo32 or with AIDA32 or whatever.

    I'm not sure whether marking the SATA drive partitions as not-active, or
    not-bootable, or whatever is going to make the problem go away, but I
    bet that's the problem. Now if you attached the SATA drives to a
    separate PCI SATA controller and put it further away from the PSU than
    the SCSI card ... elsewise I guess you need to reinstall the/an OS to
    the SATA drives.
    GSV Three Minds in a Can, Apr 17, 2006
    1. Advertisements

  3. lwoody7110

    old man Guest

    From my recollection, with this mobo, sata/raid driver had to be installed,
    from floppy, using F6 option during the installation or repair of win,
    whether using raid or not.
    Presumably your pwr supply is up to the load?
    old man, Apr 18, 2006
  4. lwoody7110

    lwoody7110 Guest

    Thanks for replying

    I tried moving the SCSI card up the bus in case that helps. The SATA
    drives are brand new - so they have no active/inactive partitions on
    them. The BIOS should find the MBR on the SCSI drives.

    My PSU is fine with a decent 460W. I draw about @ 150W when booted and
    I have never seen more than 170W.

    The option in the BIOS to pick SCSI/SATA changes the order in which the
    BIOS presents the SCSI BIOS and the SATA BIOS screens. If I select
    SATA 1st (but 1st boot device left at SCSI), I get the message with NO
    OPERATING SYSTEM. This tells me the BIOS is not enumerating the SCSI

    If I reverse it and I get the original posting. I have selected (TRY
    OTHER DEVICES) in the boot menu. This makes the board try to boot from
    PXE etc and it fails. I guess this is just one of those "features"
    that I will be stuck with but might find a cure if I ever reinstall the

    I think the PCI card method is the solution to the BIOS problem. If I
    buy a card, I will post results.
    Thanks again
    lwoody7110, Apr 18, 2006
  5. lwoody7110

    Beemer Biker Guest

    ??so you ever see the ====== that windows displays when booting?
    I assume that means you never get to select safe mode because windows never

    What did you do to prep the SATA? Did you clone the PATA to them first?
    Could they have an active primary partition and you got stuff on them
    already? You should be able to put a "blank" unpartitioned and unformatted
    disk on the system and be able to boot into windows. If you cant do that
    then the bios is attempting to boot the disk.
    I suspect that SCSI is considered SATA. You might pull off the SATA disk
    that is on the primary SATA connector and see if it can boot the SCSI and
    still recognize the SATA on the secondary connector.

    If the disks are empty, never partitioned, the problem is undoubtedly the
    bios on the motherboard. If they are basic disks, and you got a partition,
    you might (I am guessing as I never did it) convert them to dynamic disk. A
    discussion of dynamic vs basic disks is here;en-us;309044&sd=tech
    I suspect that dynamic disks cannot boot so you might end up with only the
    scsi's being bootable so your problem is solved. You might as that question
    over at and see if there is something you
    can do to prevent an SATA from booting. Raid issues are discussed there
    I assume you do not want to migrate the OS over to the SATA or you would
    have done that.

    Beemer Biker Ask about my 99'R1100RT
    Beemer Biker, Apr 20, 2006
  6. lwoody7110

    lwoody7110 Guest

    You are correct, I do not get the select the menu items for safe mode
    as the system reboots before this point. I do not see the "======="
    dots across as Windows loads normally. I think the SCSI is
    misinterepted as SATA although the BIOS menu still specifies SATA or
    SCSI as boot choices. I did try both SATA connectors individually in
    tested. I am no longer interested in trying to fix this problem with
    SATA. My solution is to buy another PATA drive as a direct replacement
    for the failed drive.
    lwoody7110, Apr 23, 2006
  7. lwoody7110

    lwoody7110 Guest

    Well - I think the problem is down to hardware conflicts. I tried
    another SCSI controller (Adaptec 29160) and this SCSI controller will
    work with SATA drives. This issue is with the IBM SCSI controller
    (IntelĀ® Server RAID Controller SRCU31A) and the onboard SATA on this

    My testing involved simply removing the IBM + SCSI HDD and installing
    the Adaptec 29160 + another SCSI drive together with the SATA drive
    attached. The Adaptec controller was able to begin a Windows
    installation with the SATA connected. This is further than the system
    can get with the IBM card installed. The IBM card is at its latest
    firmware revision. I think this concludes the post. Hopefully my
    findings might be useful for another SCSI user with this motherboard.
    lwoody7110, Apr 29, 2006
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.