ASUS C213NA DA00Q7MB6E0 REV:E ""URGENT"" needing Schematic

Discussion in 'Technical Support' started by Techie_hobby1, Dec 9, 2023.

  1. Techie_hobby1


    Dec 9, 2023
    Likes Received:
    I know this is probably a big ask but I have a C213NA Chromebook that will not power up.

    It had an issue with the battery (I found 1 of the 4 cells had swollen up), so I swapped out the battery with a New one from a reputable battery supplier...

    Now it won't power on. When I plug the ASUS charger in all I get is 4 flashing AMBER LED lights, followed by 1 WHITE LED.

    I have tried holding the Power button for 10 seconds - no change or display on screen
    I have also tried using the Hard Reset method - No change or display on screen

    I need to do some Motherboard component testing but have searched high and low for the schematic or even one of a different model, but it keeps coming back blank.

    Is there any models that might be able to assist me with tracking down the Power Rails etc.. for troubleshooting
    Techie_hobby1, Dec 9, 2023
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.