asus cul2 and lin-lin adaptor config. Need assistance.

Discussion in 'Asus' started by Guest, Nov 4, 2003.

  1. Guest

    Guest Guest

    Hi,
    I have a problem with this config. First of all the mobo is an asus
    cusl2, it boots fine with a tualatin celeron1.3ghz cpu and an
    upgradeware 370 tualatin adaptor. So the mobo, hard drive, video card,
    memory and keyboard are fine.

    Bios settings are for 1.5v and 100Mhz no overclock.

    Enter the Lin-Lin adaptor with another Celeron 1.3 which I just
    removed from an upgradeware slotI adaptor I'm using on an Asus P2b, so
    this cpu is also good.

    I have the Lin-Lin set according to the instructions on the box with
    two jumpers, one on A5-A6 and the other one on B8-B9.

    I get the whir of the cpu fan, green light on the floppy, boot noises
    from the hard drive and a black monitor screen. But it doesn't boot
    after that.

    Can anyone who has experience with this adapter give me a tip?

    please.

    thanks, eric
     
    Guest, Nov 4, 2003
    #1
    1. Advertisements

  2. Guest

    Paul Guest

    First off, I don't have the adapter, but have to question why you would
    bother buying this, when you've got a 370GU and you know it works.

    The problem could be the BIOS. Apparently, I answered a question
    like this a while back, only about another generic adapter.

    On the CUSL2, if you go for one of the later BIOS, apparently
    the Vcore is set to 1.7V, instead of the 1.5V that the Tualatin
    requests. An older version of BIOS lets the voltage go to 1.5V.
    Running at 1.7V would make the processor run hotter. That suggests
    the BIOS thinks it is dealing with a Coppermine and in the usual
    Asus way, is trying to prevent you from undervolting. My Google
    searches don't show any solutions to this, other than backing off
    the BIOS version.

    When I check the Upgradeware site for the 370GU adapter, it doesn't
    have VID jumpers and it lists the CUSL2 motherboard as compatible.
    That suggests that the hardware needed to make this work is on the
    motherboard.

    Even if the BIOS selected 1.7V on its own, I would have expected
    the thing to POST. The absolute maximum voltage for the Tualatin
    is 1.75 volts, so you would be close to the spec sheet max.

    Do you know whether entering "Jumper Mode" disables the BIOS
    programming of the VID value ? Maybe if you try disabling
    Jumperless operation, and use the jumpers on the board to set
    things up, the BIOS will let the processor set the voltage.

    I hope it isn't fried...

    What is funny, is I looked inside the 1014.001 beta BIOS, and it has
    microcode for CPUID 06B1 and 06B4, which are the Tualatin processors.
    So, at least Asus thought someone might be sticking a Tually
    in there. Now, what are the odds that the 1014.001 BIOS also
    knows not to screw with the voltage ?

    (without audio)
    ftp://ftp.asus.com.tw/pub/ASUS/mb/sock370/815e/cusl2/1014-001.zip
    (with audio)
    ftp://ftp.asus.com.tw/pub/ASUS/mb/sock370/815e/cusl2/1014a001.zip

    This thread suggests clearing CMOS and loading setup defaults as
    part of the BIOS flashing process. I think the thing that is missing,
    is which processor is used to flash the BIOS, and at what point
    the new processor is inserted. I would flash with a known stable
    processor before proceeding further. You don't want to add a dead
    BIOS chip to your challenges.

    http://www.abxzone.com/forums/showthread.php?threadid=38900

    Paul
     
    Paul, Nov 7, 2003
    #2
    1. Advertisements

  3. Guest

    Guest Guest


    Hi Paul,
    Let's see if I can answer this first question. Apart from being an
    adventurous type with various computers about the house, I am starting
    to sell these items, so ergo I am obligated to know them inside out.
    There is dang sparse info about them on the net and the configs on the
    box the apparatus comes in are, speaking bluntly, wrong, at least for
    my chipset.
    To make a long story short, I have solved the problem, which was not
    the bios or the mobo. It's the adaptor config, the jumpers which
    determine voltage. It's the jumper configuration on the adapter which
    asks for a certain voltage from the mobo regulator. I had to learn the
    jumper configs, that's all. The info provided on the box appears to be
    just plain wrong. Asking in various forums, like this one, has
    provided little data.

    I've had this experience with the 370gu, right. The thing is that with
    backing off on the bios, you lose voltage configs in the bios and
    you're stuck at 1.5v. Good for some folks, maybe bad for an overclock.

    The Lin-lIn and the 370gu from Upgradeware are really two different
    animals. Technically I can't say why. But with the Lin-Lin you can
    select your voltage. Only you need a map. The Lin-Lin is also cheaper,
    however not for the faint of heart.

    Another thing is that the upgradeware adapter is kind of permanent in
    the sense that the fit of the cpu into the adaptor is so tight that
    some folks have bent pins on removal. I'm leaving my celeron in the
    370gu for life.
    this could be true, I haven't done it, though.

    No, not fried. It's running fine. I'm booting at 1.6v at 1.520ghz now
    with the celeron 1.3.

    check out the last few posts of this thread that I am adding info to
    at:

    http://www.bp6.com/board/viewtopic.php?p=10558#10558

    cheers, eric
     
    Guest, Nov 7, 2003
    #3
  4. Guest

    Paul Guest

    If you really need to understand it, get an ohmmeter, and trace which
    jumper goes to which VID pin.

    Page 57 of this doc shows a pin side view of the Tualatin. There are
    five VID pins, VID3,VID2,VID1,VID0,VID25mV at positions
    AJ37,AL37,AM36,AL35,AK36. The voltage table is shown on page 20.

    http://support.intel.com/design/celeron/datashts/29859604.pdf

    A Coppermine Celeron datasheet is here. The pin side view is on
    page 97. You will notice that the VID pinouts are the same, except
    a Coppermine has a fixed value of VSS where VID25mV is on the Tualatin.
    The voltage table is on page 20.

    ftp://download.intel.com/design/celeron/datashts/24365820.pdf

    Since the Lin-Lin will have a Coppermine pinout on the bottom, you
    will only have VID3..VID0 to trace to the four jumpers. The voltage
    values start at 1.30 and advance in steps of 0.05. The Tualatin
    has an absolute max of 1.75 volts, so this means only the first
    10 values in the 24365820 table are usable without damaging the
    Tualatin.

    So, all you have to do is trace the four VID pins to the jumper
    pins, and then make your own table of 10 values. Remove the jumpers
    and find which of the two pins on a jumper option connects to one of
    the four VID pins. Do this with no processor in the adapter. The
    Tualatins I've seen normally use 1.5V or so, but consulting
    processorfinder.intel.com will give you the exact numbers for
    each SSPEC. Select "Celeron", then 100MHz bus and FCPGA2 for a
    listing. The server versions are probably listed under
    "Pentium III", then 133MHz bus and FCPGA2.

    HTH,
    Paul
     
    Paul, Nov 7, 2003
    #4
  5. Guest

    Paul Guest

    I don't think it is the chipset. The VID jumpers on your adapter
    (or the pins on the bottom of the processor) give values to set
    the voltage, but the "jumperfree" motherboards intercept these
    signals, and use some GPIO pins on the Super I/O chip to set
    the VID voltage by way of the BIOS. If the BIOS code is brain
    dead, you could get the BIOS applying a setting which is
    inappropriate for the processor in question. That is why you
    need to find a method that prevents the BIOS from messing around.
    I'm guessing that is why the results are inconsistent. Otherwise
    the one setting of 1.5V would be "good for all".

    ---------- -------- ---------------
    |processor|---|jumper |-------+------------|Vcore regulator
    |VID pins |---|override|---------+----------|chip
    ---------- -------- | | ---------------
    | |
    -----------
    | SuperI/O |
    | overrides |
    | VID |
    -----------
    ^ ^
    | |
    BIOS programming

    BTW: The diagram above is what I traced down on my TUA266 board.
    Resistors of various strengths are used to allow the chain of
    overrides to work, but some of the circuit is inaccessable to me,
    as it is underneath sockets and the like.

    HTH,
    Paul
     
    Paul, Nov 7, 2003
    #5
  6. Guest

    Guest Guest

     
    Guest, Nov 8, 2003
    #6
  7. Guest

    Paul Guest

    I was referring to the 24365820.pdf document from Intel, page 20.
    First off, "tms" cannot be on there, because "tms" is part of the JTAG
    test chain, and has nothing to do with configuring a processor like
    those other jumpers.

    Here is my hypothesis:
    ------------------------------------------------------------------------
    Based on the signals you are finding, there are six signals that Lin-Lin
    are trying to control. They are VID3, VID2, VID1, VID0 to set the
    voltage, and BSEL1,BSEL0 to set the FSB frequency. Inside the processor,
    these signals are either open circuit (to represent a logic 1) or shorted
    to VSS (to represent a logic 0). An external pullup resistor is used to
    make the logic 1 voltage level. So, what Lin-Lin has to do with a group
    of three pins, is either pass the original signal untouched, or ground
    the signal to VSS. In the figure below, a group of three header pins is
    denoted as A,B,C and the group of three pins is repeated six times for
    a total of 18 pins.

    Socket top VCC
    Processor | / | |
    Option | / Socket bottom | / Pullup
    | / \ | \ Resistor
    Open CCT x | | | | /
    | v v | | Vcore
    x-----x-----------A B-------x-----x---------Regulator
    | |
    VSS x | C VSS |

    1) To pass the processor defaults, connect A to B
    2) To force a signal to logic 1, use no jumper. The pullup resistor
    will make a logic 1.
    3) To force a signal to logic 0, connect B to C.

    In a group of three pins, the middle pin must be pin B in the figure
    above, so the jumper can either pivot to A (to pass the default value)
    or pivot to C (to force a logic 0). Pin A goes to the socket hole on
    top of the adapter, while Pin B goes to the pin on the bottom of the
    socket. C goes to VSS.
    ------------------------------------------------------------------------
    What was BSEL set to when you tried 1.5V ?

    BSEL1 BSEL0
    0 0 66 MHz see reference (a)
    0 1 100 MHz see reference (b)
    1 0 Reserved
    1 1 133 MHz see reference (c)

    a) ftp://download.intel.com/design/celeron/datashts/24365820.pdf (pg.23)
    b) http://support.intel.com/design/celeron/datashts/29859604.pdf (pg.24)
    c) ftp://download.intel.com/design/PentiumIII/datashts/24965704.pdf (pg.26)

    I don't have an answer for why it didn't boot, other than the BIOS
    screwing around. On a "JumperFree" board, the BIOS first reads the
    values of the signals (by putting some GPIO signals into input mode),
    and then drives out any value it wants by putting the GPIO signals
    into output mode. There are other resistors in the circuit, to prevent
    the GPIO from getting burnt by a processor shorting a signal to VSS.
    But ultimately, the GPIO has the strongest influence on the final
    value used by the voltage regulator. Maybe the BIOS runs first by using
    the processor assigned VID values, then after processor identification
    is complete, it drives out the value it wants - Asus is known for not
    allowing undervolting on processors, and if the processor is
    misidentified, this could be a strange voltage.

    HTH,
    Paul
     
    Paul, Nov 8, 2003
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.