Asus mobo - Asus (nVidia) video - Linux installation problems

Discussion in 'Asus' started by David, Aug 1, 2003.

  1. David

    David Guest

    I am having some strange results trying to install Linux (SuSE, Mandrake
    and Red Hat - all latest versions) on my Asus A7N8X Deluxe rev1.04 -
    bios1004 based systems. Both are identical except for the CPUs and memory.
    The system breakdowns are as follows:

    System 1:
    Asus A7N8X Deluxe rev1.04 - bios1004 motherboard
    Asus V9520 Videosuite videocard (nVidia)
    AMD Athlon Thunderbird 900 mhz
    512mb PC2100 DDR-RAM
    Dell P780 monitor
    WD 100JB HDD
    WD 120JB HDD
    WD 80JB HDD
    Plextor PX-320A DVD/CDRW drive
    Plextor PX-W4824A CDRW drive
    Mitsumi FDD
    Antec SOHO 1080 case
    Antec Truepower 480w PS

    System 2:
    Asus A7N8X Deluxe rev1.04 - bios1004 motherboard
    Asus V9520 Videosuite videocard (nVidia)
    AMD Athlon XP 2000+
    1gb PC3200 DDR-RAM
    Dell P780 monitor
    WD 100JB HDD
    WD 120JB HDD
    WD 80JB HDD
    Plextor PX-320A DVD/CDRW drive
    Plextor PX-W4824A CDRW drive
    Mitsumi FDD
    Antec SOHO 1080 case
    Antec Truepower 480w PS

    All BIOS settings are identical on both systems.

    All Linuxes will install on system 1 with no problems. Trying to install
    any Linux on system 2 goes like this: Boot form CD and welcome screen -
    fine. Display the choose to install or other options - fine. After choosing
    to install - nothing. But if I remove the Asus V9520 Videosuite videocard
    from system 2 and install a Matrox Millenium G450 all Linuxes will install
    just as they should. I have encountered no problems at all in installing
    Windows (98, 2K, and XP) with what would be a suspect V9520 Videosuite in
    system 2. I say what would be a suspect V9520 Videosuite because the
    suspect V9520 in system 2 moved to system 1 goes through the entire Linux
    installations just as it ought to, and the supposed good V9520 in system 1
    moved to system 2 gives the same Linux installation problem. It wasn't
    until I tried to install Linux that I even had any reason to suspect there
    was anything wrong, and the only reason I suspect the V9520 Videosuite card
    is because things work fine with the Matrox card. And since all works fine
    in Windows I don't know what to think.

    I have shifted all components one at a time from one system to the other
    with no changes. It seems that there is a bad combination here of the Asus
    A7N8X Deluxe rev1.04 - bios1004 motherboard in system 2 and either of the
    Asus V9520 Videosuite videocards, but I'm hoping that there is a non-RMA
    fix.

    Before anyone jumps up on the "Any pre-rev 2.0 A7N8X Deluxe is a pre-stable
    A7N8X Deluxe" soapbox let me say that I tried to help a friend put together
    an Asus A7N8X Deluxe system about a month ago and his rev 2.0 board had
    problems from the start. I tried all night long to get it to even post and
    gave up, took it back to Fry's Electronics the next day. When we got there
    we saw one A7N8X Deluxe rev 2.0 already on the returns desk and another man
    in line waiting to return another. The returns clerk told us to go and get
    2 more boards off the shelf and we'd test them before we took them out of
    the store. They both failed to post. He shifted out all his test components
    to make sure they were all good and they were. We got more boards off the
    shelf. By the time it was all over - 2 1/2 hours later, we had found 6 out
    of 9 faulty A7N8X Deluxe rev 2.0 mobos. 3 did start and post, 6 failed. The
    3 that worked had BIOSes 1003 (2) and 1005 (1).

    Any help, thanks.

    David Mays
     
    David, Aug 1, 2003
    #1
    1. Advertisements

  2. Hello,

    I'd recommend going throughe the mobo bios step by step and see if you
    find anything that could be causing these problems (i'd start with agp
    settings and so on). Could also be an issue with memory as you have
    different memory on these machines and maybe for some reason v9520 put's
    more stress on the memory than the matrox does...

    well these are actually quite shots in the dark, hope someone else gives
    you better help...

    Mario
     
    Mario Kadastik, Aug 1, 2003
    #2
    1. Advertisements

  3. David

    Keith Clark Guest

    There's nothing wrong with your system, it's an issue between Xfree86 and
    nVidia cards. The installer can't properly detect the card in my experience
    (I've had problems installing both to a Geforce 256 and an FX5600). There is
    some recent postings about this in one of the RedHat newsgroups. Try doing a
    Google Groups search...

    Your workaround to use a Matrox card just for the install is a good one.

    Another workaround is to do a text-mode install, make sure you select "text"
    boot, not "graphical, then when you boot for the first time manually edit your
    XF86Config file to load the 2D nVidia driver built in to XFree86 - "nv".

    Of course once you can start the X server you should download nVidia's 3D
    driver which totally rocks - I installed Unreal Tournament 2003 in both
    Windows 2000 and RedHat 9 (same machine, dual boot), and the game plays so
    fast in Linux on my FX5600 card that it's really unreal (pardon the pun ;->).
    I deleted the Windows version from the hard drive.

    Keith
     
    Keith Clark, Aug 1, 2003
    #3
  4. David

    ray hartman Guest

    BiD:

    That 1-stick-only issue is an infamous ASUS "feature" which also appears
    on my A7V333. Before burying a screwdriver in the A7Ns black-little
    electro-brain ....... try RAMslots #1 & #3.

    ray hartman
    *******************
     
    ray hartman, Aug 2, 2003
    #4
  5. David

    God Guest

    Test your RAM...

    the stick you took out might have issues...

    (or just *not* compatible with the other one, albeit pretty rare)
     
    God, Aug 2, 2003
    #5
  6. David

    FRiC Guest

    Blame the RAM, and not the board? I only use Apacer RAM (PC2100 and
    PC2700), and I have no problems using two or more sticks in any
    combination on the various ASUS boards I have around here. (A7V8X,
    A7V333-X, A7V333, A7S333, A7V266-E, and A7V266-C.)
     
    FRiC, Aug 2, 2003
    #6
  7. David

    baskitcaise Guest

    Sorry can`t get to the original post but one thing to think about is that the
    frame buffer display & nvidia combo don`t like machines with 1gig ram or
    over, have you tried with less ram.
     
    baskitcaise, Aug 2, 2003
    #7
  8. David

    Keith Clark Guest

    You must have a flaky memory DIMM.

    The nVidia drivers have no problems wih multiple DIMMS. I'm runing my
    P4P800 Deluxe board in dual-channel DDR mode and the nVidia driver works
    great.

    --Keith
     
    Keith Clark, Aug 2, 2003
    #8
  9. David

    God Guest

    The P4P800 uses an Intel865 chipset. Not nVidia Nforce2 (they're for
    Athlons)
     
    God, Aug 2, 2003
    #9
  10. David

    Keith Clark Guest

    Right - sorry, I should have said the nVidia *video* driver.

    Keith
     
    Keith Clark, Aug 3, 2003
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.