Asus not responding to RMA request

Discussion in 'Asus' started by Kroagnon, Jun 11, 2004.

  1. Kroagnon

    Kroagnon Guest

    I am trying to get an A7N8X RMA'd but they have not responded to 3 E-mails
    sent to . It has been over a week since the first one was sent
    out. Are these guys alive? I've had to RMA Abit boards and they respond
    right away, but this is leaving a bad taste in my mouth and if I don't get
    this taken care of it'll be the last Asus I buy.
     
    Kroagnon, Jun 11, 2004
    #1
    1. Advertisements

  2. Kroagnon

    Paul Guest

    Have you tried phoning them ?

    http://usa.asus.com/contact/contactindex.htm

    Filling this out first will shorten the length of your
    phone call:

    http://rma.asus.com/enduser/RmaRequest.aspx

    They do stuff like this, they claim, due to the volume
    of spam they get via Email.

    HTH,
    Paul
     
    Paul, Jun 11, 2004
    #2
    1. Advertisements

  3. Kroagnon

    rstlne Guest

    Did you try using the telephone.

    It's also possible that they are blocking your email (possible)
     
    rstlne, Jun 11, 2004
    #3
  4. Kroagnon

    blackjack Guest

    I RMA'd a A7V8X a couple of days ago. They responded to my email after I
    explained what happened in detail.
     
    blackjack, Jun 11, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.