Asus P4C800 deluxe motherboard RAID drivers

Discussion in 'Asus' started by nextenso, Oct 9, 2007.

  1. nextenso


    Oct 7, 2007
    Likes Received:
    Having replaced a failed Asus P4C800 deluxe motherboard with a identical s/hand one from ebay (so that I can attempt to recover 4 weeks of data on a pair of RAID drives I forgot to backup) I am having trouble installing the Promise RAID drivers on the board I have acquired. The board works perfectly otherwise with Windows installed on a third IDE drive. The Raid drives are a pair of IDE drives, and connected into the IDA Raid connection on the board.

    I have carried out every process the manual gives, plus some other ones. But, Windows XP Professional (with all Msoft updates) install driver process keeps saying... The software you are installing for this h/ware: WinXP Promise SATA378(tm)IDE Controller, is on the Asus CD, insert in CDROM drive, which I do, it then says the driver is not digitally signed, I click 'Continue anyway', it then starts cpoy the files and terminates saying "there was a problem installing the hardware, the device can not be start Code 10"

    I have tried copying both the SATA and IDE Raid drivers on the Asus CD. I have also tried copying the files to floppy disk, forced the install to A drive. I have checked for later version of the driver and tried that. In BIOS I have enabled the Raid setting.

    I have entered the Promise Fastrack setup during BIOS boot using Cntrl F and it recognises the drives saying they are functional.

    I do not know why Window will not install the drivers. When I originally installed the Promise Raid drivers 3 years ago, it was strainght forward. Can anyone help please
    nextenso, Oct 9, 2007
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.