Asus P8Z68-VLX DRAM and Standby LEDs on but won't power up

Discussion in 'Technical Support' started by itm, Feb 10, 2020.

  1. itm

    itm

    Joined:
    Feb 10, 2020
    Messages:
    1
    Likes Received:
    0
    I think I may have short-circuited my P8Z68-VLX yesterday when a metal port cover fell into the case, and onto one of the expansion cards (a firewire/USB adapter). The system immediately powered off and I have not been able to get it back. The PSU seems fine - I have removed it to test it in isolation and it powers up SATA devices OK. I have also tried another ATX power supply with the P8Z68-VLX and it still doesn't power up.
    When I turn on the power supply the red DRAM LED next to the 24-pin power connector lights up red, and the standby LED at the bottom of the board lights up green, but there is no response to the power switch.
    I have followed the procedure to reset the CMOS using the jumper, but it hasn't made any difference. I have also removed all of the expansion cards, and all of the 4 DIMM modules, but the result is the same.
    Is there anything else that I can try, or is my motherboard dead?
     
    itm, Feb 10, 2020
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.