Asus Prime X299A and incorrect installations of Windows Server 2016, 2019 and 2022

Discussion in 'Asus' started by AurelianoBat, Feb 15, 2022.

  1. AurelianoBat

    AurelianoBat

    Joined:
    Feb 15, 2022
    Messages:
    1
    Likes Received:
    0
    I bought a Pc with an Asus Prime X299A motherboard. The PC has a Realtek RTL8192EE Wireless LAN 802.11n PCI-E NIC and a graphics card Nvidia Geforce GT 710. It has a SSD drive with Windows 10 Pro installed and two Seagate Barracuda Hard Drives 8 TB each. Originally the mobo had a firmware 1902 Version. I installed in the first HDD a Widnows Server 2016 Evaluation version and was able to have the dual boot Windows 10 Pro / Windows Server 2016 without problem. When I tried activating Hyper-V, it didn't work neither on Win 10 Pro nor on Win Server 2016. I had read in a ROG forum that this happened to other people when they had upgraded to the 1902 version. Some time later I upgraded the firmware of the mobo to the version 3105 and Hyper-V starfted to work properly. I kept this correct situation until the 3th of February when I wished upgrade the Windows Server 2016 version with the newest Windows Server 2002 Evaluation Version. I mounted the iso file and invoked setup.exe from the Windows 2016 OS, when setup finished I did have the Windows Server 2022 on the HDD and was able booting it but there were no drivers installed neither for the Nvidia video card nor for the Wifi relatek nic adapter. So from this perspective the Windows Server 2022 is uneuseful as I cannot connect to a network and my display monitor cannot be used to its best resolution. I tried again installing Windows Server 2019 Evaluation Version and it gave the same result. no drivers for the video or the wifi nic adapter. Because I had already installed Windows Server 2016 I reinstalled it and once again the drivers for the graphics card and the wifi nic adapter were missing. I made several installations booting with different usb sticks and no way having the Windows Server proeperly installed. I tried installing another Windows 10 Pro on the hard drive and this worked perfectly and Hyper-V also works (Hyper-V also worked with the imprperly installed Windows Server versions but of course there were no external network swithc available). I upgraded the mobo firmware to 3201 version but the Windows Server installation still fail whereas the Windows 10 Pro installation works fine.

    Does it ring bells to somebody? I don't want updating all the available firmwares one by one untile the most recent version. Neither I want flashing back to the 1902 firmware version to double check that Windows Server 2016 will install. I am always nervous when upgrading firmwares and even more flashing back them. Any help or suggestion will be highly appreciated.
     
    Last edited: Feb 15, 2022
    AurelianoBat, Feb 15, 2022
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.