audio picked up by laptop mic - not from headset mic

Discussion in 'Dell' started by Timothy Daniels, Feb 6, 2012.

  1. After months of using a headset for Skype calls on my
    Dell XPS M1300 laptop, I've discovered that my voice
    was being picked up not from the mic on the headset but
    from the laptop's built-in microphone. The headset's red
    mic plug was inserted firmly into the mic jack on the front
    edge of the laptop, but the audio was still detected only
    by the laptop's built-in mic. Does anyone have a clue
    why the audio source wasn't changed the headset mic
    when the headset mic was plugged in?

    *TimDaniels*
     
    Timothy Daniels, Feb 6, 2012
    #1
    1. Advertisements

  2. Timothy Daniels

    Scott Davis Guest

    You might try going to Control Panel -> Sounds and Audio Devices, then
    select the Voice tab and see what device is selected as the default
    for voice recording.
     
    Scott Davis, Feb 6, 2012
    #2
    1. Advertisements

  3. Timothy Daniels

    Krypsis Guest

    You need to set the headset mike as the default audio input device. Go
    to tools>options>audio settings . Ensure that all potential audio
    devices are plugged in, then click on the microphone dropdown box. You
    will see a list of potential audio input devices. In my case, I have 3;
    USB headset, USB Mic (on camera) and IDT audio (inbuilt). Just move the
    headset device to the top of the list and the remainder in your
    preferred order. In my case, the USB headset is top, the USB Mic is 2nd
    and the IDT audio at the bottom. This will become the default order even
    if one or more devices aren't present. For instance, if I disconnect the
    headset, the USB mic on the camera becomes the next available rather
    than IDT audio where I never have a mic connected anyway.

    Don't forget to save your settings!
     
    Krypsis, Feb 6, 2012
    #3
  4. Timothy Daniels

    Bob_Villa Guest

    Maybe you're thinking this is the same as earphones...plugging-in
    disconnects the speakers?
     
    Bob_Villa, Feb 6, 2012
    #4
  5. Timothy Daniels

    Krypsis Guest

    Omitted to mention .... go to <use advanced options> to move the items
    to a preferred order instead of the drop box. The drop box only selects
    (and temporarily overrides) default settings from the advanced options.
    A touch of "oldtimers disease"!
     
    Krypsis, Feb 6, 2012
    #5
  6. OK, that did it (when I finally figured out that "Tools" meant the "Tools"
    in the Skype UI panel). I selected "Microphone/Line In" in the dropdown
    menu, and that did it. I had been selecting "Line" and "Mic" in the Sigmatel
    UI that appeared whenever the headset was plugged in, but neither worked
    to switch the input device to the headset microphone.
    Thank you, Krypsis!

    *TimDaniels*
     
    Timothy Daniels, Feb 7, 2012
    #6
  7. "Krypsis" added:
    There was nothing in the Advanced/Advanced Settings - nothing
    displayed, nothing to select. My Skype installation must be a little
    different from yours. Thanks for the addendum, though. It might
    help someone else.

    *TimDaniels*
     
    Timothy Daniels, Feb 7, 2012
    #7
  8. Timothy Daniels

    Krypsis Guest

    No, this is not his problem. Tim, like me, has more than one audio input
    device available. It's really a matter of selecting priorities or
    "defaults". Skype, on some versions at least, gives the user options to
    prioritise which device gets used and when. I find it especially useful
    for sound output as I have at least 2 outputs generally available.
    General PC audio uses my USB speakers. Skype however will default to the
    USB headset "if" it is plugged in. If not, the next fallback are the USB
    speakers. One very handy feature is that you can set the Skype ring to
    always use speakers by default. This is especially beneficial when you
    get a call coming in and you aren't wearing the headset.
     
    Krypsis, Feb 7, 2012
    #8
  9. Timothy Daniels

    Krypsis Guest

    My Powermac version of Skype is different to the PC version I generally
    use. What version of Skype are you using and what hardware/OS do you use
    it on?
     
    Krypsis, Feb 7, 2012
    #9
  10. Timothy Daniels

    Krypsis Guest

    It took me quite a while to work out all the nuances of Skype. These
    seem to change with every iteration as well. One problem I have with the
    Skype version that I am currently using is that it seems to forget my
    defaults every now and then.
    See if you can see anywhere in your version to set the defaults. It
    makes life incredibly easy, especially if you are using Skype on a
    notebook and want to use the headset instead of the onboard Mic and
    speakers. Saves having to change the inputs and outpouts every time you
    plug a headset in.
     
    Krypsis, Feb 7, 2012
    #10
  11. "Krypsis" inquired:
    My Skype is versiom 5.5.0.124, and it runs on a Dell XPS M1300 laptop
    with Vista SP2 as the OS. The audio codecs are by Sigmatel. I have just
    listened to a callback using the headset mic, and the laptop's built-in mic(s)
    sound better as long as I'm facing the laptop. It's probably because the
    mic in my cheapo headset is not as good as those in the laptop.

    *TimDaniels*
     
    Timothy Daniels, Feb 7, 2012
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.