1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

AVR butterfly - issue with serial loading

Discussion in 'Embedded' started by scott.manton, Mar 2, 2007.

  1. scott.manton

    scott.manton Guest

    I'm planning on making the move from PIC to AVR for my next project
    but I'm running into a very frustrating hurdle. I'm having trouble
    programming my AVR butterfly over serial using the bootloader. The
    wiring seems very straight forward, 3 wires pretty sure that is ok
    since there's pin numbers in the manual and I can read the pin numbers
    right on the cable. On the butterfly side I put the battery in, start
    the demo app and go through the menus to jump to bootloader and then
    press the center of the joystick and the screen goes blank, so I
    assume its waiting for the loader. I downloaded winAVR and build some
    of the example projects, but when I use avrdude it gets to the point
    where it says 'Connecting to programmer' and it just sits there. I
    then downloaded AVRstudio4 and tried AVRprog and it says cannot find
    programmer 1.40 or something like that. My os is WinXP and I'm
    connecting to com1.

    It doesn't seem like it should be this difficult. It has to be some
    rookie mistake I'm making. Please help!

    Scott
     
    scott.manton, Mar 2, 2007
    #1
    1. Advertisements

  2. scott.manton

    steve Guest

    when you jump to the bootloader and the screen goes blank you are in
    the bootloader, but not in the download mode, after running avrdude
    when it says "Connecting to programmer" it's waiting for you to press
    the joystick down again, then the downloading will begin
     
    steve, Mar 2, 2007
    #2
    1. Advertisements

  3. scott.manton

    scott.manton Guest

    Thanks for the tip, I was actually trying that but I did not know it
    was necessary. It turns out that my serial port was taken by some
    thread and rebooting solved it. Just as I thought it was a rookie
    move on my part.

    avrprog now works for me but avrdude is still giving trouble. It
    detects the bootloader but then gives and error saying it can't read
    lfuse properly, then aborts the programming citing safety reasons.
    What is an lfuse? If someone could explain this issue or point me to
    a resource it would be greatly appreciated!

    Scott
     
    scott.manton, Mar 5, 2007
    #3
  4. scott.manton

    larwe Guest

    It's the low byte of the fuse bits. avrdude tries to be smart by doing
    some readbacks before it will burn the chip; this is to prevent you
    from (say) locking out ISP or disabling the only operable oscillator.

    If you are working on Windows, use avrprog (built into AVR Studio).
    It's less problematic. avrdude is quite fussy to get working.
     
    larwe, Mar 5, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.