BIOS checksum error with ASUS M4N78 PRO motherboard

Discussion in 'Asus' started by Daniel Prince, Apr 29, 2010.

  1. My brother bought an ASUS M4N78 PRO motherboard. He installed a
    triple core AMD Phenom II X3 720 2.8 GHz CPU and four gigs of
    Corsair XMS2 4GB (2x2GB) 240- pin DDR2 SDRAM DDR2 (PC2 6400).

    He started the computer and was able to get into the BIOS. He set
    the date and time. He also changed the boot order to CDROM first.
    He did NOT change anything else or try to flash the BIOS.

    When he rebooted, he did not press a key when the system asked him
    if he wanted to boot from CD. The system then tried to boot from
    the hard drive. The hard drive has Windows 7 (32 bit) on it that he
    installed when he had an ASUS M4A78 Pro motherboard. It seemed as
    if Windows was not loading.

    He stopped the boot process. He thought he might have to reinstall
    Windows 7 to remove the drivers that were on the hard drive from the
    previous motherboard. The previous motherboard was an ASUS M4A78 Pro
    that he had returned because it had stopped working just after he
    had installed Windows 7 with it.

    He rebooted and got a BIOS checksum error. The BIOS asked for a file
    on the DVD that came with the motherboard. The BIOS said not to
    insert the DVD if the DVD drive was a USB drive. His drive was IDE
    so he inserted the DVD. The system seemed to find the file it was
    looking for.

    He does not remember the exact wording but first it said something
    like, "Clearing BIOS," with a small rotating star to indicate that
    it was working. This message disappeared and then it said something
    like, "Writing BIOS," with the same rotating star. This message
    disappeared and then it said reboot to regain system. After
    rebooting, there was no video. The CPU fan and case power light
    came on. There were no beeps from the case speaker.

    He removed the memory and got one long and two short beeps. He put
    the memory back, one stick at a time, and it was still dead. He says
    that he cannot get into the BIOS at all now.

    He has left several phone messages with ASUS tech support but they
    have not replied.

    He reset the CMOS and installed a different set of DIMMs. The
    motherboard still did not post.

    Does anyone know what is causing this problem? Can he fix it
    somehow or does he need to send it in for warranty repair? Thank
    you in advance for all replies.
     
    Daniel Prince, Apr 29, 2010
    #1
    1. Advertisements

  2. Daniel Prince

    TVeblen Guest

    The bios checksum error means the bios is no good.

    "The read-only memory (ROM) containing the BIOS program is protected by
    a checksum value as a double-check that the ROM code is correct. This
    checksum is compared against the values in the ROM each time the PC is
    booted and if there is a mismatch, this code is generated."

    "You can attempt to clear the CMOS (either a jumper to reset or a reset
    button on the board - read the manual), but if that does not work then
    it means the bios chip is bad. Return the board.
     
    TVeblen, Apr 29, 2010
    #2
    1. Advertisements

  3. Daniel Prince

    Paul Guest

    It's possible, that the BIOS file on the motherboard DVD, is an
    earlier revision than the one flashed into the board, at the factory.

    To start, I'd check the CPUSupport chart.

    http://support.asus.com.tw/cpusupport/cpusupport.aspx?SLanguage=en-us&model=M4A78 Pro

    Phenom IIX3 720 (HDX720WFK3DGI),2.8GHz,95W Board BIOS
    rev.C2,SocketAM3,Triple-Core 1.02G 1005

    Phenom IIX3 720 (HDZ720WFK3DGI),2.8GHz,95W,
    rev.C2,SocketAM3,Triple-Core ALL 0409

    It's hard to say what revision might be on the DVD. Perhaps the file name
    will tell you, or perhaps not. On the motherboard discs I have here, the
    recovery BIOS is generally at the root level of the disk. Use "explorer" in
    Windows to look at the file names.

    There are two possibilities:

    1) Flash update failed, requiring some kind of recovery process.

    2) Processor needs a later revision of BIOS, than is now flashed into the board.

    To escape from (2), a person might insert an older processor in place of the
    720, so that the board will operate again. Then use flash tools to put a later
    flash image into it. Then reinstall the 720 processor, when it is known an
    adequate revision is installed.

    For (1), you could try the procedure in (2), use an older processor, then see
    if the boot block survived the update. If it did, then you might have the option
    of using the built-in "DVD reading thing". But this time, you would *NOT* insert
    the original DVD. You'd provide your own DVD, with a different BIOS version on it
    at the root level. Read the manual, see what BIOS recovery options are available,
    and then try those options and see if one will work.

    In a sense, the motherboard CD/DVD is a "trap", if you're using a very recently
    released processor. Because it can get you in this version mess.

    Returning the motherboard, is the final option.

    It could always be some other hardware failure on the motherboard, but what
    are the odds of that happening at just that instant.

    Paul
     
    Paul, Apr 29, 2010
    #3
  4. The BIOS lost its contents for some reason, so the emergency bootblock
    code (a short piece of code which does enough to bring the machine up
    and load a new BIOS image from floppy or CD) asked for a disc with the
    BIOS image file. It then attempted to clear and reflash the BIOS (that
    was the spinning star) but failed. The BIOS is now empty or full of
    junk and cannot boot the machine. In tech terms, it's bricked :eek:)

    As for why the BIOS lost its contents, could be a lot of things. But
    the first I would check is that he has not got any motherboard stand-
    offs in the wrong place where they are shorting on the back of the
    board.
    Doubt it. If the chip is in a socket, you can take it out and some
    places will re-flash it if you send it to them with a copy of the BIOS
    image.
    Might be the best option.
     
    Mike Tomlinson, Apr 29, 2010
    #4
  5. How can he tell which CPU and board revision he has?
    I am thinking of buying an Athlon II X3 435. Is that an older
    processor that should work with the BIOS on the DVD?
     
    Daniel Prince, Apr 30, 2010
    #5
  6. There's a chance the whole BIOS wasn't erased and that the boot block
    BIOS is still there and will allow re-flashing from a CD or DVD. Asus
    recommends clearing the CMOS by moving the jumper. But if nothing
    works, at least the BIOS chip for that mobo is in a socket (8-pin
    thing, between the parallel IDE connector and SATA connectors), and
    maybe Asus will sell a replacement BIOS chip cheaply, or a friend
    whose mobo also has a socketed 8-pin BIOS chip can do a hot flash
    (needs 8 megabit serial flash chip -- Digi-Key, Mouser sell them).
     
    larry moe 'n curly, Apr 30, 2010
    #6
  7. Daniel Prince

    Paul Guest

    Take a look at this picture of the processor. The part number
    is printed right on the device. It may have been printed on
    a label on the outside of the box as well.

    http://www.cpu-world.com/CPUs/K10/AMD-Phenom II X3 720 - HDX720WFK3DGI (HDX720WFGIBOX).html

    http://www.cpu-world.com/Images/uploaded/0000/31/L_00003109.jpg
    They have "introduction date" listed for the processors here, under
    the CPU information tab. This one is Feb 9, 2009.

    http://www.cpu-world.com/CPUs/K10/A... Edition - HDZ720WFK3DGI (HDZ720WFGIBOX).html

    This Athlon II X3 435 is listed as Oct 20, 2009.

    http://www.cpu-world.com/CPUs/K10/AMD-Athlon II X3 435 - ADX435WFK32GI (ADX435WFGIBOX).html

    The entries on the Asus CPUSupport page, show the 435 needs an even
    more recent BIOS.

    Athlon IIX3 435( ADX435WFK32GI),2.9GHz,512KB
    rev.C2,95W,SocketAM3 1.02G 1303

    Athlon IIX3 435( ADX435WFK32GM),2.9GHz,512KB
    rev.C3,95W,SocketAM3 ALL 1501

    With regard to the board revision, it is likely printed in copper or
    white letters, on the surface of the motherboard.

    In the Asus table, this would be an example of an older processor.
    The CPU-World page doesn't have a date, but a similar processor
    is dated May 16, 2006.

    Athlon 64 X2 3800+ (CU),512Kx2,65W,rev.F2,SocketAM2

    http://www.cpu-world.com/CPUs/K8/AMD-Athlon 64 X2 3800+ - ADA3800IAA5CU (ADA3800CUBOX).html

    Paul
     
    Paul, Apr 30, 2010
    #7
  8. I checked and he has the HDZ720WFK3DGI CPU and the 1.02G revision
    board. Does that mean he needs the 0409 BIOS? How can he get that
    BIOS version? When I click on the "GO>>>" icon after the "0409",
    with FireFox, all I get is a completely blank screen.

    There are vendors on eBay who sell programmed BIOS chips for his
    motherboard for about $15.50. Would installing one of those chips
    be likely to solve the problem? How difficult is it to remove and
    install those chips?
     
    Daniel Prince, Apr 30, 2010
    #8
  9. Daniel Prince

    Paul Guest

    He doesn't need *exactly* the 0409 BIOS. That is the minimum BIOS
    version that is supposed to be useful. Any BIOS later than that
    should be fine as well (barring any bugs). You should take a look through
    any vip.asus.com postings, to see whether there are any BIOS versions
    to be avoided entirely. Or any flashing methods, known to cause
    issues. Every board is different in that regard.

    http://vip.asus.com/forum/topic.aspx?board_id=1&model=M4N78+Pro&SLanguage=en-us

    On older motherboards, the BIOS chip used to have a sticker on it,
    indicating what version of BIOS was installed at the factory. With
    the new SPI serial flash chips, there probably isn't room for such a
    sticker, as the chip is smaller. The older 32-PLCC package gave room
    for a sticker.

    If you look on the DVD, using the file "explorer", you should be
    seeing a file that was used to burn the BIOS on your recovery
    attempt. If you can figure out what version that BIOS is, and
    compare it to 0409, that may tell you whether this is just a
    version issue, or something else happened (such as the flash
    going bad, and the flashed info being corrupted). (If the file
    name is not suggestive of a version, use a hex editor and look
    through the file. Try looking near the end of the file.)

    As an example, it is possible to screw up a BIOS flash, by the
    clock feeding the flash chip being the wrong frequency. On some
    of the older boards, you could do that while overclocking. So if
    you knew you were going to flash the BIOS, you'd think about
    clearing the CMOS, to get the clocks back to "normal". A risk as
    well, might be whether you had to do anything special to get it
    running the first time. If the board wouldn't start with some
    enthusiast RAM you bought, and you used some "slow" RAM to get
    it to POST, you might have considered installing the "slow" RAM
    again, before clearing the CMOS and returning the board to defaults.
    So while you'd think nothing could go wrong on a re-flash of the
    BIOS, there can be plenty of little things that might contribute
    to it going wrong. Another would be a power failure in the middle
    of an update, which has caught a few people. Using a UPS while
    the flash is ongoing, would buy you a few minutes for the flash to
    complete. I don't know how long it takes an SPI to flash, as I haven't
    flashed one yet.

    Depending on your retailer, if your retailer has a short returns
    period, and you're within that period, you could consider returning
    the board. If it is some deal, where the retailer tells you to RMA
    to Asus, then that is going to suck, and could take you three weeks
    or more, to get the same board or some other board back.

    The reviews on that motherboard, are a bit on the low side.

    M4N78 Pro

    http://www.newegg.com/Product/ProductReview.aspx?Item=N82E16813131382

    I went there, looking for a picture. I think I see an 8 pin SPI flash
    near the six SATA connectors, and it could be socketed. There should be
    a groove or dimple on one end, marking the pin 1 end. And similar markings
    either on the socket, or a marking on the silk screen, marking pin 1 as
    well. If you remove the chip for any reason, make a drawing of how it
    goes back. There are two ways it could be inserted into the sccket.
    I don't see a seven pin SPI programming header on the board, and that
    wouldn't really help anyway, as the only SPI header programmer I've
    seen, costs $150.00.

    http://images17.newegg.com/is/image/newegg/13-131-382-S04?$S640W$

    The Asus warranty period of three years, is based on the manufacturing
    date. The serial number on the outside of the box, has one character
    for the year_number, one character for the month_number, and that tells
    you when the three year clock starts ticking. Those characters are at the
    beginning of the serial number. You likely have some time left on that.
    The board I just bought, only had about half the warranty left on it,
    so you only get the three years for sure, if you're an "early-adopter".
    Later, there is no guarantee whether you're going to get old stock or not,
    and most retailers will tell you "I can't see the box from here", so
    no cherry picking is typically available.

    The one time I was prompted here to:

    "Bad checksum

    Insert motherboard CD"

    I refused. When you see that prompt, the first thing you do is
    your research and thinking. The *last* thing you do, is give it
    the CD or DVD it is asking for. I managed to recover my board, without
    flashing it. In my case, I think clearing CMOS was enough to get me
    going again. There are some motherboards, where large numbers of
    people have inserted the motherboard disc, only to be greeted
    by a dead board. So there have been cases, where the CD/DVD is
    "death in a box". It is one reason, to always read the threads on
    vip.asus.com or reviews on Newegg, to see if there are any known
    serious issues. When I saw the "bad checksum", I was like "hey,
    wait a minute - I don't think I'm going to do that...". And that is
    because of the history involved, of loopy BIOS files.

    Paul
     
    Paul, Apr 30, 2010
    #9
  10. Daniel Prince

    Jan Alter Guest

    If the mb is under warranty get in touch with Asus support. As suggested by
    Paul and others the DVD disk most likely has installed a bios is earlier
    than the installed cpu or a corrupted bios file that is leaving the board in
    pergatory. If the mb is under warranty Asus should warmly ask for you to
    send the mb back to them for reflashing.
    If the mb is out of warranty then you may be able to replace the bios chip
    yourself with a re-imaged one if the chip is removeable
     
    Jan Alter, Apr 30, 2010
    #10
  11. I think the file is M4N78PRO.ROM 6/22/2009 1:03 AM. I can not tell
    from that what the version is unless it is 0609 or 0103.

    The end of the file is:

    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
    00 00 00 00 00 00 00 00 00 00 00 00 24 42 43 53 ............$BCS
    E0 63 CA B6 00 00 00 00 00 00 00 00 00 00 00 00 àcʶ............
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
    E9 10 32 00 00 00 00 00 00 00 00 00 00 00 00 00 é.2.............
    00 00 00 00 00 00 00 00 00 00 E9 D3 00 00 00 00 ..........éÓ....
    24 49 49 4D 3C 14 06 00 00 00 00 00 00 00 00 00 $IIM<...........
    00 00 00 00 00 00 00 00 00 00 00 00 24 42 54 53 ............$BTS
    41 31 31 39 31 30 30 31 00 00 00 00 00 00 00 00 A1191001........
    00 08 FE FF 00 08 FE FF 00 00 00 00 00 00 00 00 ..þÿ..þÿ........
    EA AA FF 00 F0 30 36 2F 31 30 2F 30 39 00 FC 00 êªÿ.ð06/10/09.ü.

    Can you tell what the BIOS version is?
     
    Daniel Prince, Apr 30, 2010
    #11
  12. Daniel Prince

    Paul Guest

    Sorry. If I'd thought about it at the time, I should have downloaded
    one and figured out what offset in the file to look at.

    I downloaded M4N78 PRO BIOS 1111 (the latest one), unzipped it
    and got a 1024KB file. With a hex editor, I went to offset
    0x7FF30 (about half way along) and found this.

    $ASUSAMI$ M4N78 1111 01/06/2010-15:55:06 MCP78U PRO ASUS rombuild419

    I would search for "ASUSAMI" and see what is next to it.

    Paul
     
    Paul, Apr 30, 2010
    #12
  13. This is what I found:

    $ASUSAMI$ M4N78 0903 06/10/2009-14:55:04 MCP78U PRO ASUS rombuild418

    Version 0903 should be new enough for his CPU.
     
    Daniel Prince, Apr 30, 2010
    #13
  14. Daniel Prince

    Paul Guest

    So now the question is, whether it has a working boot block
    in the BIOS flash chip or not. If it asks for the DVD, or
    manages to write something on the screen, there is hope.
    Otherwise, somebody is going to have to reflash it for
    you.

    I'd try clearing the CMOS, if you haven't tried that already.
    Turn off all power (unplug), before following any instructions
    in the manual for using the clear CMOS jumper or interface.

    Paul
     
    Paul, Apr 30, 2010
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.