BIOS Flash Trashed?? Seemed to Flash OK, But Business System Down!

Discussion in 'MSI' started by Harkhof, Feb 13, 2006.

  1. Harkhof

    Harkhof Guest

    In anticipation of a newly ordered 4400+ x2, I flashed the Bios of my MSI
    K8N NEO2 Plat (MS 7025) to the latest BIOS version 1.B. Since I don't have a
    floppy drive in that machine, I used the MSI live update utility and chose
    to allow the MSI windows flash utility.

    Everything seemed to go OK, but when the system restarted, it seemed to go
    through POST OK until it gets to the CDROM boot option (press any key to...)
    and then the screen remains blank (with the power light green rather than
    yellow, as though the monitor were still receiving a signal). At this point,
    there is no further drive or boot activity.

    Not wanting to shut the system down, I waited about an hour for the system
    to come up, which of course, didn't happen. I then reset the system and
    pressed DEL to enter the BIOS. The BIOS seems to have been succesfully
    flashed to version 1.B.

    I changed a few of the settings (halt on no errors, boot orders, etc.), all
    with the same result. I also chose the "optimized settings", still no luck.
    The only difference, since I changed the boot order is that the system POST
    now ends at the DMI Pool check, screen again goes blank, light remains
    green.

    Also, from another machine, I checked to see to see if it showed up on the
    network on the off chance that perhaps the machine was "booting behind the
    curtain", but it wasn't in the network.

    I need this machine to be up and running fast, as it is my main business
    machine. I have flashed many BIOS and never had an issue until now (albeit
    all with a floppy flash util from DOS).

    The only possible "clue" that may be of use is a message that flies by
    during POST (only after I press DEL to enter BIOS) so fast that I had to use
    a digital camera to take an image of it. It reads (and I quote the poor
    english used in the message):

    Warning:
    "Have Option ROM cannot be invoke (Vendor ID:10DEh, Deivce ID:00DFh)"

    Again, this is an exact quote, including spelling errors. I think this may
    be related somehow to my promise TX133 controller, which I do NOT use to
    boot, only to accomodate data drives. It appears just before the TX133
    POSTs.

    I have tried:
    Changing various BIOS settings
    Reverting to optimized settings
    Clearing the CMOS via the JBat jumper
    Booting with the XP SP2 CD to attempt a repair (gets to "setup is inspecting
    your computer" and reboots after a few seconds).

    Since I tried booting with the XP CD, I can now no longer get to the BIOS,
    not even after clearing it via the MB jumper, after which, the expected
    checksum error occurred. Pressing F1 to continue produced the same results
    as above.

    The strange thing is that the BIOS seemed to "take" (since I was, at least
    initially able to enter the bios, and the version was the one flashed to...)

    I'm out of ideas. Any suggestions?

    Thanks for all help!

    Hark

    MSI MS7025
    1 ghz (2x512) Corsair value RAM (running at dual channel)
     
    Harkhof, Feb 13, 2006
    #1
    1. Advertisements

  2. Harkhof

    mxh Guest

    Addendum:
    Also will not boot from USB floppy. Floppy is detected, attempts
    to boot from floppy after DMI verification, floppy drive lights up and
    grinds for 5 secs, computer sits and does nothing, only this time, the text
    stays on screen. I've tried 4 different boot disks, including win98,
    win98SE, ME and an XP boot disk, all with the same result. Trying the same
    floppy drive and same boot disk on other machines results in successful
    boot.

    Hark
     
    mxh, Feb 13, 2006
    #2
    1. Advertisements

  3. Harkhof

    mxh Guest

    Addendum 2:
    Setting the CMOS clear jumper to "clear", removing battery, waiting 5 mins,
    re-inserting battery and re-positioning CMOS (JBatt) jumper to normal gets
    the system started. However, going through BIOS to restablish simple
    settings results in the same problem. Guess I'll try one setting at a time,
    reboot, etc.

    Thaqnks,
    Hark
     
    mxh, Feb 13, 2006
    #3
  4. Harkhof

    Harkhof Guest

    Hmm, I thought I had sent this follow up, but it doesn't appear here. if
    this is posted twice, please disregard.

    OK, it turns out (if anyone is interested, since this seems to be a
    monlogue) that it is my Promise Ultra 133TX controller that is causing the
    issues, or rather, it seems, the bios of the controller. I have (had) to
    drives set as masters, each to its own channel on the controller. If I pull
    the data cables off of the controller, it boots fine (it doesn't load the
    controller bios if there are no drives attached). I've tried everything to
    make the controller work with MSI's 1.B bios, but no go.

    I changed the drives around, I tried new cables, I tried just one drive and
    then just the other, I updated the controller BIOS and driver, etc., etc.,
    etc. Nothing seems to work. Fortunately, I ordered a sata drive with the new
    4400+ x2 and today I ordered another one. Time to phase out the ATA drives
    anyway, get rid of all those pesky air blocking ATA cables.

    I'll take this up later with MSI and Promise, but for now I've disconnected
    one of my optical drives from the secondary IDE channel and connected the
    most necessary drive from the controller, so things are now under control
    (heh!).

    Hopefully, my lonely experience will help someone who may find themselves in
    a similar predicament. That is if there really *is* anyone out there...

    Hark
     
    Harkhof, Feb 14, 2006
    #4
  5. Harkhof

    Folk Guest

    Of course. And thanks for following up. It's not just today's
    readers that benefit from your posts but tomorrow's as well.
     
    Folk, Feb 14, 2006
    #5
  6. Harkhof

    bobfrantic

    Joined:
    Oct 22, 2006
    Messages:
    1
    Likes Received:
    0
    I too have trouble with "WARNING: HAVE OPTION ROM CAN NOT BE INVOKE"

    I have same issue with same pci/ide controller Promise TX133 and with a SiS Raid/IDE pci controller card. I get this error WARNING: HAVE OPTION ROM CAN NOT BE INVOKED when booting and my system will then stop responding during the copying of files for the installation of XP. I have a Mach Speed PT88BSPRO-EC MB with a Celeron D 3.20 gig socket 775, 2 gigs dual channel ram, agp 8x video. 1-Sata 120 gig 1.5 gb/s WD hd, primary master and slave are WD ata 133 IDE hd's, and i put 4 of the same drives on the pci/ide controller card. I was able to install XP with just one DVDrom, The sata drive, as only drives connected. I connected the primary master and slave and things still worked. Then I put the Promise TX133 card for the other four drives in and it started with the trouble again. Has anyone who has had this trouble found a fix, or a bios update? Mach Speed said they couldn't troubleshoot this any further saying it was my problem. I never had this trouble before getting their board. Help please...... its very irritating to say the least. :(
    bob(very)frantic

    QUOTE=Folk]On Mon, 13 Feb 2006 23:04:55 -0600, "Harkhof" <> wrote:


    >Hopefully, my lonely experience will help someone who may find themselves in
    >a similar predicament. That is if there really *is* anyone out there...


    Of course. And thanks for following up. It's not just today's
    readers that benefit from your posts but tomorrow's as well.[/QUOTE]
     
    bobfrantic, Oct 22, 2006
    #6
  7. Harkhof

    mosi

    Joined:
    Nov 1, 2006
    Messages:
    1
    Likes Received:
    0
    Promise TX2200/Tx23000 boot problems

    Hello.

    I have encountered the same problems with my Msi k8n neo platinum main board with a promise TX2200/TX2300 card installed with 2 S-ATA disks in raid 0 attached to the card.
    I upgraded the bios on the main board to the newest bios at the time of writing this (v.2.1). This made it impossible to boot from the promise card anymore and I got this error just before you enter the bios setup that says :
    "Have option ROM can not be invoke (Vendor ID : 10DEh, Device ID : 00DFh)"

    To solve the problem I whent through the diffrent bios versions available from MSI and found out that version 1.7 worked. First time I tryed with this update the machine would not boot, so I cleared CMOS data and than all worked just fine.
    Now the promise card is found and my system boots on my raid disks once again :)

    Don't think I will upgrade the bios on this system anymore, to much work... :)

    Morten
     
    mosi, Nov 1, 2006
    #7
  8. Harkhof

    Protonus

    Joined:
    Jan 9, 2009
    Messages:
    1
    Likes Received:
    0
    I fixed this on my MSI board by restoring optimized defaults in the BIOS. Prior to that I could not for the life of me clear the error message. Just a heads up for anyone else that stumbles on this from 'teh googles.
     
    Protonus, Jan 9, 2009
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.